Lawson: Configuring and Administering Process Automation Training Workbook

Infor Lawson
April 27, 2016
Course code: 01_0121010_IEN0279_LSU
Legal notice
Copyright © 2016 Infor. All rights reserved.

Important Notices
The material contained in this publication (including any supplementary information) constitutes and contains confidential and proprietary information of Infor.

By gaining access to the attached, you acknowledge and agree that the material (including any modification, translation or adaptation of the material) and all copyright, trade secrets and all other right, title and interest therein, are the sole property of Infor and that you shall not gain right, title or interest in the material (including any modification, translation or adaptation of the material) by virtue of your review thereof other than the non-exclusive right to use the material solely in connection with and the furtherance of your license and use of software made available to your company from Infor pursuant to a separate agreement, the terms of which separate agreement shall govern your use of this material and all supplemental related materials ("Purpose").

In addition, by accessing the enclosed material, you acknowledge and agree that you are required to maintain such material in strict confidence and that your use of such material is limited to the Purpose described above. Although Infor has taken due care to ensure that the material included in this publication is accurate and complete, Infor cannot warrant that the information contained in this publication is complete, does not contain typographical or other errors, or will meet your specific requirements. As such, Infor does not assume and hereby disclaims all liability, consequential or otherwise, for any loss or damage to any person or entity which is caused by or relates to errors or omissions in this publication (including any supplementary information), whether such errors or omissions result from negligence, accident or any other cause.

Without limitation, U.S. export control laws and other applicable export and import laws govern your use of this material and you will neither export or re-export, directly or indirectly, this material nor any related materials or supplemental information in violation of such laws, or use such materials for any purpose prohibited by such laws.

Trademark Acknowledgements
The word and design marks set forth herein are trademarks and/or registered trademarks of Infor and/or related affiliates and subsidiaries. All rights reserved. All other company, product, trade, or service names referenced may be registered trademarks or trademarks of their respective owners.
# Table of contents

About this workbook .............................................................................................................. 5  
Course overview ................................................................................................................ 6  
Course description and agenda ......................................................................................... 7  

**Lesson 1: Infor Process Automation (IPA) overview** ......................................................... 11  
  Infor Process Automation (IPA) introduction ..................................................................... 12  
  Integration with other systems ......................................................................................... 13  
  Components ......................................................................................................................... 14  
  Architecture ......................................................................................................................... 15  
  Presentation interfaces ......................................................................................................... 17  
  Check your understanding ................................................................................................. 18  

**Lesson 2: Activity nodes** ................................................................................................ 19  
  About activity nodes .......................................................................................................... 20  
  Common activity nodes ...................................................................................................... 21  
  Control activity nodes ........................................................................................................ 22  
  Data activity nodes ............................................................................................................ 23  
  User Interaction activity nodes ......................................................................................... 25  
  Notification activity nodes ............................................................................................... 26  
  Queue activity nodes ......................................................................................................... 27  
  Web/XML/JSON activity nodes ........................................................................................ 28  
  Infor Lawson activity nodes ............................................................................................. 29  
  Infor ION activity nodes .................................................................................................... 30  
  M3 activity nodes ............................................................................................................... 31  
  Check your understanding ................................................................................................. 32  

**Lesson 3: Infor Process Designer** .................................................................................. 35  
  Infor Process Designer views ........................................................................................... 36  
  Preferences .......................................................................................................................... 37  
  Variables .............................................................................................................................. 40  
  Build a basic email process ............................................................................................... 42  
  Check your understanding ................................................................................................. 45  

**Lesson 4: Infor Landmark Transaction process** ............................................................... 47  
  Build a process using Landmark Transaction node ......................................................... 48  
  Check your understanding ................................................................................................. 53  

**Lesson 5: System configuration** .................................................................................... 54  
  Configuration sets .............................................................................................................. 55  
  Check your understanding ................................................................................................. 58  

**Lesson 6: Infor Lawson query and resource update process** .......................................... 59  
  Build a process using the Resource Update and Infor Lawson Query activity nodes ........ 60  
  Check your understanding ................................................................................................. 68  

**Lesson 7: User configuration** ........................................................................................ 69  
  Set up process users .......................................................................................................... 70  
  Proxy management ............................................................................................................ 73  
  Check your understanding ................................................................................................. 76  

**Lesson 8: Requisition and approval process** ................................................................. 77  
  Requisition approval process ............................................................................................ 78  
  Additional configuration ...................................................................................................... 87  
  Check your understanding ................................................................................................. 88  

**Lesson 9: Enable services** ............................................................................................. 89  
  Service, triggers and workunits .......................................................................................... 90  
  Service enablement ............................................................................................................ 92  
  Check your understanding ................................................................................................. 96  

**Lesson 10: Trigger process** ........................................................................................... 98  
  Using the Trigger node ...................................................................................................... 99
Lesson 23: Java Script Object Notation (JSON) ................................................................. 216
JSON activity node ........................................................................................................ 217
Lesson 22: For Each process ......................................................................................... 209
For Each activity node .................................................................................................. 210
Build a process to configure a loop for an XML element ............................................ 211
Check your understanding ......................................................................................... 215
Lesson 21: XML process .............................................................................................. 200
XML activity node ........................................................................................................ 201
Build an XML process ............................................................................................... 202
Check your understanding ......................................................................................... 208
Lesson 20: Infor ION .................................................................................................... 194
ION Connect overview ............................................................................................... 195
ION channels and receivers ....................................................................................... 196
ION connection setup ............................................................................................... 197
ION Pulse integration ............................................................................................... 198
Check your understanding ......................................................................................... 199
Lesson 19: File channels ............................................................................................. 183
Channels and receivers .............................................................................................. 184
Properties that affect file channels ......................................................................... 185
File channels process .............................................................................................. 186
Check your understanding ....................................................................................... 193
Lesson 18: Data iteration and file access ..................................................................... 175
Data Iterator activity node ....................................................................................... 176
File Access activity node ......................................................................................... 177
Build a Data Iterator and File Access process ......................................................... 178
Check your understanding ....................................................................................... 182
Lesson 17: System command and FTP ........................................................................ 167
Define system command LSF configuration ......................................................... 168
Define file transfer LSF configuration .................................................................. 169
Build an LSF system command and FTP process .................................................. 170
Check your understanding ....................................................................................... 174
Lesson 16: SQL query and update process ................................................................. 153
Connect to an SQL database .................................................................................... 154
SQL Query and SQL Transaction activity nodes .................................................... 157
Build an SQL query and update process ................................................................ 160
Check your understanding ....................................................................................... 166
Lesson 15: Scheduling ............................................................................................... 146
Schedule form ........................................................................................................... 147
My Actions form ....................................................................................................... 148
Schedule a process ................................................................................................... 149
Check your understanding ....................................................................................... 152
Lesson 14: Infor Landmark process ............................................................................. 138
Delivered Infor Landmark processes ...................................................................... 139
Modify a delivered Infor Landmark process ............................................................ 140
Check your understanding ....................................................................................... 145
Lesson 13: User action process .................................................................................. 123
HRTM User Action Classic HR application type .................................................... 124
HRTM User Action Infor Lawson HR and TM Application Type .............................. 130
Check your understanding ....................................................................................... 137
Lesson 12: Web run process ...................................................................................... 117
Building a Web run process ..................................................................................... 118
Check your understanding ....................................................................................... 122
Lesson 11: Infor Lawson query process ..................................................................... 106
Build a process using the Infor Lawson Query node ............................................... 107
Check your understanding ....................................................................................... 116
Lesson 10: File channels ............................................................................................ 98
Channels and receivers ............................................................................................. 99
Properties that affect file channels ......................................................................... 100
File channels process ............................................................................................. 101
Check your understanding ....................................................................................... 105
Lesson 9: Infor ION ..................................................................................................... 92
ION Connect overview ............................................................................................ 93
ION channels and receivers .................................................................................... 94
ION connection setup ............................................................................................ 95
ION Pulse integration .............................................................................................. 96
Check your understanding ....................................................................................... 99
Lesson 8: SQL query and update process .................................................................. 85
Connect to an SQL database .................................................................................... 86
SQL Query and SQL Transaction activity nodes .................................................... 89
Build an SQL query and update process ................................................................ 92
Check your understanding ....................................................................................... 97
Lesson 7: System command and FTP ....................................................................... 78
Define system command LSF configuration ........................................................... 79
Define file transfer LSF configuration .................................................................. 80
Build an LSF system command and FTP process .................................................. 81
Check your understanding ....................................................................................... 84
Lesson 6: Data iteration and file access ..................................................................... 71
Data Iterator activity node ....................................................................................... 72
File Access activity node ......................................................................................... 73
Build a Data Iterator and File Access process ......................................................... 74
Check your understanding ....................................................................................... 78
Lesson 5: Relationships ............................................................................................... 64
Relational activity node ............................................................................................ 65
Build a relational process ......................................................................................... 66
Check your understanding ....................................................................................... 71
Lesson 4: File channels .............................................................................................. 57
Channels and receivers ............................................................................................ 58
Properties that affect file channels ......................................................................... 59
File channels process ............................................................................................. 60
Check your understanding ....................................................................................... 64
Lesson 3: Infor ION ..................................................................................................... 50
ION Connect overview ............................................................................................ 51
ION channels and receivers .................................................................................... 52
ION connection setup ............................................................................................ 53
ION Pulse integration .............................................................................................. 54
Check your understanding ....................................................................................... 58
Lesson 2: SQL query and update process .................................................................. 43
Connect to an SQL database .................................................................................... 44
SQL Query and SQL Transaction activity nodes .................................................... 47
Build an SQL query and update process ................................................................ 50
Check your understanding ....................................................................................... 54
Lesson 1: File channels .............................................................................................. 36
Channels and receivers ............................................................................................ 37
Properties that affect file channels ......................................................................... 38
File channels process ............................................................................................. 39
Check your understanding ....................................................................................... 43
Check your understanding ....................................................................................... 105
<table>
<thead>
<tr>
<th>Lesson</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>24</td>
<td>Web services</td>
<td>221</td>
</tr>
<tr>
<td>25</td>
<td>Wait node</td>
<td>229</td>
</tr>
<tr>
<td>26</td>
<td>Encrypt and decrypt</td>
<td>233</td>
</tr>
<tr>
<td>27</td>
<td>IPA administration</td>
<td>236</td>
</tr>
</tbody>
</table>

Appendices

- Appendix A: Understanding dates | 249
- Appendix B: Data iterator – Landmark transaction example | 251
- Appendix C: Data iterator – Infor Lawson Resource Transaction example | 253
- Appendix D: Data iterator – Infor Lawson example | 255
- Appendix E: Custom activities | 257
- Appendix F: Infor Cloverleaf | 261
- Appendix G: Java Messaging Service (JMS) | 262
About this workbook

Welcome to this Infor Education course! We hope you will find this learning experience enjoyable and instructive. This Training Workbook is designed to support the following forms of learning:

- Classroom instructor-led training
- Virtual instructor-led training
- Self-directed learning

This Training Workbook is not intended for use as a product user guide.

Self-directed learning (SDL)

If this course is eligible for self-directed learning, demos and exercises throughout this Training Workbook will be hyperlinked to Demonstration/Let Me Try simulations that allow you to view and practice the execution of the demo or exercise in a simulated training environment.

Activity data

You will be asked to complete some practice exercises during this course. Step-by-step instructions are provided in this guide to assist you with completing the exercises. Where necessary, data columns are included for your reference.

Your instructor will provide more information on systems used in class, including server addresses, login IDs, and passwords.

Symbols used in this workbook

Hands-on exercise (“Exercise”)  For your reference
Instructor demonstration (“Demo”)  Your notes
Can be used for either “Scenario” or “Discussion”  Question
Note  Answer
Course overview

Reference materials
Infor Lawson reference materials are available from the following locations:
- Infor Lawson Help menu
- Infor Xtreme®

Course duration
40 hours

Learning objectives
Upon completion of this course, you will be able to:
- Describe Infor Process Automation and its architecture.
- Describe the purpose of each activity node.
- Describe the Infor Process Designer functionality.
- Explain how to create and run a basic email process.
- Explain how to build processes using various activity nodes.
- Describe how to run processes.
- Describe how to configure Infor Process Automation users.
- Explain how to enable services.
- Describe how to create configuration sets.
- Explain how to administer Infor Process Automation.

Audience
- Customer User
- Pre-Sales Consultant
- Business Consultant
- Technical Consultant
- Support
- System Administrator

System requirements
- Infor Process Automation Training Environment
Course description and agenda

This course provides hands-on experience using Infor Process Server, Infor Process Designer, and Infor Rich Client to monitor and maintain Infor Process Automation (IPA), create and modify business processes, and access routed work in the Inbasket. This training is for versions: 10 and all previous versions. Previous course name/code: Infor: Using Process Automation/01_0141000_IEN0003.

Prerequisite knowledge
To optimize your learning experience, Infor recommends that you have the following knowledge prior to attending this course:
- Knowledge of Infor Lawson applications

<table>
<thead>
<tr>
<th>Lesson</th>
<th>Lesson title</th>
<th>Learning objectives</th>
<th>Day</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Infor Process Automation overview</td>
<td>Review course expectations.</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Activity nodes</td>
<td>Define Infor Process Automation (IPA) and how it integrates with other systems.</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Explain the IPA architecture.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Recognize the two key components of IPA.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Match each presentation option available for IPA with its description.</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Infor Process Designer</td>
<td>Identify the available views of Infor Process Designer.</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Explain how to use the Infor Process Designer interface.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Explain how to set Infor Process Designer preferences.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describe the purpose of using variables.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Explain how to build a basic email process.</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Infor Landmark transaction process</td>
<td>Describe how to build a process using the Landmark Transaction node to do a query in Infor Landmark.</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>System configuration</td>
<td>Describe a configuration set.</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Match each configuration set type with its description.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Identify the configuration information needed to connect to the Infor Lawson environment.</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Infor Lawson query and resource update process</td>
<td>Describe how to build a process using the Resource Update and Infor Lawson Query activity nodes.</td>
<td>1/2</td>
</tr>
<tr>
<td>7</td>
<td>User configuration</td>
<td>Explain how to set up process users.</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Describe proxy management</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Requisition and approval process</td>
<td>Explain how to build a process flow that routes requisitions for approval.</td>
<td>2</td>
</tr>
<tr>
<td>Lesson</td>
<td>Lesson title</td>
<td>Learning objectives</td>
<td>Day</td>
</tr>
<tr>
<td>--------</td>
<td>------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----</td>
</tr>
</tbody>
</table>
| 9      | Enable services                    | - Describe the functionality of services, triggers, and workunits.  
- Explain how to enable a service.  
- Explain how to initiate and test a process.                                                                                                              | 2   |
| 10     | Trigger process                    | - Describe how to trigger a new process within a process.                                                                                                                                                              | 2   |
| 11     | Infor Lawson query process         | - Describe how to build a process using the Infor Lawson Query node.                                                                                                                                                   | 3   |
| 12     | Web run process                    | - Describe how to build a Web run process.                                                                                                                                                                              | 3   |
| 13     | User action process                | - Explain how to create a process that routes work to an employee’s supervisor.                                                                                                                                       | 3   |
| 14     | Infor Landmark process             | - Recognize the location of delivered Infor Landmark processes.  
- Explain how to modify a delivered Landmark process.                                                                                                                                                                | 3   |
| 15     | Scheduling                         | - Identify the forms and features of the scheduler.  
- Explain how to schedule a process.                                                                                                                                                                                    | 3   |
| 16     | SQL query and update process       | - Describe how to configure an SQL connection.  
- Explain how to build an SQL query and update process.                                                                                                                                                                 | 4   |
| 17     | System command and FTP             | - Describe how to set up and execute a system command                                                                                                                                                                  | 4   |
| 18     | Data iterator and file access      | - Explain how to build a process using the Data Iterator and File Access activity nodes.                                                                                                                                 | 4   |
| 19     | File channels                      | - Describe the purpose of channels.  
- Explain how to set up a file channel and receiver for a local file.                                                                                                                                                 | 4   |
| 20     | Infor ION                           | - Describe the functionality of Intelligent Open Network (ION) Connect.  
- Identify a Business Object Document’s function.                                                                                                                                                                     | 4   |
| 21     | XML process                        | - Identify XML activity node properties.  
- Define how to set up the XML activity node to output Infor Lawson data to XML.                                                                                                                                       | 5   |
| 22     | For Each process                   | - Recognize the four processing options available for a loop.  
- Describe how to set up the For Each node to parse an XML document.                                                                                                                                                 | 5   |
<p>| 23     | Java Script Object Notation (JSON) | - Explain how to build a process to convert XML to JSON.                                                                                                                                                                | 5   |
| 24     | Web services                       | - Describe how IPA works with web services.                                                                                                                                                                              | 5   |
| 25     | Wait node                          | - Describe the functionality of the Wait activity node.                                                                                                                                                                 | 5   |</p>
<table>
<thead>
<tr>
<th>Lesson</th>
<th>Lesson title</th>
<th>Learning objectives</th>
<th>Day</th>
</tr>
</thead>
<tbody>
<tr>
<td>26</td>
<td>Encrypt and decrypt</td>
<td>• Describe the functionality of the Encrypt and Decrypt activity nodes.</td>
<td>5</td>
</tr>
<tr>
<td>27</td>
<td>IPA administration</td>
<td>• Identify tasks associated with administering the IPA server.</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Describe the system administration section of the Process Service Administrator.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Describe IPA settings in the grid.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Explain how to start or stop Infor Process Automation.</td>
<td></td>
</tr>
<tr>
<td>Course summary</td>
<td></td>
<td>• Debrief course.</td>
<td>5</td>
</tr>
</tbody>
</table>

**Appendices**

There are appendices at the end of this Training Workbook that you may find useful. They contain information that is not part of the instructional content of this course but provide additional related reference information.

<table>
<thead>
<tr>
<th>Appendix</th>
<th>Appendix title</th>
<th>Content description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appendix A</td>
<td>Understanding dates</td>
<td>This appendix is a scenario that demonstrates how to modify dates in a query.</td>
</tr>
<tr>
<td>Appendix B</td>
<td>Data Iterator for Infor Landmark</td>
<td>This appendix is a scenario to parse a CSV file to update actor roles.</td>
</tr>
<tr>
<td>Appendix C</td>
<td>Data Iterator Infor Lawson Resource</td>
<td>This appendix is a scenario to parse a CSV file to update resource groups.</td>
</tr>
<tr>
<td>Appendix D</td>
<td>Data Iterator Infor Lawson</td>
<td>This appendix is a scenario to parse a CSV file to create a vendor.</td>
</tr>
<tr>
<td>Appendix E</td>
<td>Custom activities</td>
<td>This appendix is a scenario to use a custom activity to convert ASCII to EBCDIC.</td>
</tr>
<tr>
<td>Appendix F</td>
<td>Infor Cloverleaf</td>
<td>This appendix includes information on the Infor Cloverleaf activity node.</td>
</tr>
<tr>
<td>Appendix G</td>
<td>Java Messaging Service (JMS)</td>
<td>This appendix explains how to set up JMS inbound and outbound messaging.</td>
</tr>
</tbody>
</table>
Lesson 1: Infor Process Automation (IPA) overview

Estimated time
30 minutes

Learning objectives
After completing this lesson, you will be able to:

- Define Infor Process Automation (IPA) and how it integrates with other systems.
- Explain the IPA architecture.
- Recognize the two key components of IPA.
- Match each presentation option available for IPA with its description.

Topics
- Infor Process Automation (IPA) introduction
- Integration with other systems
- Components
- Architecture
- Presentation interfaces
- Check your understanding
Infor Process Automation (IPA) introduction

IPA is a tool used to support business process modeling (BPM). IPA can automate, control, and measure business processes that span:

- Systems to systems
  - Interface/connecting non-Infor applications to Infor applications
- People to systems
- People to people
  - Multi-step, multi-level, human review, and approval workflow

To illustrate the value of IPA, we can use an example from the human resources function. Let’s say the Human Resource (HR) generalists in your organization must perform a long and complex set of tasks (called a procedure) every time a new employee is set up in the system. It makes sense to automate this process to ensure that all steps in the procedure are performed accurately and in the correct sequence.

As you progress through this first lesson, you will gain a better understanding of the IPA architecture and how the product works.
Integration with other systems

IPA runs on Infor Landmark technology platform and is delivered with every Infor Landmark-built application. It is considered an integral component of Infor Talent Management (TM). IPA connects to multiple systems and stores all the configurations in a database for easy maintenance.

This diagram illustrates the systems to which IPA can connect and integrate with both internal and external systems within the Infor Lawson/Landmark environment:
Components

IPA has two key components:

- Infor Process Designer (client machine)
- Infor Process Server (server-side)

**Infor Process Designer**

Infor Process Designer (referred to as the Process Designer) is a desktop point-and-click tool for creating processes. In this context, a process refers to the extensible markup language (XML) file of instructions needed to perform the process.

Any user at your site who is creating processes will need to have the Process Designer tool installed on their desktop machines. Typical users include business analysts, power users, and software developers.

The tool allows users to graphically define a process. For example, a process may transfer information or work from one user to another until the work is completed. **Note:** Not all processes involve user information; some pertain to systems or workflows.

**Infor Process Server**

The Infor Process Server (referred to as the Process Server) allows menus and other tools for system administrators to configure, launch, maintain, and troubleshoot processes. These tools are accessed via the Infor Landmark technology.

Process files have the extension .lpd, which are XML files in a proprietary format that the Process Designer and Process Server can read.
Architecture

IPA is associated with an Infor Landmark Technology release and is loaded with Infor Landmark Technology.

The following diagram shows the high level architecture of IPA:

![Architectural diagram]

**Key components**

Architectural characteristics of the key components of IPA include:

- Infor Process Designer must be associated with the specific Infor Landmark Technology release.

**Processes and multiple data areas**

Infor Grid technology supports high scalability for IPA processes and data.

- Able to run multiple instance of Process Server which allows for multiple data areas
- Process Server instance can be dedicated to a specific data area
- Process Server instances can be independently stopped/started

The following diagram shows different ways in which data areas can be configured and used:
Presentation interfaces

You can access IPA functionality from presentation interfaces associated with these IPA components:

- Infor Rich Client
  - Process Server Administrator
- Inbasket
- Infor Process Designer

Let's take a closer look at each.

**Infor Rich Client**

Infor Rich Client is a web-deployable client application where you may access Infor Landmark applications. Infor Landmark applications can trigger a process to be initiated.

The Infor Rich Client includes the Process Server Administrator for managing and monitoring processes.

**Process Server Administrator**

The Process Server Administrator is available through the Infor Rich Client and can be controlled through Infor Landmark security. The Process Server Administrator can also be accessed via a web URL.

The Process Server Administrator provides menus and tools to configure, manage, schedule, and monitor processes. This area is usually accessible by the IPA system administrator or anyone who would be responsible to manage or monitor processes.

**Inbasket**

Within a process, information can be routed to users to take action. Information can be passed to one user, based on the roles a user is assigned, the HR reporting structure or could be routed to multiple users.

Routed work is sent via the Inbasket. The Inbasket can be in an Infor Landmark application, Infor Lawson application, Infor Smart Office, M3, Infor Ming.le, accessed via a web url or through mobile applications such as tablet or phone.

**Infor Process Designer**

Infor Process Designer allows user to create an electronic process that moves work from defined activity to defined activity. This process is called a process design. The Infor Process Designer is a client application that is loaded for anyone who is responsible for creating or modifying process designs.
Check your understanding

Infor Process Automation (IPA) runs on the ___________ platform.

a) IBM®
b) WebSphere®
c) Infor Landmark

Identify which processes IPA can automate, control, and measure. Select all that apply.

a) Systems to systems
b) People to systems
c) People to people
d) Multi-step, multi-level, human review, and approval workflow
e) Interface/connecting non-Infor applications to Infor applications

Which two components are part of IPA?

a) Infor Process Designer
b) Infor Rich Client
c) Infor Process Server
d) Configuration Console

With which three interfaces can you access IPA?

a) Configuration Console > Security Class
b) Infor Rich Client > Process Server Administrator
c) Inbasket
d) Infor Process Designer

Routed work is sent to which interface?

a) My Personalization
b) Inbasket
c) Infor Process Designer
Lesson 2: Activity nodes

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:

- Recognize the purpose and use of each activity node.

Topics
- About activity nodes
- Common activity nodes
- Control activity nodes
- Data activity nodes
- User Interaction activity nodes
- Notification activity nodes
- Queue activity nodes
- Web/XML/JSON activity nodes
- Infor Lawson activity nodes
- Infor ION activity nodes
- M3 activity nodes
- Check your understanding
About activity nodes

One of the strengths of IPA is its flexibility in allowing customers to create processes, which are, in effect, custom applications. When you build a process, you use an activity node to represent each step in the process. Activity nodes are visual cues that help you to build a process in the Infor Process Designer, but more importantly are the functional procedures that activate in sequence as the process runs.

Each activity node performs a special function within a process.

Activity nodes are grouped into the following categories:

- Common activity nodes
- Control activity nodes
- Data activity nodes
- User interaction activity nodes
- Notification activity nodes
- Queue activity nodes
- Web/XML/JSON activity nodes
- Infor Lawson activity nodes
- ION activity nodes
- M3 activity nodes

In this lesson you are introduced to the types of activity nodes within each category. Throughout this workbook, you will see many of these activity nodes again and have the opportunity to use them when designing a process as part of a hands-on exercise.
Common activity nodes

Common activity nodes are the nodes that are used in every process. All processes have Start and End nodes which appear automatically on the Process Designer canvas when you begin a new process.

The table below provides an overview of the Common activity nodes:

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
</table>
| Start | ![Start icon](image) | • Begins the business automation process  
• Defines variables to be used throughout the process. | • Automatically displays when creating a new process  
• Use when beginning a process |
| End   | ![End icon](image) | Ends the business automation process.            | • Automatically displays when creating a new process  
• Use to end a process          |
Control activity nodes

The table below provides an overview of the Control activity nodes:

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign</td>
<td><img src="image" alt="Assign Icon" /></td>
<td>Assigns values to a variable that is included in the process</td>
<td>Use to assign a variable</td>
</tr>
<tr>
<td>Branch</td>
<td><img src="image" alt="Branch Icon" /></td>
<td>Places “if-then-else” conditions into a process</td>
<td>Use to make a decision on how to proceed in a flow</td>
</tr>
<tr>
<td>Custom Activity</td>
<td><img src="image" alt="Custom Activity Icon" /></td>
<td>Provides the ability to execute activities</td>
<td>Use to define input variables as the parameters for custom activity</td>
</tr>
<tr>
<td>Return</td>
<td><img src="image" alt="Return Icon" /></td>
<td>Returns connector return data to the connector that initiated a business process</td>
<td>Use to return data to the Process Automation server</td>
</tr>
<tr>
<td>System Command</td>
<td><img src="image" alt="System Command Icon" /></td>
<td>Provides the capability to execute command line functions on the server on which the server is running</td>
<td>Use to execute a command on the server within the business process</td>
</tr>
<tr>
<td>Wait</td>
<td><img src="image" alt="Wait Icon" /></td>
<td>Allows you to add a wait time to a process</td>
<td>Use in situations where it is predictable that a process is not able to process during a specific timeframe</td>
</tr>
<tr>
<td>Trigger</td>
<td><img src="image" alt="Trigger Icon" /></td>
<td>Enables you to initiate an additional process either by process name or by service name; can also start other processes from the current process</td>
<td>Use to start sub-processes within the larger process you are creating</td>
</tr>
</tbody>
</table>
## Data activity nodes

The table below provides an overview of the Data activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Iterator</td>
<td><img src="image1" alt="Data Iterator Icon" /></td>
<td>Provides the capability to iteratively read the data in a variable or file</td>
<td>Use to look for specific data or data parameters that can then be used as part of a business process</td>
</tr>
<tr>
<td>Data Transformation</td>
<td><img src="image2" alt="Data Transformation Icon" /></td>
<td>Invokes the IBM WebSphere Transformation Extender product</td>
<td>Use anytime you want to include an IBM WebSphere Transformation Extender map within the business process</td>
</tr>
<tr>
<td>Encrypt</td>
<td><img src="image3" alt="Encrypt Icon" /></td>
<td>Allows you to encrypt data based on the selected encryption protocol such as Pretty Good Privacy (PGP)</td>
<td>Use when you want to send encrypted data</td>
</tr>
<tr>
<td>Decrypt</td>
<td><img src="image4" alt="Decrypt Icon" /></td>
<td>Allows you to decrypt data based on the selected encryption protocol such as PGP</td>
<td>Use when you are receiving data that has been encrypted</td>
</tr>
<tr>
<td>File Access</td>
<td><img src="image5" alt="File Access Icon" /></td>
<td>Provides the ability to read and write data to a file</td>
<td>Use to read and write data to a file, append to a file, list files, delete files, and check if a file exists</td>
</tr>
<tr>
<td>For Each</td>
<td><img src="image6" alt="For Each Icon" /></td>
<td>Allows you to configure a loop, equivalent to a For or While loop in programming, for processing of multiple items</td>
<td>Use to process multiple items</td>
</tr>
<tr>
<td>FTP</td>
<td><img src="image7" alt="FTP Icon" /></td>
<td>Provides a way to transfer files from one machine to another within a process</td>
<td>Use to transfer to or receive from a local or remote machine</td>
</tr>
<tr>
<td>Msg Builder</td>
<td><img src="image8" alt="Msg Builder Icon" /></td>
<td>Collects values for a query using Infor Lawson Query or SQL Query</td>
<td>Use when executing a loop in which multiple values might need to be stored</td>
</tr>
<tr>
<td>SQL Query</td>
<td><img src="image9" alt="SQL Query Icon" /></td>
<td>Enables SQL queries to be built to retrieve data from a database.</td>
<td>Use to create or export a SQL statement</td>
</tr>
<tr>
<td>Activity node name</td>
<td>Icon</td>
<td>Purpose</td>
<td>When to use</td>
</tr>
<tr>
<td>---------------------</td>
<td>------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>SQL Transaction</td>
<td>![icon]</td>
<td>Provides a Java Database Connectivity (JDBC) driver to access any database that is JDBC compliant; node enables speedy updates and changes to the database</td>
<td>Use for any SQL action that does not return a result, set with one or more records</td>
</tr>
</tbody>
</table>
User Interaction activity nodes

User Interaction activity nodes allow a user or users to participate in decision-making or to take action on something via their Inbasket.

The table below provides an overview of the User Interaction activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>HRTM User Action</td>
<td><img src="image" alt="Icon" /></td>
<td>Allows routing actions needed based on the TM or Classic HR Supervisor structure</td>
<td>Use when an employee’s or resource’s supervisor must make a decision</td>
</tr>
<tr>
<td>User Action</td>
<td><img src="image" alt="Icon" /></td>
<td>Sends work to a user’s Inbasket</td>
<td>Use when you want a user to make a decision on something in your business process</td>
</tr>
</tbody>
</table>
Notification activity nodes

Notification activity nodes allow you to create processes that send notifications to a user. The table below provides an overview of the Notification activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Email</td>
<td><img src="image" alt="Email Icon" /></td>
<td>Provides a method to send emails</td>
<td>Use to send emails within a process</td>
</tr>
</tbody>
</table>
## Queue activity nodes

The table below provides an overview of the Queue activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cloverleaf</td>
<td><img src="image" alt="Cloverleaf Icon" /></td>
<td>Provides one-way communication from Infor Lawson to an Infor Cloverleaf-compatible system</td>
<td>Use to send communication from Infor Lawson to Infor Cloverleaf</td>
</tr>
<tr>
<td>Java Message Service (JMS)</td>
<td><img src="image" alt="Java Icon" /></td>
<td>Sends Java Messaging Service (JMS), J2EE- compliant Application Programming Interface (API) messages between two or more clients; receives JMS messages through channel administration</td>
<td>Use to send JMS messages</td>
</tr>
<tr>
<td>WebSphere MQ</td>
<td><img src="image" alt="MQ Icon" /></td>
<td>Allows the sending of messages or data on an IBM WebSphere MQ queue</td>
<td>Use the WebSphere MQ activity node within a process to write a message to a WebSphere MQ queue</td>
</tr>
</tbody>
</table>
## Web/XML/JSON activity nodes

The table below provides an overview of the Web/XML/JSON activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>JSON Builder</td>
<td><img src="image" alt="JSON logo" /></td>
<td>Allows building a light-weight data-interchange format, Java Script Object Notation (JSON)</td>
<td>Use when building a new JSON text or modifying an existing one</td>
</tr>
<tr>
<td>JSON Converter</td>
<td><img src="image" alt="JSON to XML/CSV logo" /></td>
<td>Converts JSON into extensible markup language (XML) or comma-separated values (CSV) and XML or CSV into JSON</td>
<td>Use to convert XML or CSV data into JSON format or to convert JSON data into XML or CSV format</td>
</tr>
<tr>
<td>JSON Parser</td>
<td><img src="image" alt="JSON logo" /></td>
<td>Interprets JSON text that has been received by a process</td>
<td>Use when JSON text needs to be parsed</td>
</tr>
<tr>
<td>XML</td>
<td><img src="image" alt="XML logo" /></td>
<td>Allows XML to be built or parsed within a process</td>
<td>Use the XML node to use XML Schema to interface with programs, customers, and vendors</td>
</tr>
<tr>
<td>Web Run</td>
<td><img src="image" alt="Web logo" /></td>
<td>Allows executing any web-based program</td>
<td>Use the WebRun activity node to execute any web-based program as part of a process</td>
</tr>
<tr>
<td>Web Services</td>
<td><img src="image" alt="Web Services logo" /></td>
<td>Allows the server to call a web service and return the information; makes use of the error connector</td>
<td>Use the Web Services activity node to call a web service; use the returned information in a process</td>
</tr>
</tbody>
</table>
## Infor Lawson activity nodes

The table below provides an overview of the Infor Lawson activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Landmark Transaction</td>
<td>![Icon]</td>
<td>Enables querying and/or performing transactions on Landmark data</td>
<td>Use for querying information associated with Landmark applications</td>
</tr>
<tr>
<td>Query</td>
<td>![Icon]</td>
<td>Enables constructing a call to classic Infor Lawson applications; calls go through the Lawson System Foundation data service</td>
<td>Use for querying information in the classic Infor Lawson applications (Infor Lawson based)</td>
</tr>
<tr>
<td>Transaction</td>
<td>![Icon]</td>
<td>Enables you to perform a transaction to a classic Infor Lawson application form</td>
<td>Use when creating a process to perform a transaction in a classic Infor Lawson application</td>
</tr>
<tr>
<td>Adapter</td>
<td>![Icon]</td>
<td>Allows IPA to invoke and communicate with the Infor Lawson system; performs Transaction Service (AGS) transactions to Infor Lawson applications</td>
<td>Use when multiple Transaction Service (AGS) calls are needed to process input data</td>
</tr>
<tr>
<td>Resource Query</td>
<td>![Icon]</td>
<td>Retrieves resource information</td>
<td>Use to query and retrieve the resource information from the Infor Security LDAP</td>
</tr>
<tr>
<td>Resource Update</td>
<td>![Icon]</td>
<td>Provides a way to add/update/delete users within the Infor Lawson system</td>
<td>Use to create a process to add/update/delete users within the Infor Lawson system</td>
</tr>
</tbody>
</table>
Infor ION activity nodes

The table below provides an overview of the ION activity nodes:

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert</td>
<td>![Alert Icon]</td>
<td>Allows for escalations in an ION process</td>
<td>Use to create escalations in an ION process</td>
</tr>
<tr>
<td>Inbox Query</td>
<td>![Inbox Query Icon]</td>
<td>Enables an iterative query against the ION Inbox and retrieves records meeting the specified criteria</td>
<td>Use to query against the ION Inbox</td>
</tr>
<tr>
<td>ION Inbox Update</td>
<td>![Update Icon]</td>
<td>Enables updating records in the ION Inbox</td>
<td>Use when updating selected records in the ION Inbox</td>
</tr>
<tr>
<td>Notification</td>
<td>![Notification Icon]</td>
<td>Allows you to configure tasks or notify users in an ION process</td>
<td>Use to notify users through an ION process</td>
</tr>
<tr>
<td>Outbox</td>
<td>![Outbox Icon]</td>
<td>Allows connecting to an ION Outbox</td>
<td>Use to connect to an ION Outbox within a process</td>
</tr>
</tbody>
</table>
# M3 activity nodes

<table>
<thead>
<tr>
<th>Activity node name</th>
<th>Icon</th>
<th>Purpose</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>M3 Transaction</td>
<td><img src="image" alt="M3 icon" /></td>
<td>Queries and performs transactions to data using the Movex Java API</td>
<td>Use to query and/or perform transactions to data from the Infor M3 server</td>
</tr>
<tr>
<td>M3 Event Hub Publisher</td>
<td><img src="image" alt="Event Hub icon" /></td>
<td>IPA can act as a publisher/publish events to the Event Hub; enables others to act upon via the Event Hub activity node</td>
<td>Use to send events to the Event Hub through a process</td>
</tr>
</tbody>
</table>
Check your understanding

These activity nodes appear automatically on the Infor Process Designer canvas when you begin a new process. Select all that apply.

- a) Start
- b) Go
- c) End
- d) Branch

This control activity node places “if-then-else” conditions into a process?

- a) Return
- b) Trigger
- c) Wait
- d) Branch

You would use this control activity node to start new processes within the larger process you are creating.

- a) Branch
- b) Custom Activity
- c) System Command
- d) Trigger

You would use this control activity node to assign a variable.

- a) Assign
- b) Trigger
- c) Wait
- d) Return

You would use this data activity node to transfer to or receive from a local or remote machine.

- a) Data transformation
- b) Data Iterator
- c) FTP
You would use this data activity node to break down a file or data parameters to be used as part of a business process.

a) Encrypt  
b) Decrypt  
c) Data Iterator  
d) FTP

Which of the following data activity nodes collects values for a query using Infor Lawson Query, Landmark Query, or SQL Query?

a) SQL transaction  
b) SQL builder  
c) Msg Builder

Which activity nodes allow a user or users to participate in decision making or to take action on something via their Inbasket?

a) Infor ION activity nodes  
b) Notification activity nodes  
c) User Interaction activity nodes  
d) Control activity nodes

Identify the three types of Queue activity nodes.

a) Infor Cloverleaf  
b) Java Message Service (JMS)  
c) Web Run  
d) WebSphere MQ

The _____ allows building a light-weight data-interchange format, Java Script Object Notation (JSON).

a) JSON Parser  
b) JSON Converter  
c) JSON Builder

Which web activity node do you use to execute any web-based program as part of your process? Select all that apply.

a) XML  
b) Web Services  
c) Web Run
Which Infor Lawson activity node enables constructing a call to classic Infor Lawson applications?

a) Infor Lawson Adapter
b) Infor Lawson Transaction
c) Infor Lawson Query

Which Infor Lawson activity node do you use to create a process to update resources within security in the Infor Lawson Foundation environment?

a) Resource Query
b) Resource Update
c) Landmark Transaction
Lesson 3: Infor Process Designer

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:

- Identify the available views of Infor Process Designer.
- Explain how to use the Infor Process Designer interface.
- Explain how to set Infor Process Designer preferences.
- Describe the purpose of using variables.
- Explain how to build a basic email process.

Topics
- Infor Process Designer views
- Preferences
- Variables
- Build a basic email process
- Check your understanding
Infor Process Designer views

As you learned in Lesson 1, the Infor Process Designer is a desktop point-and-click tool for creating processes.

When the Infor Process Designer launches, it opens to a split-screen interface containing multiple views. These views can be moved, closed, maximized, minimized, or resized.

Main window

The main window, also referred to as the Process Editor, is the largest portion of the window and by default is in the center of the screen. This is where you place activity nodes and connectors when you are designing. When you create a new process file or open an existing process file, the Process Editor is available.

Additional views and windows

Additional views are grouped into three sections:

- **General** – This section contains the Console, Outline, Palette, Progress, and Properties windows.
- **Help** – This section contains online help for Infor Process Designer.
- **Infor Process** – This section contains the Activities, Breakpoints, Debug, Process Issues, and Variables windows.

You can access these views from the menu bar, by selecting Window > Show view > Other.

Manage your view

The following features are available to help you manage your processes and views:

- Zoom In/Out
- Display multiple processes
- Copy and paste nodes
- Upload/ Download processes

Design vs. test perspective

There are two different perspectives you use within Infor Process Designer:

- **Design** – Opens the Palette window if available
- **Test** – Opens the Console window if available
Preferences

You can manage defaults for Infor Process Designer within the preferences section. Preferences include the following:

**Help**
The Help default includes help content from a remote info center.

**Infor Process Designer**
The Process Designer sets the debug to get detailed information from the console view when testing processes within the Process Designer.

**Landmark activity node**
You can define default variables or default the transaction parameters to use the hard coded values, or be promoted to enter values when using the Landmark Transaction activity node.

**Editor**
This default feature allows you to change colors and display information on the editor such as the connector color, show ID instead of the name on the Process Editor view, and so on.

**External jars**
This default allows the loading of external jar files to be used to make JDBC connections for the SQL Query and SQL Transaction activity nodes. Additional connection information is defined elsewhere.

**Manage preferences**
You can determine if you want to download a single process at a time or download multiple processes by using this default feature.

⚠️ Some options require you to restart the Infor Process Designer to take effect.
Exercise 3.1: Set preferences

In this exercise, you will define default preferences with the Infor Process Designer.

Exercise 3.1 steps

1. Log in to the training environment using your assigned login. Note: Your instructor will assign you a student login number.
2. Click the AutoRDP icon on your desktop. The training desktop displays.
3. Double-click the IPDesigner icon (Infor Process Designer). Note: The connection defaults to the Human Capital Management (hcm) data area.
4. Type Tr@in123 in the Password field. Note: To prepare any field in the system for text entry, first click in the text field.
5. Click Login. The Infor Process Designer displays.
7. Select Infor Process Designer.
8. Select the Debug check box, if it not already selected.
9. Select Infor Process Designer > Activity Nodes > Landmark in the Infor Process Designer menu. Note: You can select the Landmark default options you want from the drop-down menus and create the windows you want to use for this process.
10. Select Prompt in the Data area drop-down menu.
11. Select Use hardcoded value in the Module drop-down menu.
12. Select Use hardcoded value in the Object Name drop-down menu.
13. Select Use hardcoded value in the Action drop-down menu.
15. Click the Connector color box.
16. Select a blue color square from the Color window.
17. Click OK.
18. Click OK. The changes you made are saved.
19. Click X on the Welcome tab. The Welcome tab closes. Note: Depending on your setting, you may not see the Welcome tab.
20. Select **Window > Show View > Other**.
21. Click the **arrow** next to **General**.
22. Double-click **Palette**. The Palette view is expanded and displayed in the design window.
23. Select and drag any window to the place where you want this preference to appear on the screen. Repeat until all the windows are arranged in your preferred view.
Variables

A variable is a symbol or a name that stands for a value. Variables can represent either numeric or alphanumeric values.

Variables play an important role in process creation because they allow you to write flexible JavaScript expressions. Rather than entering specific data directly into an expression, you can use variables to represent the data.

When a process is executed, the variables are replaced with real data. This makes it possible for the same process to handle different sets of data, making the process dynamic for each transaction.

Types

Variables can be grouped into four different types:

- Global variables
  - Available before the process executes, throughout execution, and after execution
  - Service variables
  - Configuration variables

- Process variables
  - Variables that you as a process designer create on the Start node
  - They last throughout the execution of the process

- Activity variables
  - Variables created by activity nodes
  - They last long enough to pass information to the next node
  - They are not available throughout execution of the entire process

- Return (output) variables
  - Associated with synchronous triggers and the Return activity node
  - Use to request information to be sent back to the calling (or triggering) application after your process has executed

How to write a variable

Variables, once established, cannot be switched when used further in the flow without being redone throughout. If a variable is initially defined at the Start node as a string, the variable cannot be deleted and then added back as an integer without fixing it anywhere it is used through to the end of the flow.

When defining variables:

- Never start with a number
- Do not use spaces
- Do not use special characters (underscore is ok)
- Variables are case sensitive

Variables can be added as part of the process or created and defined during a process.

Format

When defining variables you must define the variable format as one of the following:

- String
- Boolean
- Date
Variables can be selected within a process by pressing the Ctrl key and spacebar or typing the variable in a specific format. Because the Assign and Branch activity nodes have predefined java expressions built in, you do not need the variable format for variables used within these two activity nodes.
Build a basic email process

To learn how to build a basic email process, we will review the scenario, demonstrate the process, and complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use to send a simple email notification:

Scenario
In this scenario, you will identify the application product line and use a basic email flow to communicate the results.
For this process, you will use the following nodes:
- Start
- Email

Demo: Build a basic email process
Your instructor will demonstrate how to build a basic email process.

Exercise 3.2: Build a basic email process
In this exercise, you will build a basic email process.

Exercise 3.2 steps
Part 1: Add the Email activity node to the Process Editor
Note: Your assigned login number is identified as “xx” in the exercise steps.
1. Double-click the IPDesigner icon on your training desktop.
2. Type Tr@in123 in the Password field.
3. Click Login. The Infor Process Designer opens.
5. Click the **Palette** tab to access nodes and folders. **Note**: The Palette tab includes nodes, folders, and other components to build a query.

6. Select the **Notification** folder to access the **Email** node.

7. Click and drag the **Email** node to the **Process Editor** between the **Start** and **End** nodes.

**Part 2: Set up connections for the Email nodes on Infor Process Designer**

1. Select **Connection** in the **Palette**.

2. Select the **Start** node in the **Process Editor**.

3. Select the **Email** node in the **Process Editor**. A blue connector arrow appears between the **Start** and **Email** nodes indicating a connection has been set up.

4. Select the **Email** node again.

5. Select the **End** node. A second blue connector arrow appears between the **Email** and **End** activity nodes.

6. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

**Part 3: Set the Email activity node’s properties in the Properties panel**

**Notes:**

- The **Properties** panel on the left side of the **Process Editor** window becomes active when an activity node is selected on the Process Editor.
- The panel display varies depending on what type of activity node is selected.

1. Select the **Email node** to view the properties associated with the activity node.

2. Type **user<xx>@edu.com** in the **To** field.

3. Type **BasicEmailTest@infor.com** in the **From** field.

4. Type **Email of Product Line** in the **Subject** field.

5. Type **Product Line** in the **Body** field.

6. Press **Ctrl + space** in the **Body** field. A pop-up window listing process variables opens.

7. Select **appProdline** from the list. The **Body** field displays “Product Line: <!appProdline>”. **Note**: Quotes are not included.

8. Click the **On Error** tab. The **On Error** options displays.

9. Select the **Stop process** radio button under the **What should happen on error?** section.

**Part 4: Save the Infor Process Designer file**

1. Select **File > Save As**. The **Save As** dialog window opens.

2. Select **Desktop** as the location to save the file.

3. Type **EmailProcess** in the **File name** field.

4. Click **Save**. The **Infor Process Designer (.Ipd)** file is saved to your training desktop.

**Part 5: Run the process and test results**

1. Select **Process > Run** on the **Infor Process Designer** toolbar.

2. Select the **No input data** radio button.

3. Click **OK**.

Lawson: Configuring and Administering Process Automation Training Workbook © 2016 Infor Education
4. Review the details in the **Console** tab to see if the process ran successfully. **Note:** If you receive an error, check your connections and run the process again.

5. Select **File > Close**. The **EmailProcess.lpd** file closes.

6. Click the **minus (–) sign** to minimize the **Infor Process Designer**.

**Part 6: Log in to the MailEnable email server and check results**

1. Double-click the **MailEnable** icon in the training desktop. The **MailEnable – Webmail Sign In** window opens.
2. Type `user<xx>` in the **Username** field.
3. Type `Tr@in123` in the **Password** field.
4. Click **Login**.
5. Verify the productline is included in the email.
Check your understanding

Which Infor Process Designer view is where you place activity nodes and connectors when you are designing?

a) Palette  
b) Properties  
c) Main (Process Editor)

The General section contains the following views. Select all that apply.

a) Palette  
b) Properties  
c) Progress  
d) Console  
e) Outline

Identify the two different perspectives you use within Infor Process Designer.

a) Production  
b) Test  
c) Design

In order to change the defaults in Infor Process Designer, you access the _____ section.

a) Main window  
b) Preference  
c) Help

Identify reasons why you would use variables in your process design? Select all that apply.

a) Variables allow you to write flexible JavaScript expressions.  
b) Variables are dynamic content so when a process is executed, the variables are replaced with real data.  
c) Variables allow the same process to handle different sets of data.
To create a simple email process, drag the _____ node between the Start and End activity nodes in Process Editor.

a) Control  
b) FTP  
c) Email
Lesson 4: Infor Landmark Transaction process

Estimated time
1 ½ hours

Learning objectives
After completing this lesson, you will be able to:

- Describe how to build a process using the Landmark Transaction node to do a query in Infor Landmark.

Topics
- Build a process using Landmark Transaction node
- Check your understanding
Build a process using Landmark Transaction node

To learn how to build a query process using the Landmark Transaction, Msg Builder, and Email nodes, we will review a scenario, demonstrate the process, and complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use to build a query:

Landmark transaction process diagram

Scenario
The HR Generalist wants a listing of the primary location for all the Employees at HR Organization 7000.

Create a process to extract the employees and their primary location. Gather the information about the user and notify the system administrator about this information.

For this process, you will use the following nodes:
- Landmark Transaction
- Msg Builder
- Email

Demo: Build a process to query Landmark and collect the data
Your instructor will demonstrate how to build a process to query Landmark, collect the data, and send a notification with the data included.
Exercise 4.1: Build a process to query Landmark and collect data

In this exercise, you will build a process to query Landmark, collect the data, and send a notification with the data included.

Exercise 4.1 steps

Note: Your assigned login number is identified as "xx" in the exercise steps.

Part 1: Add the Landmark Transaction to extract data from employees

1. Click the Infor Process Designer icon on your task bar. The application opens.
3. Click the Palette tab to view the options.
4. Select the Infor Lawson folder to access the Landmark Transaction node.
5. Click and drag the Landmark Transaction node to the Process Editor between the Start and End nodes.
6. Select Connection in the Palette.
7. Select the Start node in the Process Editor.
8. Select the Landmark Transaction node in the Process Editor. A blue connector arrow appears between the Start and Landmark Transaction nodes.
9. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
10. Select the Landmark Transaction node in the Process Editor. The Landmark Transaction properties opens in the Properties panel on the left.
11. Type EMP in the ID field.
12. Type EmployeeLocQuery in the Name field.
13. Click Build in the Activity Information window. The Landmark Transaction Builder window opens.
14. Type or select the following data on the Fields tab:

<table>
<thead>
<tr>
<th>Field</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data area</td>
<td>hcm</td>
</tr>
<tr>
<td>Module</td>
<td>hr</td>
</tr>
<tr>
<td>Object Name</td>
<td>Employee</td>
</tr>
<tr>
<td>Action</td>
<td>Find</td>
</tr>
<tr>
<td>Action Operator</td>
<td>[blank]</td>
</tr>
<tr>
<td>Action Type</td>
<td>MultipleRecordQuery</td>
</tr>
</tbody>
</table>

15. Double-click Employee in the Key Fields window. The Employee field is added to the Selected Fields/Values panel.
16. Double-click HR Organization in the Key Fields window. The HR Organization field is added to the Selected Fields/Values panel.
17. Scroll to find **Name.FullPresentationName** in the **Non-Key Fields** window.

18. Double-click **Name.FullPresentationName**.

19. Scroll to find **PrimaryLocation** in the **Non-Key Fields** window.

20. Double-click **PrimaryLocation**.

   **Note:** The Selected Fields/Value section includes Employee, HR Organization, Name.FullPresentationName, and PrimaryLocation.

21. Select **HROrganization** in the **Selected Fields/Value** section.

22. Click the **Set Field Value** icon. The **Set Field Value** window opens. **Note:** The **Set Field Value** icon is a pencil image.

23. Type **7000** in the **Value** field.

24. Click **OK**. The value displays with double quotation marks (“ ”).

25. Click the **Test** tab. The **Test** tab options opens.

26. Click **Test**. This tests your results. A list of HR employees displays in the **Test Results** panel.

   **Note:** If the list does not display, review the values you entered in the previous steps and retest your query.

27. Click **OK**. The **Landmark Transaction Field Value Handling** window opens.

28. Type or select the following options for fields on the **Landmark Transaction Field Value Handling** window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Option</th>
<th>Value</th>
<th>Variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data area</td>
<td>Use variable</td>
<td>hcm</td>
<td>appProdline</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This is the default, if this option does not display, select it.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Module</td>
<td>Use hardcoded value</td>
<td>hr</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This is the default.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Object Name</td>
<td>Use hardcoded value</td>
<td>Employee</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This is the default.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Action</td>
<td>Use hardcoded value</td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This is the default.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

29. Click **OK**.

30. Click the **On Error** tab in the **Properties** panel. The **On Error** tab options opens.

31. Select the **Stop process** radio button.

**Part 2: Add the Msg Builder activity node to collect data in Msg Builder variable**

1. Click the **Palette** tab to view the options.

2. Select the **Data** folder to access the **Msg Builder** node.
3. Click and drag the **Msg Builder** node to the **Process Editor** ensuring it is placed between the **EmployeeLocQuery** nodes loop and the **Landmark Transaction** node. **Hint:** See the process diagram above for placement.

4. Select **Connection** in the **Palette**.

5. Select the **EmployeeLocQuery** node.

6. Select the **Msg Builder** node. A blue connector arrow appears between the **EmployeeLocQuery** node and the **Msg Builder** node.

7. Select the **Msg Builder** node.

8. Select the **End-EmployeeLocQuery** node. A blue connector arrow appears between the **Msg Builder** node and the **End-EmployeeLocQuery** node.

9. Click the **Palette** tab to view the options.

10. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

11. Select the **Msg Builder** node in the **Process Editor**. The **Msg Builder** properties display in the **Properties** panel on the left.

12. Type or select the following options for the **Msg Builder** properties:

<table>
<thead>
<tr>
<th>Field</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>EMPLOC</td>
</tr>
<tr>
<td>Name</td>
<td>Collect Data</td>
</tr>
<tr>
<td>Variable Name</td>
<td>PRIMELOC</td>
</tr>
<tr>
<td>Message</td>
<td>Press <strong>Ctrl + space</strong> to select variables. Note: Type the identifier before the variable so you know what you are looking at when you receive the information. Employee Number: &lt;!EMP_Employee&gt; Employee Name: &lt;!EMP_Name_FullPresentationName&gt; Employee Primary Location: &lt;!EMP_PrimaryLocation&gt;</td>
</tr>
</tbody>
</table>

**Part 3: Add the Email node to email results from the query**

1. Click the **Palette** tab to view the options.

2. Select the **Notification** folder to access the **Email** node.

3. Click and drag the **Email** node to the **Process Editor**, placing it to the right of the **End-EmployeeLocQuery** node. **Hint:** See the process diagram above for placement.

4. Click the **Palette** tab again.

5. Select **Connection**.

6. Select the **End-EmployeeLocQuery** node.

7. Select the **Email** node. A blue connector arrow appears between the **End-EmployeeLocQuery** node and **Email** node.

8. Select the **Email** node again.

9. Select the **End** node. A blue connector arrow appears between the **Email** node and **End** node.
10. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

11. Select the Email node in the Process Editor. The properties for the Email node display on the Properties panel on the left.

12. Type the following data in the Email properties:

<table>
<thead>
<tr>
<th>Details</th>
<th>Table properties to use if building your own table</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>User&lt;xx&gt;@edu.com</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:LandmarkQuery@infor.com">LandmarkQuery@infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>Primary Locations</td>
</tr>
<tr>
<td>Body</td>
<td>The Employee’s Primary Location for HR Organization 7000: &lt;![PRIMELOC&gt;</td>
</tr>
</tbody>
</table>

13. Click the On Error tab.

14. Select the Stop process radio button.

Part 4: Save the file and test the process

1. Select File > Save As.
2. Select Desktop as the location to save the file.
3. Type QueryEmpLocs in the File Name field.
4. Click Save. The file saves to your training desktop.
5. Click the Run Process icon. The Run Process window opens. Note: the Run Process icon is a right-facing arrow image.
6. Select the No input data radio button.
7. Click OK.
8. Review the details in the Console tab to see if the process ran successfully. Note: If you receive an error, check your connections and run the process again.
9. Click X to close the Infor Process Designer.

Part 5: Log in to the MailEnable email server and check results

1. Double-click the MailEnable icon in the training desktop. The MailEnable – Webmail Sign In window opens.
2. Type user<xx> in the Username field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Verify the email indicates the process was sent with the information in the query.
Check your understanding

Which activity node would you select to query Landmark data?

a) Landmark Transaction
b) Java Message Service (JMS)
c) Infor Lawson Query
Lesson 5: System configuration

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:

- Describe a configuration set.
- Match each configuration set type with its description.
- Identify the configuration information needed to connect to the Infor Lawson environment.

Topics
- Configuration sets
- Check your understanding
Configuration sets

A configuration set is a stored set of technical specifications for connecting to a server. The types of information you need to provide for a connection vary depending on the type of server to which you are connecting. Typical specifications include things such as:

- Server name
- Port number
- User name
- Password

Creating configuration sets is done through the System Configuration menu of the Process Server Administrator. Configuration allows you to define multiple connections to support your business processes. This means that when you create a configuration set, all connections you create, whether they are to an Infor M3, Infor Lawson, and so on, are stored in one location.

For example, suppose you create a configuration set called "MyConfigurations," and then, you create connections to M3 (MyM3) and Infor Lawson (MyInforLawson). You can add MyM3 and MyInforLawson to MyConfigurations. Any time you need to connect to either M3 or Infor Lawson, you would specify "MyConfigurations" as the configuration to use.

Types of configuration sets

The table describes three types of configuration sets:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>The system configuration set is created during installation. This set contains the email address and other information that the system uses by default if a process does not provide specific information. Defaults include:</td>
</tr>
<tr>
<td></td>
<td>- Mail Server</td>
</tr>
<tr>
<td></td>
<td>Note: You can also define the mail server connection by data area.</td>
</tr>
<tr>
<td></td>
<td>- Mail From default</td>
</tr>
<tr>
<td>Main</td>
<td>The main configuration set is delivered by Infor. By default, all connections you create are stored in the main configuration set. Most customers create connections specific to the types of processes they are creating. These connections, including those specifically for emails, can be specified through a process.</td>
</tr>
<tr>
<td></td>
<td>- Default configurations specific to Infor Lawson application</td>
</tr>
<tr>
<td></td>
<td>- Used when no configuration is selected within the process</td>
</tr>
<tr>
<td>Custom</td>
<td>Custom configuration sets are created by clients, if needed. If you have many connections to organize, using the main configuration set may not suffice. You have the option to create custom configuration sets.</td>
</tr>
<tr>
<td></td>
<td>- Specific connection configuration</td>
</tr>
<tr>
<td></td>
<td>- Available configuration sets to select from within a process</td>
</tr>
</tbody>
</table>

Note: Configuration is set up under each data area. For example, if you have a Human Capital Management (hcm) data area or Infor Landmark Procurement (improc) data area or a Lawson System Foundation (LSF) data area, then you would set up configurations for each. The Process Designer is also specific to each data area.
Demo: Review the system configuration set

Your instructor will demonstrate how to change the Mail From configuration to ProcessAutomation@infor.com. Your instructor will also show you the mail server configuration and the Email configuration in the main configuration set.

Demo steps

2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Select the hcm data area in the upper-left of the Infor Rich Client canvas.
8. Click the Properties tab. The Properties tab options opens.
9. Double-click mailFrom.
10. Type user00@edu.com in the Value field.
11. Click Save.
12. Click X to close the Configuration form.
13. Click the Email tab. The Email tab options opens.
15. Validate the inputs below. Note: Specific email configurations can be set up by data area:
   - Mail Server: lsf10gdeinfor2.com:25
   - User Name: lawson
   - Password: Tr@in123
   - Email Actions Base URL: http://lsf10.gdeinfor2.com:8080.
16. Select the apps10 data area.
19. Repeat steps 13-15 to verify that the same information displays in the system configuration set on the Configuration form.
20. Click X to close the Email Connection form.
21. Click X to close the Configuration form.
Demo: Define a configuration set

Your instructor will describe the specific Infor Lawson information defined to connect to the Infor Lawson environment and applications.

Demo steps

   
   Note: You can click and drag the Process Server Administrator from the Start menu to the Infor Rich Client canvas to create a short-cut icon.


3. Click the Infor Lawson tab. The Infor Lawson tab options opens.


5. Type or select the following options to update the parameters:
   - Connection Type: web
   - User: lawson@gdeinfor2.com
   - Password: Tr@in123
   - Resource ID: lawson@gdeinfor2.com
   - Data Area: APPS10
   - Web Root: https://lsf10.gdeinfor2.com

6. Click Save.

7. Click X to close the Infor Lawson Connection form.

8. Click X to close the Configuration form.

9. Click X to close the Configuration Sets list form.

10. Click X to close Infor Rich Client.

   Note: Because some processes may be triggered from the Landmark hcm data area and some from the Infor Lawson applications apps10 data area, the connection needs to be defined in the apps10 data area. Your instructor will verify that this information has been added to the main configuration set in the apps10 data area.

Additional configurations may be needed for specific activities. These are covered within the activity lessons.
Check your understanding

A ________ is a stored set of technical specifications for connecting to a server.

a) Style sheet  
b) Configuration set  
c) Data area

Which configuration set contains the Mail From email address?

a) System  
b) Main  
c) Custom

Which type of configuration set do clients typically create to meet their business process needs?

a) Main  
b) Custom  
c) System

Which configuration setup will be the default if you don’t select a configuration set on an activity node?

a) Custom  
b) Main  
c) System
Lesson 6: Infor Lawson query and resource update process

Estimated time
2 ½ hours

Learning objectives
After completing this lesson, you will be able to:

- Describe how to build a process using the Resource Update and Infor Lawson Query activity nodes.

Topics
- Build a process using the Resource Update and Infor Lawson Query activity nodes
- Check your understanding
Build a process using the Resource Update and Infor Lawson Query activity nodes

To learn how to build a query process and then update Infor Lawson resources, we will review a scenario, demonstrate the process, and then complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use:

![Diagram](image.png)

*Infor Lawson query and resource update process diagram*

**Scenario**

In this scenario, you will build a process to extract the employee information from Infor Lawson and use the information to create a user in the Infor Lawson LDAP. You will give the user the ability to access Employee Self-Service and the Inbasket in Infor Lawson. The user will be used to route work that will be used in the Infor Lawson Requisition Approval lesson.

For this process, you will use the following nodes:

- Infor Lawson Query
- Infor Lawson Resource Update
- Email
- Error Connection
- `<_inputData>` variable to test one record
Demo: Build a query and resource update process
Your instructor will demonstrate how to build a query and resource update process.

Exercise 6.1: Build a query and update resource process
In this exercise, you will build a query and resource update process.

Exercise 6.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Make a new connection to apps10 in the designer

1. Double-click the IPDesigner icon on the training desktop.
2. Click Manage Connections. The Connection Manager window opens.
3. Click New.
4. Type the following connection information for apps10:
   - Connection: LSFapps10
   - Grid host: lmrk10.gdeinfor2.com
   - Grid port: 50005
   - User: lawson@gdeinfor2.com
   - Data area: apps10
5. Click Save.
6. Click OK. You return to the Infor Process Designer login screen.
7. Verify the selection is LSFApps10 in the Connection field. If it is not, select it.
8. Type Tr@in123 in the Password field.
9. Click Login. The Infor Process Designer opens with a connection to the apps10 data area.

Part 2: Infor Lawson Query: Extract data from employee

2. Click the Palette to view the options.
3. Select the Infor Lawson folder to access the Query node.
4. Click and drag the Query node to the Process Editor. Hint: See the process diagram for placement.
5. Select Connection in the Palette.
6. Select the Start node.
7. Select the **LwsnQuery** node. A blue connector arrow appears between the two nodes.
8. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
9. Select the **LwsnQuery** node in the **Process Editor**. The **LwsnQuery** properties display in the **Properties** panel on the left.
10. Type **HR** in the **ID** field in the **Properties** panel.
11. Type **HRQuery** in the **Name** field.
12. Click **Build**. The **Infor Lawson Process Query Builder** displays.
13. Select **APPS10** in the **Product Line** field. **Note**: To display the options in any field, click the arrow in the field to open the drop-down list.
14. Select **HR-Human Resources** in the **Module Name** field.
15. Select **EMPLOYEE - Employee** in the **Table** field. The options for the **EMPLOYEE** business class displays.
16. Click the **Fields** tab. The **Fields** tab opens.
17. Double-click the following fields. The fields are added to the **Selected Fields** section:
   - COMPANY
   - EMAIL-ADDRESS
   - EMPLOYEE
   - FIRST-NAME
   - FULL-NAME
   - LAST-NAME
   - NAME-PREFIX
18. Click the **Index & Condition** tab. The **Index & Condition** tab opens.
19. Select **EMPSET1** in the **Indexes** section.
20. Select the **Values** field next to **COMPANY** in the **Keys** section. The **Set Value** form opens.
21. Type **4321** in the **Value** field.
22. Select the **Value** field next to **EMPLOYEE** in the **Keys** section. The **Set Value** form opens.
23. Press **Ctrl + space** in the **Value** field. A pop-up window listing variables opens.
24. Double-click **_inputData** from the variable list. The variable **_inputData** populates the field.
25. Click the **Test** tab. The **Test** tab opens.
26. Type **<your assigned employee number>** in the **Value** field next to **_inputData**.
27. Click **Test API**.
28. Validate that your employee information was returned in the **Test Results** section.
29. Click **Finish**.
30. Select (highlight) **APPS10** in your query string.
31. Replace **APPS10** by typing **<appProdline> variable &** in the **Query** string for the node properties.
32. Click the **On Error** tab.
33. Select the **Stop process** radio button.

**Part 3: Infor Lawson Resource Update: Update resource fields**

1. Click the **Palette** tab to view the options.
2. Select the Infor Lawson folder to access the Resource Update node.
3. Click and drag the Resource Update node to the Process Editor, between the HRQuery node and the HRQuery-End node.
4. Select Connection in the Palette.
5. Select the HRQuery node.
6. Select the Resource Update node. A blue connector arrow appears between the two nodes.
7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
8. Select the Resource Update node in the Process Editor. The Resource Update node's properties display on the Properties panel on the left.
9. Type RES in the ID field.
10. Type ResourceUpdate in the Name field.
11. Select Add from the Action drop-down menu.
12. Click Build. The Infor Lawson Resource Update form displays.
13. Select the Add radio button.
14. Select People from the RM Objects drop-down menu.
15. Double-click the Value field next to Last Name. The Set Value form displays.
17. Select from HR_LAST_NAME the Variable list.
18. Click OK.
19. Double-click the Value field next to ID. The Set Value form displays.
20. Press Ctrl + space in the Value field. The Set Value Variable list opens.
21. Select _inputData from the Set Value Variable list.
22. Click OK.
23. Double-click the Value field next to First Name. The Set Value form displays.
24. Press Ctrl + space in the Value field. The Set Value Variable list opens.
25. Select HR_FIRST_NAME from the Variable list.
26. Click OK.
27. Double-click the Value field next to PortalRole. The Set Value form displays.
28. Type ess.xml in the Value field.
29. Click OK.
30. Double-click the Value field next to ProductLine. The Set Value form displays.
31. Type APPS10 in the Value field.
32. Click OK.
33. Double-click the Value field next to WFUser. The Set Value form displays.
34. Type 1 in the Value field.
35. Click OK.
36. Double-click the Value field next to Name. The Set Value form displays.
37. Press Ctrl + space in the Value field. The Set Value Variable list displays.
38. Select **HR_FULL_NAME** from the **Variable** list.
39. Click **OK**.
40. Double-click the **Value** field next to **Email**. The **Set Value** form displays.
41. Press **Ctrl + space** in the **Value** field. The **Set Value Variable** list displays.
42. Select **HR_EMAIL_ADDRESS** from the **Variable** list.
43. Click **OK**.
44. Double-click the **Value** field next to **Role**. The **Set Value** form displays.
45. Type **Employee** in the **Value** field.
46. Click **OK**.

**Part 4: Infor Lawson Resource Update: Update service attribute fields**

1. Click the **Service** tab.
2. Double-click the **COMPANY** field under **EMPLOYEE(Agent)**. The **Set Value** form displays.
3. Press **Ctrl + space** in the **Value** field. The **Set Value Variable** list displays.
4. Select **HR_COMPANY** from the **Variable** list.
5. Click **OK**.
6. Double-click the **EMPLOYEE** field under **EMPLOYEE(Agent)**. The **Set Value** form displays.
7. Press **Ctrl + space** in the **Value** field. The **Set Value Variable** list displays.
8. Select **HR_EMPLOYEE** from the **Variable** list.
9. Click **OK**.
10. Double-click the **PASSWORD** field under **SSOP (primary)**. The **Set Value** form displays.
11. Type **Tr@in123** in the **Value** field.
12. Click **OK**.
13. Double-click the **USER** field under **SSOP (primary)**. The **Set Value** form displays.
14. Type **<!HR_EMPLOYEE>@gdeinfor2.com** in the **Value** field.
15. Click **OK**.
16. Double-click the **REQUESTER** field under **REQUESTER(Agent)**. The **Set Value** form displays.
17. Type **ipa<<xx>>** in the **Value** field. **Note**: The product line defaults as the product line for the selected **Lawson LSF** server.
18. Click **OK**.
19. Click **OK**.
20. Click the **On Error** tab.
21. Select the **Go to error handler** radio button. This is where you would select the process you want to take if there is an error.

**Part 5: Infor Lawson Resource Update: Update fail email notification**

1. Click the **Palette** tab to view the options.
2. Select the **Notification** folder to access the **Email** node.
3. Click and drag the Email node to the Process Editor so that it is to the right of the ResourceUpdate node. **Hint:** See the process diagram above for placement.

4. Select Error connection in the Palette.

5. Select the ResourceUpdate node.

6. Select the Email node. A red error connector arrow appears between the two nodes.

7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

8. Select the Email node in the Process Editor. The node’s properties display in the Properties panel.

9. Type user<xx>@edu.com> in the To field.

10. Type resource@infor.com in the From field.

11. Type Resource Update Failed in the Subject field.

12. Type The Resource update failed. &lt;!lastErrorCode&gt; and &lt;!RES_EMPLOYEE_returnMessage&gt; in the Body field.

13. Click the On Error tab.

14. Select the Stop process radio button.

15. Select Connection in the Palette.

16. Select the Email node.

17. Select the End-HRQuery node. A blue connector arrow appears between the two nodes.

18. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

**Part 6: Email results from query**

1. Click the Palette tab to view the options.

2. Select the Notification folder to access the Email node.

3. Click and drag the Email node to the Process Editor under the HRQuery node.

4. Select Connection in the Palette.

5. Select the Resource Update node.

6. Select the Email node under the HRQuery node.

7. Select the Email node.

8. Select the End HRQuery node. A blue connector arrow appears between the two nodes.

9. Select the End HRQuery node again.

10. Select the End node. A blue connector arrow appears between the two nodes.

11. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

12. Select the Email node in the Process Editor. The node’s properties display in the Properties panel.

13. Press Ctrl + space in the To field. The Set Value Variable list displays.

14. Select &lt;!HR_EMAIL_ADDRESS&gt;.

15. Press Ctrl + space in the From field. The Set Value Variable list displays.

16. Select &lt;!_configuration.system.mailFrom&gt;.
17. Type Welcome """" in the Subject field. Note: Press Ctrl + space to select the variables.

18. Type """" in the Body field.

19. Click the On Error tab.

20. Select the Stop process radio button.

Part 7: Save and run the process

1. Select File > Save As.
2. Select Desktop as the file location.
3. Type ResourceUpdate in the File name field.
4. Click Save.
5. Select Process > Run (or click Run process) to run the process. Note: After the process runs, the Run Process form displays.
6. Select the Use connector radio button on the Run Process form.
7. Select the Specify input data radio button.
8. Type """" in the Specify input data field.
9. Click OK.
10. Click X to close the ResourceUpdate.lpd file.

Part 8: Validate the process results

1. Double-click the Infor Lawson for Infor Ming.le® shortcut on the training desktop. The Infor Lawson for Infor Ming.le home page opens.
2. Type 10<xx>@gdeinfor2.com> in the User name field.
3. Type Tr@in123 in the Password field.
4. Click Sign In. Note: It may take a while for the initial login.

Notes:
- You may receive a message to store your password at this site; if so, select Not for this site.
- You may receive a message that Internet Explorer blocked a pop-up.
  - Select Allow once and click OK to save the changes to your layout and reload your layout. This allows the Employee Self-Service bookmark to be loaded for your user.
5. Select Bookmarks. The Inbasket and Employee Self-Service bookmarks display.
6. Click X to close the Infor Lawson for Infor Ming.le page.

Note: You can design a process to create the LSF user record and the actor record. We have already built your users as actors in Landmark. Also, to allow full access to everything in Infor Lawson for training purposes, security is turned off on the training image.

Depending on the Infor Security Services (ISS) version you are running, the Build Resources Full Index function may need to be executed for the users to be accessible in Infor Security Services.
The following is a high-level overview of how the user can access ISS:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Open <strong>Infor Lawson Interface Desktop</strong> (LID).</td>
</tr>
<tr>
<td>Step 2</td>
<td>Choose the servers</td>
</tr>
<tr>
<td></td>
<td>- Connect to <strong>NTserver</strong></td>
</tr>
<tr>
<td></td>
<td>- Select <strong>LSF10.GDEINFOR2.COM</strong></td>
</tr>
<tr>
<td>Step 3</td>
<td>Log in</td>
</tr>
<tr>
<td></td>
<td>- User name is <em>lawson</em></td>
</tr>
<tr>
<td></td>
<td>- Password is <em>G!oba!08</em></td>
</tr>
<tr>
<td>Step 4</td>
<td>Access <strong>Command Prompt</strong></td>
</tr>
<tr>
<td></td>
<td>- Type 17 (Manage Search Index)</td>
</tr>
<tr>
<td></td>
<td>- Type 1 (Build Resources Full Index)</td>
</tr>
<tr>
<td></td>
<td>- Type 4 to exit and close the Lawson Interface Desktop</td>
</tr>
</tbody>
</table>
Check your understanding

Which activity node would you select to build a process that extracts employee data from an Infor Lawson application?

a) Infor Lawson Query
b) Infor Lawson Adapter
c) HRTM User Action

Which activity node would you select to create a resource in the Infor Lawson LDAP?

a) Infor Lawson Resource Query
b) Infor Lawson Resource Update
c) Landmark Transaction
Lesson 7: User configuration

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:

- Explain how to set up process users.
- Describe proxy management.

Topics
- Set up process users
- Proxy management
- Check your understanding
Set up process users

If you are using a User Action or HRTM User Action within a process, the user must be set up as a process user to allow you to route work to the user. All process users must be valid actors. If you are using a User Action within a process, you can also define specific tasks and assign the user to tasks. Work can be routed to a task or multiple tasks, so any user assigned to that task receives work on which to take action.

Scenario
In this scenario, you will be establishing users and tasks to facilitate. A variety of options is available to route work. In a future process, you will route a requisition request for approval.

Demo: Set up process users and tasks
Your instructor will demonstrate how to create a User Profile and System Setup of Tasks.

Exercise 7.1: Set up process users and tasks
In this exercise, you are establishing users and tasks to facilitate. A variety of options are available to route work. In a future process, you will route a requisition request for approval.

Exercise 7.1 Steps
Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Setup tasks
1. Go to the training desktop.
2. Double-click Infor Rich Client hcm.
3. Type lawson@gdeinfor2.com in the Login Name field.
4. Type Tr@in123 in the Password field.
5. Click Login. The Infor Rich Client application opens.
6. Select apps10 in the data area in the upper-left corner of Infor Rich Client canvas.
7. Select Start > Applications > Process Server Administrator > Configuration > User Configuration > Tasks. The Tasks form displays.
8. Select Actions > Create on the toolbar.
9. Type <ReqApprover##A> in the Task Name field. Note: Your assigned number equals ##.

10. Select the default in the Display Inbasket field. Note: The default is typically the standard Inbasket.

11. Click Save.

12. Click X to close the Task form.

13. Select Actions > Create.

14. Type ReqApprover##B in the Task Name field.

15. Click Save.

16. Click X to close the Task form.

17. Click X to close the Tasks form.

Part 2: Create a process user


2. Select Actions > Create in the top portion of the Users form.

3. Type 10<xx> in the User field.

4. Select Default in the Notify Option field, if it is not already selected.

5. Select the Landing Page Link in the Inbasket Link Type field.


7. Accept default values for all field entries display.

8. Click Save.

9. Click X to close the User form.

Part 3: Add a task to a user

1. Select 10<xx> user you just created in the Users form.

2. Select Actions > Create in User Task section at the bottom portion of the Users form. The User Task form displays.

3. Click the arrow.


5. Click Select.

6. Click Save.

7. Click X in to close the User Task form.

8. Select 10<xx> user again on the Users form.

9. Select Actions > Create in the User Tasks section on the bottom of the Users form.

10. Click the arrow.


12. Click Select.

13. Click Save.

14. Click X to close the User Task form.
15. Click X to close the Users form.

16. Click X to close Infor Rich Client.

To customize the landing page and customization for the Inbasket, refer to the Inbasket Interface Options and Display Customizations section of the Infor Process Automation Administration Guide available by selecting the Technology Info Center > Infor Landmark Technology Administration Guides.
Proxy management

A proxy lets you, or an administrator on your behalf, assign a task that you typically perform to another user so that that person can take action for you. You might, for example, need to assign proxy for a task if you are going on vacation and need someone to sign off in your absence, or even to assign a proxy permanently to facilitate one of your tasks.

There are two ways to assign proxy rights:

- IPA administrators can assign proxies for users.
- Users who have been given the required access rights can assign proxies for themselves.

Demo: Assign a user as a proxy for a task

Your instructor will review the ProcessAutomationProxy_ST security class details that is assigned to the InbasketUser_ST role and demonstrate how to assign a user for a proxy for a task.

---

Demo steps

Part 1: Review proxy security class in GEN

1. Double-click Infor Rich Client hcm.
2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Select the gen data area. Note: The data area selection menu is in the upper-left of screen.
7. Click the magnifying glass in the Role field.
8. Type InbasketUser_ST in the Search field.
11. Click the Security Classes Assigned to Role tab.
13. Select Apps10 in the Data Area field.
15. Select the ProcessAutomationProxy_ST in the Security Class field. Note: You may have to search for the security class.
16. Click Select.
17. Click Save. The ProcessAutomationProxy_ST security class is now included in the list of security classes assigned to the InbasketUser_ST role.
19. Review the record details.
20. Click X to close the Role Security Class form.
21. Click X to close the Role form.
22. Click X to close the Role List window and return to the Infor Rich Client canvas.

Part 2: Assign a user for a proxy task
1. Select the apps10 data area in Infor Rich Client.
3. Click the magnifying class in the Actor ID field.
4. Type <your assigned employee number> in the Actor ID field.
5. Press Enter.
6. Select <your assigned employee>.
7. Select ReqApprover<xx>A in the Task section.
8. Select Actions > Create in the Proxy List section. The Proxy Form window opens.
9. Select IN02 in the Proxy User field. This is your proxy user.
10. Select <today's date> for the Effective Date field.
11. Select <tomorrow's date> for the Expiration Date field.
12. Click Save. The record is saved
13. Click X to close the Proxy Form.
14. Click the minus (−) sign to minimize the Infor Rich Client screen.
15. Return to the training desktop.

Part 3: Test the proxy assignment
1. Log in to Infor Lawson for Infor Ming.le. The Infor Lawson for Infor Ming.le home page opens.
2. Type 10<xx> gdeinfor2.com in the User name field.
3. Type Tr@in123 in the Password field.
4. Click Sign In.
5. Select Bookmarks > Inbasket > apps10.
7. Select ReqApprover<xx>A in the Tasks section.
   Notes:
   o IN02 is your proxy under the Proxy List.
If your user has work in the Inbasket, the proxy user IN02 would be able to take action on your user’s work.

8. Click X to close Infor Lawson for Infor Ming.le.
Check your understanding

Which path would you select to set up process users?

a) Start > Infor Process Designer > User Process  
b) Start > Process Server Administrator > Configuration > User Configuration  
c) Start > Process Server Administrator > Configuration > System > User

Which two statements are true about the process to assign proxies?

a) Users can only assign proxies to others and never to themselves.  
b) IPA administrators can assign proxies for users.  
c) Users with the appropriate access rights can assign proxies for themselves.
Lesson 8: Requisition and approval process

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:

- Explain how to build a process flow that routes requisitions for approval.

Topics
- Requisition approval process
- Additional configuration
- Check your understanding
Requisition approval process

In this lesson you will learn how to build the process flow that is used to route requisitions for approval. To do this, we will review a scenario, demonstrate the process, and then complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use:

![Requisition approval process diagram]

Scenario

In this scenario, you will create a requisition approval process routing work to users based on the user’s assigned tasks. The process includes updating an Infor Lawson application, and notifying the requester of the results by getting the requester’s email from the resource record.

For this process, you will use the following nodes:

- Infor Lawson Query
- User Action
- Infor Lawson Transaction
- Resource Query
- Email

Demo: Create a requisition approval process

Your instructor will demonstrate how to create a requisition approval process routing and updating an Infor Lawson application based on the users’ actions and sending a notification of the results.
Exercise 8.1 : Create a requisition approval process

In this exercise, you will create a process that is initiated when a requisition is released. Approvals are routed to users based on their tasks (two-level approval), with ability to reject or approve the request. Based on the users' action, the requisition's status is updated and the requester will receive an email with the results. The requisitions email address is captured from the Lawson Resource information.

Exercise 8.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Build an Infor Lawson query

1. Double-click Infor Process Designer on the training desktop.
2. Select LSFapps10 in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click the Property tab.
7. Select Req Approval in the Service Name field in the Property tab of the Process Editor.
8. Click Reload Service Variables.
9. Verify the message “Service variables have been reloaded” displays below the Properties window.
10. Click the Palette tab to view the options.
11. Select the Infor Lawson folder to access the Query node.
12. Click and drag the Infor Lawson Query node next to the Start node.
13. Select Connection in the Palette.
14. Select the Start node on the Process Editor.
15. Select the LwsnQuery node on the Process Editor. A blue connector arrow appears between the two nodes.
16. Select the LwsnQuery node again.
17. Select the End-Query node. A blue connector arrow appears between the two nodes. Note: Do not select the End node.
18. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
19. Select the LwsnQuery node on the Process Editor. The LwsnQuery node properties display in the Properties panel.
20. Type REQINFO in the ID field.
21. Type ReqInformation in the Name field.
22. Click Build. The Infor Lawson Process Query Builder form displays.
24. Select RQ-Requisitions in the Module Name field.
25. Select **REQHEADER** in the **Table** field.
26. Double-click the following fields.
   - **APPROVAL-VAL**
   - **PFLOW-APRV-LVL**
   - The fields are added to the **Selected Fields** list:
27. Click the **Index & Condition** tab.
28. Select **RQHSET1** in the **Indexes** section. The **Index** is added to the **Keys** section.
29. Select the **COMPANY Value** field in the **Keys** section.
30. Type `<RQH.Company>` in the **Value** field. **Note:** You can also press **Ctrl + space** to select the variable.
31. Click the **REQ-NUMBER Value** field.
32. Type `<RQH.Req_Number>` in the **Value** field.
33. Click **Finish**. This brings you back to the General tab in the Properties panel.
34. Highlight **APPS10** in the **Query String** field in the **General** tab.
35. Press **Ctrl + space**. The **Process Variables** list displays.
36. Select **appProdline** from the **Process Variables** list. The **Query String** field shows **appProdline**. The variable **appProdline** replaces the literal value **APPS10**.
37. Click the **On Error** tab.
38. Select the **Continue Process** radio button.
39. Select the **Notify** check box.
40. Type **user<xx>@edu.com** in the **To** field.
41. Type **requisitions@edu.com** in the **From** field.

**Part 2: Add user actions**

1. Click the **Palette** tab.
2. Select the **User Interaction** folder to access the **User Action** node.
3. Click and drag the **User Action** node to the **Process Editor**, next to **End-ReqInformation**.
4. Select **Connection** in the **Palette**.
5. Select the **End-ReqInformation node in the Process Editor**.
6. Select the **User Action** node. A blue connector arrow appears between the two nodes.
7. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
8. Select the **User Action** node in the **Process Editor**. The **User Action** node properties displays in the **Properties** panel.
9. Type **UA1** in the **ID** field.
10. Type **Approver A** in the **Name** field.
11. Click the **plus (+) sign** under **Work assignment** in the **General** tab. The **Select tasks/or users** window opens.
12. Click the **Tasks** tab.
13. Select the **ReqApprover<xx>A** check box.
14. Click **OK**.
15. Click the **plus (+) sign** under **Actions** in the **General** tab. The **Action Builder** window opens.
16. Type **Approve** in the **Action name** field.
17. Click **OK**.
18. Click the **plus (+) sign** under **Actions** to add another action.
19. Type **Reject** in the **Action name** field.
20. Click **OK**.
21. Click and drag a second **User Action** node to the **Process Editor**. **Hint:** Review the process diagram placement.
22. Select **Connection** in the **Palette**.
23. Select the **Approver A User Action** node.
24. Select the **second User Action** node. The **Select a Branch Condition** form displays.
25. Select **Approve** in the **Condition** field.
26. Click **OK**.
27. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
28. Select the **second User Action** node. The **User Action** node properties displays in the **Properties** panel.
29. Type **UA2** in the **ID** field.
30. Type **Approver B** in the **Name** field.
31. Click the **plus (+) sign** under the **Work Assignment** area.
32. Select the **ReqApprover<xx>B** check box.
33. Click **OK**.
34. Click the **plus (+) sign** under **Actions** in the **General** tab. The **Action Builder** window opens.
35. Type **Approve** in the **Action name** field.
36. Click **OK**.
37. Click the **plus (+) sign** under **Actions** to add another action.
38. Type **Reject** in the **Action name** field.
39. Click **OK**.

**Part 3: Approve transaction**

1. Click the **Palette** tab.
2. Select the **Infor Lawson** folder to access the **Transaction** node.
3. Click and drag two **Transaction** nodes to the **Process Editor**, placing one **Transaction node** on each of the **Approver B User Action** nodes.
4. Select the first **Transaction** node. The **Transaction** node properties displays in the **Properties** panel.
5. Add the following information for the first **Transaction** node properties:
6. Type **APPR** in the **ID** field.
7. Type **Approve** in the **Name** field.
8. Click Build.

9. Type the following parameters:
   - **Prod Line** = APPS10
   - **Module** = RQ-Requisitions
   - **Token** = RQ13.1 – Direct Approval
   - **Method** = Approve

10. Double-click to add the following fields to the Selected Fields section:
    - **RQH-COMPANY**
    - **RQH-REQ-NUMBER**

11. Type the following values to each field:
    - **RQH-COMPANY** = <!RQH_COMPANY>
    - **RQH-REQ-NUMBER** = <!RQH_REQ_NUMBER>

12. Click Finish.

13. Highlight **APPS10** in the Transaction query string.


15. Select <!appProdline> from the Process Variables list. The variable <!appProdline> replaces the literal value APPS10.

16. Click the On Error tab.

17. Select the Continue Process radio button.

18. Select the Notify check box.

19. Type user<xx>@edu.com> in the To field.

20. Type approver@edu.com in the From field.

**Part 4: Reject transaction**

1. Select the second Transaction node in the Process Editor.

2. Add the following information for the second Transaction node properties:

3. Type **REJ** in the ID field.

4. Type **Reject** in the Name field.

5. Click Build.

6. Type the following parameters:
   - **Prod Line** = APPS10
   - **Module** = RQ-Requisitions
   - **Token** = RQ13.1 – Direct Approval
   - **Method** = Reject

7. Double-click to add the following fields to Selected Fields section:
   - **RQH-COMPANY**
   - **RQH-REQ-NUMBER**

8. Type the following values to each field:
   - **RQH-COMPANY** = <!RQH_COMPANY>
   - **RQH-REQ-NUMBER** = <!RQH_REQ_NUMBER>

9. Click Finish.
10. Highlight **APPS10** in the **Transaction** query string.
11. Press **Ctrl + space**. The **Process Variables** list opens.
12. Select `<!appProdline>` from the **Process Variables** list. The variable `<!appProdline>` replaces the literal value **APPS10**.
13. Click the **On Error** tab.
14. Select the **Continue Process** radio button.
15. Select the **Notify** check box.
16. Type `user<xx>@edu.com>` in the **To** field.
17. Type `rejecter@edu.com` in the **From** field.

**Part 5: Add connections**

1. Select **Connection** in the **Palette**.
2. Select **Approver A**.
3. Select the **Reject Transaction** node. The **Select a Branch Condition** window opens.
4. Select **Reject**.
5. Click **OK**. A blue connector arrow appears between the two nodes.
6. Select **Approver B**.
7. Select the **Reject Transaction** node. The **Select a Branch Condition** window opens.
8. Select **Reject**.
9. Click **OK**. A blue connector arrow appears between the two nodes.
10. Select **Approver B**.
11. Select the **Approve Transaction** node.
12. Select **Approve**.
13. Click **OK**.

**Part 6: Notify Resource Query**

1. Click the **Palette** tab.
2. Select the **Infor Lawson** folder to access the **Resource Query** node.
3. Click and drag the **Resource Query** node to the **Process Editor** placing it next to the **Reject Transaction** node.
4. Select the **Resource Query** node. The **Resource Query** node properties displays in the **Properties** panel.
5. Type **RQReject** in the **ID** field.
6. Type **Requester** in the **Name** field.
7. Click **Build**. The **Infor Lawson Resource Query Builder** form displays.
8. Select **People** in the **RM Objects** field.
9. Click **Get Attributes**. The **Attributes** list displays.
10. Select the **Email** check box.
11. Click **Next**.
12. Click the Services tab.
13. Select APPS10_REQUESTER in the Services field.
14. Select REQUESTER in the Field field.
15. Type &lt;!RQH_REQUESTER&gt; in the Value field.
16. Click Add Expression. The expression is added to the Criteria section.
17. Click Finish.
18. Click the On Error tab.
19. Select the Continue Process radio button.
20. Select the Notify check box.
21. Type user&lt;xx&gt;@edu.com in the To field.
22. Type requester@edu.com in the From field.
23. Right-click the Resource Query node in the Process Editor.
24. Select Copy.
25. Click Paste on the Process Editor next to the Approve Transaction node.
27. Type RQApprove in the ID field.
28. Type Requester in the Name field.
29. Add the following connections: Hint: See the process diagram for connections.
   - Reject node to Requester
   - Requester to End-Requester
   - Approve node to Requester
   - Requester to End-Requester

Part 7: Email notification
1. Click the Palette tab.
2. Click and drag the Email node from the Notification folder to the Process Editor. Hint: See the process diagram for placement.
3. Select the Email node. The Email node properties displays in the Properties panel.
4. Type the following values in the Email node properties:

<table>
<thead>
<tr>
<th>Email node properties</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>RejectEmail</td>
</tr>
<tr>
<td>To</td>
<td>&lt;!RQReject_EMAIL&gt;</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:RQCommunication@Infor.com">RQCommunication@Infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>Rejected Requisition: &lt;!RQH_REQ_NUMBER&gt;</td>
</tr>
</tbody>
</table>
Email node properties | Value
--- | ---
Body | Requisition Number - <!RQH_REQ_NUMBER> This requisition has been Rejected

5. Click the **On Error** tab.
6. Select the **Stop Process** radio button.
7. Select **Connection** in the **Palette**.
8. Select the **Reject End-Requester** node.
9. Select the **Reject Email** node. A blue connector arrow appears between the two nodes.
10. Select the **Email** node again.
11. Select the **End** node. A blue connector arrow appears between the two nodes.
12. Click **Select** in the **Palette** (or press Esc on your keyboard) to exit the connection mode.
13. Right-click the **Email** node.
14. Select **Copy**.
15. Click **Paste**. A second (copy) of the **Email** node is copied to the **Process Editor**. **Hint**: See the process diagram for placement.
16. Select the **second (copy) Email** node. The **Email** node properties displays in the **Properties** panel.
17. Type the following values in the **Email node** properties:

<table>
<thead>
<tr>
<th>Email node properties</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>ApproveEmail</td>
</tr>
<tr>
<td>To</td>
<td>&lt;!RQApprove_EMAIL&gt;</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:RQCommunication@Infor.com">RQCommunication@Infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>Approved Requisition: &lt;!RQH_REQ_NUMBER&gt;</td>
</tr>
<tr>
<td>Body</td>
<td>Requisition Number - &lt;!RQH_REQ_NUMBER&gt; This requisition has been Approved.</td>
</tr>
</tbody>
</table>

18. Click the **On Error** tab.
19. Select the **Stop process** radio button.
20. Select **Connection** in the **Palette**.
21. Select the **Approve End-Requester** node.
22. Select the **Approve Email** node.
23. Select the **Approve Email** node again.
24. Select the **End** node.
25. Click **Select** in the **Palette** (or press Esc on your keyboard) to exit the connection mode.
Part 8: Save file and run process

1. Select File > Save As.
2. Select Desktop.
3. Type ReqApproval<xx> in the File name field.
4. Click Save.
5. Select Process > Run. The process runs.
6. Select the No input data radio button.
7. Click OK.
8. Test the Approve/Reject and Approve/Approve and Reject paths.

⚠ Emails are not received unless you included your email address hard-coded in the To: field replacing after test.
Additional configuration

A timeout action is delivered with both the User Action and HRTM User Action. Within the system configuration set, you can define a `timeOutActionUser`, which would be the process. Timeout actions can also be identified within the User Action and HRTM User Action to allow you to take a specific action after the timeout period, or reassign the work to another user or task if action has not been taken after the timeout period.
Check your understanding

Which activity nodes would you use to build a process flow that routes work to users based on the user’s assigned tasks? Select all that apply.

a) User Action  
b) Infor Lawson Transaction  
c) Resource Query

In which configuration set can you define a timeOutActionUser?

a) Main  
b) Custom  
c) System
Lesson 9: Enable services

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:

- Describe the functionality of service, triggers, and workunits.
- Explain how to enable a service.
- Explain how to initiate and test a process.

Topics
- Service, triggers and workunits
- Service enablement
- Check your understanding
Service, triggers and workunits

Service
A service is an IPA entity that allows an application trigger to create a workunit associated with that service. A service has specific requirements, such as an application code name that corresponds to that service name and initiating event.

Triggers
An Infor Lawson trigger is COBOL code in a Lawson application that defines an event within the application that when it occurs, ultimately creates a workunit.

Workunits
A workunit is a data set that allows IPA to start an associated process and track its execution.

When a process runs, it generates one or more workunits. Each workunit represents the history of the process as it executes. A trigger is activated as the by-product of a user performing a business action in an application. For example, releasing a requisition or putting a customer order on hold.

The Process Server Administrator menu provides a Workunits menu which provides tools for monitoring the process of workunits.

Emailing reminders to users of items assigned to them
Administrators can configure the Reminder_Summary_Emailer_Template.lpd, which is delivered by Infor that automatically reminds users who have incomplete work items in their Inbaskets to take action.

The User record in the Process Server Administrator must have the Send Summary Email Reminder feature set to receive the reminders. Review the Infor Process Automation Administration Guide for more information on configuring and modifying the process.

Process versions
When IPA process flows are uploaded to the IPA server, new process versions are created. The most recently uploaded version is used when new workunits are created.

Make Current Version
Infor Process Automation administrators can revert to earlier versions of process flows by using the Make Current Version feature on the Process Definition window.

You might want to do this if, for example, the new version of the process has errors and the Infor Process Automation administrator wants to go back to a previous version.

Existing workunits that are still in process, including those pending on user actions, will continue to use the process flow version that was current when the workunit was created.

To select the setting, go to the Process Definition window, right-click the workunit and then, from the context menu, select Make Current Version.
In rare circumstances, administrators may want to change the process version used by workunits that are still processing. You can use the Make Current Version feature on Action Pending Workunits (still processing), though most administrators will neither need nor want to use this feature.

**Process execution log files**

Data can be captured about the process execution. Logging settings are available from the Process Designer when uploading process and can be maintained on the process in the Process Server administration area.

Available logging levels are:

- **None**: No data is stored in the log file. Consider using this setting for a process that is successfully and is not in need of trouble shooting.
- **Workunit Only**: The log file captures data about workunits only as they are created and move through the system.
- **Activity Only**: The log file captures data about each action an activity node makes, including when they are activated, run successfully, run unsuccessfully, and responded to, and so on.
- **Workunit and Activity**: All flow actions are captured. This setting generates a large amount of data.

**Maintaining execution log files and workunit data**

The log buffer is the amount of data about a process that the system holds in memory before sending data to the log file. The default is 5000 bytes. You can change this for an individual process. The smaller the buffer time, the more time it writes to the log file which can impact performance. See the Infor Process Automation Administration Guide for more information on modifying the log buffer size.

To minimize the amount of data related to workunits that is stored on your system without deleting the important artifacts, you can clear logs and activities. Choices for clearing include:

- **Clear Workunit and Activity Logs**: Gets rid of data for workunits and activities
- **Delete Activity and Activity Logs**: Deletes activity records but retains logs
- **Delete Workunit Variables**: Deletes workunit variable information but retains activity information and logs

See additional information about clearing logs and activities for workunits and cleaning up workunit views and data in the Infor Process Automation Administration Guide.
Service enablement


Some Infor Lawson services are delivered enabled and some are delivered disabled. You must enable services before they can be used in IPA. A service can invoke one or more processes. Multiple processes can be processed at the same time.

Services have several components:

- Service definition and criteria
- Processes
- Service variables

Scenario: Enable a service

In this scenario, you will determine prerequisites, enable a service, and test a process.

Demo: Enabling a service

Your instructor will demonstrate how to identify prerequisites in the LSF applications, enable and disable a service, and define the process or processes the service will use. Additionally, your instructor will show how to access Infor Lawson for Infor Ming.Ie to identify that the Requisition Approval prerequisites are set up.

Exercise 9.1: Enabling a service

In this exercise, you will upload your process to the server and add your process to the Termination service.

Exercise 9.1 steps

Part 1: Upload your process to the server

Notes:

- Your assigned login number is identified as “xx” in the exercise steps.
- This exercise uses the ReqApprovalxx.lpd process.

2. Select Workunit and Activity Level in the Log Level field.
3. Click OK.

Part 2: Attach process to ReqApproval service

1. Double-click the Infor Rich Client hcm icon on your desktop.
2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login. The Infor Rich Client application opens.
5. Select the apps10 data area.
7. Select Configuration > Service Definitions. The Service Definitions list displays.
8. Double-click the Req Approval service. The Service Definition form displays.
10. Type 4321 in the Company field.
11. Type xx in the Location field. The xx is your assigned user number.
13. Click Save.
14. Click X to close the Service Process Definition form.
15. Click X to close the Service Definitions list.
16. Click the minus (−) sign to minimize Infor Rich Client.

Note: There may be prerequisites within the Infor Lawson Application that need to be set for the service to initiate. For example the Requisition Approval Type must be set to 1-Header using ProcessFlow on the Inventory Control Company (IC01.1) or Requesting Location (RQ01.1) or Requester (RQ04.1) with the Infor Lawson Applications.

Demo: Testing your process

Your instructor will demonstrate how to test your process by triggering the service event and determining if the process ran successfully.

Exercise 9.2: Testing your process

In this exercise, you will test your process by triggering the service event and determining if the process ran successfully.
Exercise 9.2 steps

**Note:** Your assigned login number is identified as “xx” in the exercise steps.

**Part 1: Initiate the trigger**

1. Double-click the Infor Lawson for Infor Ming.le icon on your training desktop.
2. Type 10<xx>@gdeinfor2.com in the User name field.
3. Type Tr@in123 in the Password field.
4. Click Sign In. The Infor Lawson for Infor Ming.le home page opens.
5. Type RQ10 in the Search field.
6. Press Enter. The Requisition (RQ10.1) form displays.
7. Select ipa<xx> in the Requester field.
8. Click the Next arrow. A requisition record defaults.

**Part 2: Verify a workunit was created**

1. Click the Infor Rich Client icon in the system tray to open the application.
2. Select the apps10 data area if not already selected.
3. Select Process Server Administrator > Administration > WorkUnits > Workunits. The Workunits list displays. **Note:** A workunit was created for your process and the workunit is in a Processing status.
5. Click the User Actions tab.
6. Verify that the user action displays in an Action Awaiting status.
7. Click the minus (−) sign to minimize Infor Rich Client.

**Part 3: Take action**

1. Click the Infor Lawson for Infor Ming.le icon from your task tray to open the application.
2. Select Bookmarks > Inbasket > apps10. The bookmarks display.
3. Select My Work. The workunit item count displays under the My Work for ReqApprover<xx>A.
4. Select Approve on the top of the screen. The message “Approve completed successfully” displays.
5. Select My Work from the menu bar. The workunit information displays under the My Work tab. The workunit appears under the work for ReqApprover<xx>B task.
6. Select Approve on the top of the screen. The message “Approve completed successfully” displays.

**Part 4: Validate that the requisitions status was updated**

1. Type RQ10 in the Search field in Infor Lawson for Infor Ming.le.
2. Press Enter. The Requisition (RQ10.1) form displays.
3. Type ipa<xx> in the Requester field.
4. Type <your requisition number> in the Requisition Number field.
5. Click Inquire (or click Next). The status changes to Processed.

Part 5: Verify you received the email

1. Double-click the MailEnable icon in the training desktop. The MailEnable – Webmail Sign In window opens.
2. Type user<xx> in the Username field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Verify the email notifies you of the approval.

If you have errors, access the workunit in the Process Server Administrator, review the error logs. Make changes as needed and retest the process.

Part 6: Repeat for Approve/Reject and Reject actions

1. Select <your requisition number> from Part 4.
2. Click Inquire.
3. Click Next. An unreleased requisition displays for your requester.
5. Repeat steps for Part 2 – Part 5 to run the Approve/Reject and Reject actions.
Check your understanding

__________ are individual work items that are generated when a process runs.

a) Messages
b) Workunits
c) Notifications

Where would you go to view workunits that currently are awaiting action from a user?

a) Work History tab
b) Actions menu
c) Action Pending Workunits menu

Which field would you select in the Service Definition form’s Process tab to attach a process to a service definition?

a) Process Definition
b) Service Definition
c) Workunit Definition

Which of the following are components of a service? Select all that apply.

a) Service definition and criteria
b) Processes
c) Data areas
d) Service variables

Which status does the user action display in the Workunit form > User Action tab if it is awaiting approval?

a) Approval Needed
b) Action Awaiting
c) Supervisor Action
If you have errors on a workunit in the Process Server Administrator, where can you go to check the error information?

a) Landmark Grid  
b) Inbasket  
c) Error log
Lesson 10: Trigger process

Estimated time
1 ½ hours

Learning objectives
After completing this lesson, you will be able to:

- Describe how to trigger a new process within a process.

Topics
- Using the Trigger node
- Check your understanding
Using the Trigger node

The Trigger node triggers a process within another process, for example:

- **Sync process** – The parent process waits for the child process to complete before resuming.
- **Async process** – The parent process moves on after triggering the child process.

This lesson demonstrates how to modify a process to include a trigger. In order to learn how to trigger a process, we will review a scenario, demonstrate the process, and then complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use:

Requisition Approval Process with Work Object diagram

**Scenario**

Previously you built a process to approve requisitions. The organization requires any special (X) or services (S) that were approved and over $5000 be sent to the buyer to get three quotes. You will use the Trigger node to modify your Requisition Approval process and trigger an additional process if the special or service total is over $5000.

For this process, you will use the Trigger node.

**Demo: Build a process to trigger an additional process**

Your instructor will demonstrate how to build a process that will trigger off an additional process.
Exercise 10.1: Build a process to trigger an additional process

In this exercise, you will use the Trigger node to modify your Requisition Approval process and trigger an additional process if the special (X) or service (S) total is over $5000.

Exercise 10.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Modify your Requisition Approval process to trigger an additional process

1. Double-click Infor Process Designer.
2. Select the LSFapps10 in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Search and select your Requisition Approval process.
7. Click Download.
8. Select Desktop.
9. Type ReqApprovalWO<xx> in the Name field.
10. Click Save.
11. Click OK.
12. Click OK.
13. Click Close to close the Manage Processes window.

Part 2: Define the branch.

1. Select the blue connector arrow between the Approve node and the (Approve) Requester node.
2. Press Delete.
3. Click the Palette tab.
4. Select the Control folder to access the Branch node.
5. Click and drag Branch node between the Approve node and the Requester node.
6. Select Connection in the Palette.
7. Connect the Approve to the Branch node.
8. Select the Branch node. The Branch parameters window opens.
9. Click the plus (+) sign. The Condition Expression Builder opens and you can add a condition to the Branch node.
10. Type XSOver5000 in the Branch name field.
11. Type RQH_X_S_TOTAL > 5000.00 in the Branch Condition field.
12. Click OK.
13. Select the Branch node again.
14. Click the plus (+) sign. The **Condition Expression Builder** opens and you can add another condition to the **Branch** node.

15. Type `NotOver5000` in the **Branch name** field.

16. Type `true` in the **Branch Condition** field.

17. Click **OK**.

**Part 3: Create the additional process**

Creating an additional process needs to be completed and uploaded to identify what process the Trigger node will trigger.

1. Select **File > New Process File**. An untitled .lpd file opens. The **Start** and **End nodes** display in the **Process Editor**.

2. Click the **Palette** tab.

3. Click and drag the **Email** node from the **Notification** folder to the **Process Editor**. **Hint:** See the process diagram for placement.

4. Select the **Email** node. The **Email** node properties displays in the **Properties** panel.

5. Type the following values in the **Email node** properties:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>User&lt;xx&gt;@edu.com</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:RequisitionOrder@infor.com">RequisitionOrder@infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>Request requires quotes</td>
</tr>
<tr>
<td>Body</td>
<td>The requisition &lt;!RQH_REQ_NUMBER&gt; requires a quote. Please contact with the quote information.</td>
</tr>
<tr>
<td>On Error</td>
<td>Stop process</td>
</tr>
</tbody>
</table>

6. Select **Connection** in the **Palette**.

7. Select the **Start** node.

8. Select the **Email** node. A blue connector arrow appears between the two nodes.

9. Select the **Email** node again.

10. Select the **End** node. A blue connector arrow appears between the two nodes.

11. Select **File > Save As**.

12. Select **Desktop**.

13. Type `QuoteReq<xx>` in the **File name** field.

14. Click **Save**. The `QuoteReq<xx>` file is saved.

15. Select **Process > Upload** process. The process uploads to the Infor Landmark IPA server.
Part 4: Complete creating the Requisition Approval process

1. Click the ReqApprovalWO<xx> tab in the Process Editor.

2. Select the Control folder. You can now access the Trigger node.

3. Click and drag the Trigger node to the Process Editor between the Branch and the Requester (Approve) node.

4. Select the Trigger node. You can now define the parameters.

5. Select ProcessAsync in the Trigger Type field.


7. Click the Process Variables tab.

8. Select the following variables to pass.
   - RQH_BUYER_CODE
   - RQH_COMPANY
   - RQH_REQ_LOCATION
   - RQH_REQ_NUMBER
   - RQH_REQUESTER
   - RQH_X_S_TOTAL

9. Click the On Error tab.

10. Select the Continue process – Custom Log Entry radio button.

11. Select Connection in the Palette.

12. Select the Branch node.

13. Select the Trigger node selecting the XS Over 5000 condition. A blue connector arrow appears between the two nodes.

14. Select the Trigger node.

15. Select the Requester (Approve) node. A blue connector arrow appears between the two nodes.

16. Select the Branch node.

17. Select the Requester (Approve) node selecting the Not Over 5000 condition. A blue connector arrow appears between the two nodes.

18. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

19. Click Save.

20. Select Process > Upload process. The process is uploaded.

21. Click X to close Infor Process Designer.

Part 5: Modify the service definition

1. Log in to Infor Rich Client hcm.

2. Type lawson@gdeinfor2.com in the Username field.

3. Type Tr@in123 in the Password field.

4. Click Login.

5. Select the apps10 data area.


7. Click the magnifying glass icon.
8. Type Req Approval in the Search field.
10. Double-click Req Approval.
11. Double-click the Company 4321, Location <xx> line item. The Service Definition form opens.
12. Select ReqApprovalWO<xx> in the Process Definition field. Note: You are replacing the ReqApproval01 that is currently displayed.
13. Click Save.
14. Click X to close the Service Definition form.
15. Click X to close the Service Definition Lists.
16. Click the minus (–) sign to minimize Infor Rich Client screen.

Part 6: Test the process and begin triggering the initial requisition approval
1. Double-click Infor Lawson for Infor Ming.le icon on your training desktop.
2. Type 10<xx>@gdeinfor2.com in the User name field.
3. Type Tr@in123 in the Password field.
4. Click Sign In. The Lawson Home page opens.
5. Type RQ10 in the Search field.
6. Press Enter. The Requisition (RQ10.1) form displays.
7. Type or select requester ipa<xx> in the Requester field.
8. Click the Next arrow. A requisition displays.
9. Delete <the requisition number> from the Requisition Number field.
10. Verify that the requisition total amount displayed is over 5,000.
11. Click the Add icon. A requisition number appears.
12. Select Special Actions > Release. The requisition is released.

Part 7: Approve the requisitions and validate workunits
1. Select Bookmarks > apps10 > My Work in Infor Lawson for Infor Ming.le. Your list of workunits opens.
2. Select ReqApprover<xx>A.
3. Click Approve.
4. Select ReqApprover<xx>B.
5. Click Approve.
6. Click X to close Infor Lawson for Infor Ming.le.
7. Click Infor Rich Client in your task bar.
8. Select Start > Applications > Process Server Administrator > Administration > WorkUnits. You can review the workunit and verify that your additional processed was triggered.
9. Verify that a workunit was created for the QuoteReq<xx> process.
10. Click X to close Infor Rich Client.
Part 8: Check email

1. Double-click the MailEnable icon in the training desktop. The MailEnable – Webmail Sign In window opens.
2. Type user<xx> in the Username field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Verify the productline is included in the email.
Check your understanding

Identify the two ways to run a Trigger node:

- a) Async
- b) JSON
- c) Synch

This process is started without waiting for the parent process to complete.

- a) Async
- b) JSON
- c) Synch

This process is started after the parent process is completed.

- a) Async
- b) JSON
- c) Sync
Lesson 11: Infor Lawson query process

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:
- Describe how to build a process using the Infor Lawson Query node.

Topics
- Build a process using the Infor Lawson Query node
- Check your understanding
Build a process using the Infor Lawson Query node

The Infor Lawson Query node allows you to query Infor Lawson classic data within a process. This lesson demonstrates an example of how a process can be built to utilize the Infor Lawson Query activity node as well as other common activity nodes.

To learn how to build a query process, we will review a scenario, demonstrate the process, and then complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use:

Infor Lawson Query process diagram

Scenario

Build a process that finds purchase orders over $5000 and collects information about each purchase order. The flow separates the purchase orders into those with amounts between $5000 through $10000 and those amounts over $10000. The process will send emails with information on purchase orders (POs). No emails will be sent if there is no data over $5000 or $10000.

For this process, you will use the following nodes:

- Infor Lawson Query
- Branch
- Assign
- Msg Builder
- Email
- Break Points
Demo: Build an Infor Lawson query process

Your instructor will demonstrate how to build an Infor Lawson query process.

Exercise 11.1: Build an Infor Lawson query process

In this exercise, you will build an Infor Lawson query process.

Exercise 11.1 steps

Part 1: Define variables and save the file

1. Double-click Infor Process Designer.
2. Select the LSFapps10 in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Select the Start node. The properties for the Start node displays in the Properties panel.
7. Click the plus (+) sign to create a new variable. The Variable Expression Builder displays.
8. Type Count5K in the Variable Name field.
9. Select Integer from the Variable Type drop-down menu.
10. Type 0 in the Variable Value field.
11. Click OK.
12. Click the plus (+) sign to create another new variable.
13. Type Count10K in the Variable Name field.
14. Select Integer from the Variable Type drop-down menu.
15. Type 0 in the Variable Value field.
16. Click OK.
17. Select File > Save As. Note: Click Yes to save the process if validation errors exist.
18. Select Desktop.
19. Type LawsonPOQuery in the File name field.
20. Click Save. The file is saved.
After variables are established they cannot be switched when used further in the flow without the process being redone throughout.

Part 2: Lawson Query - Gather the purchase order information

1. Click the Palette tab.
2. Select the Infor Lawson folder to access the Query node.
3. Click and drag the Query node to the Process Editor. Hint: See the process diagram for placement.
4. Select Connection in the Palette.
5. Select the Start node.
6. Select the LwsnQuery node. A blue connector arrow will appear between the two nodes.
7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
8. Select the LwsnQuery node on the Process Editor. The LwsnQuery node properties display in the Properties panel.
9. Type POQuery in the ID field.
10. Type POQuery in the Name field.
11. Click Build. The Infor Lawson Process Query Builder form opens.
13. Select PO-Purchase Order in the Module Name field.
14. Select PURCHORDER in the Table field.
15. Double-click the following fields to add them to the Selected Fields window:
   - PO-DATE
   - PO-NUMBER
   - TOT-PRD-AMT
   - VENDOR
16. Click the arrow next to VENDOR in the Related Tables & Fields section.
17. Double-click LEGAL-NAME to move the field to the Selected Related Fields section.
18. Click the Criteria tab.
19. Double-click the Fields field next to PURCHORDER.
20. Select COMPANY in the Fields drop-down menu.
21. Select the equal (=) sign in the Operators field.
22. Type 4321 in the Value field.
23. Select TOT-PRD-AMT in the next row Fields drop-down menu.
24. Select greater than, equal (>=) in the Operators field.
25. Type 5000 in the Value field.
26. Click the Test tab.
27. Click Test API.
28. Click Finish
29. Highlight \texttt{PROD=APPS10} in the query string.
30. Type \texttt{PROD=<\textit{appProdLine}>} over the PROD=APPS10 entry to replace it.
31. Click the \texttt{On Error} tab.
32. Select the \texttt{Stop process} radio button.

Part 3: Branch - Make a determination if the total product amounts are under or over 10,000

1. Click the \texttt{Palette} tab.
2. Select the \texttt{Branch} node from the \texttt{Control} folder.
3. Click and drag the \texttt{Branch} node to the \texttt{Process Editor}, placing it next to the \texttt{POQuery} node.
4. Select \texttt{Connection} on the \texttt{Palette}.
5. Select the \texttt{POQuery} node.
6. Select the \texttt{Branch} node. A blue connector arrow appears between the two nodes.
7. Click \texttt{Select} in the \texttt{Palette} (or press Esc on your keyboard) to exit the connection mode.
8. Select the \texttt{Branch} node on the \texttt{Process Editor}. The \texttt{Branch} node \texttt{Properties} window opens.
9. Click the plus (+) sign in the \texttt{Properties}. The window defines a branch and the \texttt{Condition Expression Builder} displays.
10. Type \texttt{Over10K} in the \texttt{Branch name} field.
11. Type \texttt{POQuery\_TOT\_PRD\_AMT}\texttt{>=} \texttt{10000.00} in the \texttt{Branch condition} field.
12. Click \texttt{OK}.
13. Click the plus (+) sign. Another branch can be defined.
14. Type \texttt{Under10K} in the \texttt{Branch name} field.
15. Type \texttt{POQuery\_TOT\_PRD\_AMT}\texttt{<} \texttt{10000.00} in the \texttt{Branch condition} field.
16. Click \texttt{OK}.

Part 4: Assign – assign values to the record count variables

1. Select the \texttt{Assign} node from the \texttt{Control} folder in the \texttt{Palette}.
2. Click and drag the \texttt{Assign} node to the \texttt{Process Editor}.
3. Select \texttt{Connection} in the \texttt{Palette}.
4. Select the \texttt{Branch} node.
5. Select the \texttt{Assign} node. The \texttt{Select a Branch Condition} form displays.
6. Select \texttt{Over 10K} in the \texttt{Condition} field.
7. Click \texttt{OK}. A blue connector arrow appears between the two nodes.
8. Click \texttt{Select} in the \texttt{Palette} (or press Esc on your keyboard) to exit the connection mode.
9. Select the \texttt{Assign} node in the \texttt{Process Editor}. The \texttt{Assign} node \texttt{Properties} window opens.
10. Type \texttt{DefineCnt10k} in the \texttt{ID} field.
11. Type \texttt{Define10KrecordCnt} in the \texttt{Name} field.
12. Click the plus (+) sign. The \texttt{Variable Assignment} form displays.
13. Select \texttt{Count10K} in the \texttt{Variable name} field.
14. Type \texttt{Count10K+1} in the \texttt{Variable value} field.
15. Click OK.
16. Select the Assign node from the Control folder in the Palette.
17. Click and drag the Assign node to the Process Editor.
18. Select Connection in the Palette.
19. Select the Branch node.
20. Select the Assign node. The Select a Branch Condition form displays.
22. Click OK. A blue connector arrow appears between the two nodes.
23. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
24. Select the Assign node. The Assign node Properties window opens.
25. Type DefineCnt5K in the ID field.
26. Type Define5KrecordCnt in the Name field.
27. Click the plus (+) sign. The Variable Assignment form displays.
28. Select Count5K from the Variable name drop-down menu.
29. Type Count5K+1 in the Variable value field.
30. Click OK.

Part 5: Msg Builder – Gather data for purchase order over 10k and data for purchase orders over 5k

1. Select the Msg Builder node from the Data folder in the Palette.
2. Click and drag the Msg Builder node to the Process Editor next to the Define10KrecordCnt node.
3. Select Connection in the Palette.
4. Select the Define10KrecordCnt node on the Process Editor.
5. Select the Msg Builder node on the Process Editor. A blue connector arrow appears between the two nodes.
6. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
7. Select the Msg Builder node on the Process Editor. The Msg Builder node properties display in the Properties panel.
8. Type POData10K in the Name field.
9. Type DATA10K in the Variable name field.
10. Type the following in the Message field. (Press Ctrl + Space) to select the variables:
   - PO Date: $<IPOQuery_PO_DATE>
   - PO Number: $<IPOQuery_PO_NUMBER>
   - PO Vendor: $<IPOQuery_VENDOR>
   - PO Vendor Name: $<IPOQuery_VENDOR_LEGAL_NAME>
   - PO Amount: $<IPOQuery_TOT_PRD_AMT>
11. Right-click the Msg Builder node in the Process Editor.
12. Select Copy.
13. Right-click the Process Editor beside the Define5KrcdCnt node.
15. Select Connection in the Palette.
16. Select the Define5KrecordCnt node.
17. Select the copied Msg Builder node. A blue connector arrow appears between the two nodes.
18. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
20. Type POData5K in the Name field.
21. Type DATA5K in the Variable field. Do not make any changes to the existing Message content.
22. Select Connection in the Palette.
23. Select the POData10K node.
24. Select the End-POQuery node.
25. Select the POData5K node.
26. Select the End-POQuery node again. Both Msg Builder nodes are connected to the End-POQuery node.
27. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
28. Click Save. Note: The process isn't complete, therefore validation errors will occur. Click Yes, if a validation message displays.

Part 6: Branch – Build the decision to send the 10Kemail or the 5Kemail

1. Click the Palette tab.
2. Select the Branch node from the Control folder in the Palette.
3. Click and drag the Branch node to the Process Editor, to the right of the End-POQuery node.
4. Select Connection in the Palette.
5. Select the End-POQuery node.
6. Select the Branch node. A blue connector arrow appears between the two nodes.
7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
8. Select the Branch node on the Process Editor. The Branch node Properties window opens.
9. Click the plus (+) sign in the Properties window. The Condition Expression Builder form displays.
10. Type Records10KFound in the Branch name field.
11. Type Count10K>=1 in the Branch condition field.
12. Click OK.
13. Click the plus (+) sign in the Properties window.
14. Type Records10KNotFound in the Branch name field.
15. Type Count10K==0 in the Branch condition field. Note: The equal operator is == in Java.
16. Click OK. You will now add another Branch node to the Process Editor.
17. Select the Branch node in the Palette.
18. Click and drag the Branch node to the Process Editor, under the Branch node you had created in steps 1-16.
19. Select Connection.
20. Select the first Branch node you created.
21. Select the second Branch node you just added. The Select a Branch Condition form displays.
22. Select Records10KNotFound in the Condition field.
23. Click OK.
24. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
25. Select the second Branch node on the Process Editor. The Branch node Properties window opens.
26. Type Records5KFound in the Name field.
27. Click the plus (+) sign in the Properties window.
28. Type Records5KFound in the Branch name field.
29. Type Count5K>=1 in the Branch condition field.
30. Click OK.
31. Click the plus (+) sign in the Properties window. You can add another branch condition.
32. Type Records5KNotFound in the Branch name field.
33. Type Count5K==0 in the Branch condition field.
34. Click OK.
35. Click Save. (Click Yes to proceed with the save if validation errors exist.)

Part 7: Email – Email 10K and 5K data results
1. Click the Palette tab.
2. Select the Email node from the Notification folder in the Palette.
3. Click and drag the Email node to the Process Editor. Hint: See the process diagram for placement.
4. Select Connection in the Palette.
5. Select the Records10KFound branch node on the Process Editor.
6. Select the Email node. The Select a Branch Condition form displays.
7. Select the Records10KFound in the Condition field.
8. Click OK. A blue connector arrow appears between the Branch node and the Email node.
9. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
10. Select the Email node in the Process Editor. The Email node Properties window opens.
11. Type user<xx>@edu.com in the To field.
12. Press Ctrl + space in the From field.
13. Select _!configuration.system.mailFrom from the drop-down list.
14. Type LawsonQuery – 10K in the Subject: field.
15. Type The following <!Count10k> POs are in excess of $10,000: <!DATA10K> in the Body field.
16. Click the On Error tab.
17. Select the Continue process radio button.
18. Select **Custom Log Entry**.
19. Select **Connection** in the **Palette**.
20. Select the **Email** node on the **Process Editor**.
21. Select the **Records5KFound** node on the **Process Editor**.
22. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
23. Right-click the **Email** node in the **Process Editor**.
24. Select **Copy**.
25. Right-click under the **Email** node on the **Process Editor**.
26. Select **Paste**. There are now two **Email** nodes in the **Process Editor**.
27. Select **Connection** in the **Palette**.
28. Select the **Records5KFound Branch** node.
29. Select the **Email** node you just created. The **Select a Branch Condition** form displays.
30. Select **Records5KFound** in the **Condition** field.
31. Click **OK**.
32. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
33. Select the **Email** node you just created. The **Email node Properties** window opens.
34. Type **LawsonQuery – 5K** in the **Subject:** field.
35. Type **The following <!Count5K> POs are in excess of $5,000: <!Data5K>** in the **Body** field.
36. Click the **On Error** tab.
37. Select the **Stop Process** radio button.
38. Select **Connection** in the **Palette**.
39. Select the **Email** node you just created on the **Process Editor**.
40. Select the **End** node. A blue connector arrow appears between the Email and the End nodes.
41. Select the **Records5KFound Branch** node.
42. Select the **End** node. The **Select a Branch Condition** displays.
43. Select **Records5KNotFound** in the **Condition** field.
44. Click **OK**.
45. Click **Save**.

**Part 8: Test the query process and check email was received**

1. Click the **Run Process** arrow. The query runs.
2. Select the **No input data** radio button.
3. Click **OK**.
4. Double-click the **MailEnable** icon in the training desktop. The **MailEnable – Webmail Sign In** window opens.
5. Type **user<xx>** in the **Username** field.
6. Type **Tr@in123** in the **Password** field.
7. Click **Login**.

114  Lesson 11: Infor Lawson query process
© 2016 Infor Education
8. Review the email.

Appendix A of this Training Workbook contains an optional scenario that reviews how to modify a query using dates.
Check your understanding

Which of the following is true about creating variables using the Variable Expression Builder? Select all that apply.

a) Variables should not start with a number.
b) Variables are case sensitive.
c) Variables should not contain any spaces.

The _____________ allows you to query Infor Lawson classic data within a process.

a) Infor Lawson Query
b) Msg Builder
c) Branch
d) Break Points

Which activity node would you use when executing a loop in which multiple values might need to be stored?

a) Branch
b) Data Iterator
c) Msg Builder
Lesson 12: Web run process

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:
- Describe how to build a Web run process.

Topics
- Building a Web run process
- Check your understanding
Building a Web run process

The WebRun activity node allows you to initiate an executable in order to run an Infor Lawson application job through a process.

This lesson demonstrates how to create and execute an Infor Lawson job using a Web run process. To do this we will review a scenario, demonstrate the process, and then complete a hands-on exercise. The diagram below is a graphic representation of the process design we will use:

![Web run process diagram]

**Scenario**
In this scenario, you will use the Infor Lawson Transaction activity node to create a job in an Infor Lawson application and use the WebRun activity node to execute the job.

For this process, you will use the following nodes:
- Lawson Transaction
- WebRun

**Demo: Create and execute a Infor Lawson job**
Your instructor will demonstrate how to use the Lawson Transaction activity node to create a job in an Infor Lawson application and use the WebRun activity node to execute the job.

**Exercise 12.1: Create and execute a Infor Lawson job**
In this exercise, you will use the Lawson Transaction activity node to create a job in an Infor Lawson application and use the WebRun activity node to execute the job.
Exercise 12.1 steps

**Note:** Your assigned login number is identified as "xx" in the exercise steps.

**Part 1: Set up the Transaction node**
1. Double-click the **Infor Process Designer** icon on your training desktop.
2. Select the **LSFapps10** connection.
3. Type **Tr@in123** in the **Password** field.
4. Click **Login**.
6. Click the **Palette** tab to view the options.
7. Select the **Infor Lawson** folder to access the **Transaction** node.
8. Click and drag the **Transaction** node between the **Start** and **End** nodes.
9. Select **Connection** in the **Palette**.
10. Select the **Start** node.
11. Select the **Transaction (LwsnTxn)** node. A blue connector line appears between the two nodes.
12. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
13. Select the **Transaction (LwsnTxn)** node in the **Process Editor**.
14. Click **Build** in the **Properties** tab.
15. Type or select the following values using the information below:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Productline/Module/Token</td>
<td>APPS10 / IF / GL210</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Click Yes on any warning messages.</td>
</tr>
<tr>
<td>Method</td>
<td>Add</td>
</tr>
<tr>
<td>Selected Fields</td>
<td>COMPANY, JOB-NAME, USER-NAME</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Double-click to move to Selected Field section</td>
</tr>
<tr>
<td>Selected Fields Values</td>
<td>COMPANY=4321</td>
</tr>
<tr>
<td></td>
<td>JOB-NAME:GL21010&lt;xx&gt;</td>
</tr>
<tr>
<td></td>
<td>USER-NAME=LSF10\lawson</td>
</tr>
</tbody>
</table>

16. Click **Finish**.
17. Click the **On Error** tab.
18. Select the **Stop process** radio button.

**Part 2: Set up the Web run process**
1. Click the **Palette** tab.
2. Select the **Web/XML/JSON** folder to access the **Web Run** node.
3. Click and drag the **Web Run** node to the right of the **Transaction** node. **Hint:** See process diagram for placement.

4. Select **Connection**.

5. Select the **Transaction (LwsnTxn)** node in the Process Editor.

6. Select the **WebRun** node in the Process Editor. A blue connector arrow appears between the two nodes.

7. Click **Select** in the **Palette** (or press Esc on your keyboard) to exit the connection mode.

8. Select the **WebRun** node.

9. Type or select the following values to define the WebRun node property fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
</table>
| Override Connection | Override Information:  
Web root [https://lsf10.gdeinfor2.com](https://lsf10.gdeinfor2.com)  
User id: lawson@gdeinfor2.com  
Password: Tr@in123 |
| URL Type          | Infor Lawson                                                         |
| Web Program       | cgi-lawson/jobrun.exe                                                |
| Method            | POST                                                                 |
| Post String       | FUNC=run&USER=LSF10\lawson&JOB=GL21010xx&OUT=xml  
(where xx equals your assigned number)  
**Note:** The variable names and values to be entered are based on the syntax above, so it is specific to the job. |
| Content Type      | text/plain                                                           |

10. Click the **On Error** tab.

11. Select the **Stop process** radio button.

12. Select **Connection** in the **Palette**.

13. Select the **WebRun** node in the **Process Editor**.

14. Select the **End** node. A blue connector arrow appears between the two nodes.

15. Select **File > Save As**.

16. Save the process as **WebRunJob<xx>**.

17. Select **Process > Run**. The process runs.

18. Select **No Input Data**.

19. Click **OK**.

20. Click **X** to close the **Infor Process Designer**.
Part 3: Test your process

1. Double-click the Infor Lawson for Infor Ming.le icon on your training desktop.
2. Type lawson@gdeinfor2.com in the User name field.
3. Type Tr@in123 in the Password field.
4. Click Sign In.
5. Type GL210 in the search box.
6. Press Enter.
7. Select GL210<xx> in the Job Name field.
8. Click Inquire. The Company Listing (GL210) form opens.
9. Click Print Manager. Note: If you see your job’s output, the job ran successfully. If not, then check your process for issues and run it again.

Note: When submitting a job for an Infor Lawson program, you could also use the Java version for the call. The following is an example:

```
/lawson-ios/action/SubmitJob?jobName=CU201&jobOwner=PHLSF01115\lawson&startDate=&startTime=&jobQueue=&displayOldFormat=true&OUT=XML
```

You can find out the exact call string by creating a job and submitting it and then go to the host name?debug=true. This will launch a trace window that allows you to capture the call.
Check your understanding

Which activity node allows you to initiate a Java servlet in order to run a Lawson System Foundation application job through a process?

a) WebRun node
b) HRTM User Action
c) Infor Lawson Transaction

Which activity node would you use to create a record in a Lawson System Foundation application?

a) WebRun node
b) Infor Lawson Transaction
c) Decrypt
Lesson 13: User action process

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:

- Explain how to create a process that routes work to an employee’s supervisor.

Topics
- HRTM User Action Classic HR Application type
- HRTM User Action Infor Lawson HR and TM Application type
- Check your understanding
HRTM User Action Classic HR application type

A user action process can be designed for Infor Lawson or Landmark. In this lesson we will demonstrate an Infor Lawson example. You will see how the HRTM User action pulls the Classic HR supervisor based on the supervisor structure.

The diagram below is a graphic representation of the process design we will use:

![HRTM User Action process diagram]

Scenario: Create process to pull the classic Lawson System Foundation (LSF) HR supervisor

In this scenario, you will create a process that will pull the classic HR employee's supervisor based on the HR supervisor structure.

For this process, you will use the following nodes:

- HRTM User Action
- Email

Demo: Create process to pull the classic Lawson System Foundation (LSF) HR supervisor

Your instructor will demonstrate how to create a process that will pull the classic LSF employee’s supervisor based on the HR supervisor structure.
Exercise 13.1: Create a process to pull the classic LSF HR supervisor

In this exercise, you will create a process that will pull the classic LSF employee's supervisor based on the HR supervisor structure.

Exercise 13.1 steps

Note: Your assigned login number is identified as "xx" in the exercise steps.

Part 1: Create the variables

1. Double-click the Infor Process Designer icon on your training desktop.
2. Select the LSFapps10 connection.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Select the Start node. The properties for the Start node display in the Properties panel.
7. Click the plus (+) sign to create a new variable. The Variable Expression Builder opens.
8. Type COMPANY in the Variable Name field.
9. Select String from the Variable Type drop-down menu.
10. Type 4321 in the Variable value field.
11. Click OK.
12. Click the plus (+) sign to create another variable.
13. Type EMPLOYEE in the Variable Name field.
14. Select String from the Variable Type drop-down menu.
15. Type 10<xx> in the Variable Value field.
16. Click OK.

Part 2: Add an HRTM User Action node

1. Click the Palette tab.
2. Select the User Interaction folder in the Palette to access the HRTM User Action node.
3. Click and drag the HRTM User Action node to the Process Editor to the right of the Start node. Hint: See the process diagram for placement.
4. Select Connection in the Palette.
5. Select the Start node.
6. Select the HRTM User Action node. A blue connector arrow appears between the two nodes.
7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
8. Select the HRTM User Action node.
9. Type or select the following values to define the following HRTM User Action property fields:
Click the plus (+) sign to add an Action. The Action Builder opens.

Type Approve in the Action name field.

Click OK.

Select File > Save As.

Select Desktop.

Type HRClassicUser in the File name field.

Click Save. Note: Click Yes if a validation message displays.

Part 3: Add another HRTM User Action node

1. Select the User Interaction folder to access the HRTM User Action node.
2. Click and drag the HRTM User Action node to the Process Editor to the right of the UA1 node.
3. Select Connection in the Palette.
4. Select the UA1 node.
5. Select the HRTM User Action node you just added to the Process Editor. The Select a Branch Condition window opens.
6. Select the Approve condition.
7. Click OK.
8. Select the UA1 node again in the Process Editor.
9. Select the HRTM User Action.
10. Select the TimeOut condition.
11. Click OK.
12. Select the UA1 node again.
13. Select the End node.
14. Select the NotFound condition.
15. Click OK.
16. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
17. Select the HRTM User Action node in the Process Editor.
18. Type or select the following values to define the following HRTM User Action property fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>UA1</td>
</tr>
<tr>
<td>Name</td>
<td>UA1</td>
</tr>
<tr>
<td>Application Type</td>
<td>Classic HR</td>
</tr>
<tr>
<td>Company</td>
<td>COMPANY</td>
</tr>
<tr>
<td>Employee</td>
<td>EMPLOYEE</td>
</tr>
</tbody>
</table>

10. Click the plus (+) sign to add an Action. The Action Builder opens.

11. Type Approve in the Action name field.

12. Click OK.

13. Select File > Save As.


15. Type HRClassicUser in the File name field.

16. Click Save. Note: Click Yes if a validation message displays.

Part 3: Add another HRTM User Action node

1. Select the User Interaction folder to access the HRTM User Action node.
2. Click and drag the HRTM User Action node to the Process Editor to the right of the UA1 node.
3. Select Connection in the Palette.
4. Select the UA1 node.
5. Select the HRTM User Action node you just added to the Process Editor. The Select a Branch Condition window opens.
6. Select the Approve condition.
7. Click OK.
8. Select the UA1 node again in the Process Editor.
9. Select the HRTM User Action.
10. Select the TimeOut condition.
11. Click OK.
12. Select the UA1 node again.
13. Select the End node.
14. Select the NotFound condition.
15. Click OK.
16. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
17. Select the HRTM User Action node in the Process Editor.
18. Type or select the following values to define the following HRTM User Action property fields:
<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>UA2</td>
</tr>
<tr>
<td>Name</td>
<td>UA2</td>
</tr>
<tr>
<td>Application Type</td>
<td>Classic HR</td>
</tr>
<tr>
<td>Company</td>
<td>COMPANY</td>
</tr>
<tr>
<td>Employee</td>
<td>EMPLOYEE</td>
</tr>
</tbody>
</table>

19. Click the **plus (+) sign** to add an Action. The **Action Builder** opens.
20. Type **Approve** in the **Action name** field.
21. Click **OK**.
22. Click **Save. Note:** Click **Yes** if validation error message comes up.

**Part 4: Add the Email node**

1. Select the **Notifications** folder in the **Palette** to access the **Email** node.
2. Click and drag the **Email** node to the right of the **UA2** node.
3. Select **Connection** in the **Palette**.
4. Select the **UA2** node.
5. Select the **Email** node. The **Select a Branch Condition** window opens.
6. Select the **Approve** condition.
7. Click **OK**.
8. Select the **UA2** node again.
9. Select the **Email** in the Process Editor.
10. Select the **TimeOut** condition.
11. Click **OK**.
12. Select the **UA2** node again.
13. Select the **End** node.
14. Select the **NotFound** condition.
15. Click **OK**.
16. Select the **Email** node in the Process Editor.
17. Select the **End** node.
18. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
19. Select the **Email** node in the **Process Editor**.
20. Type or select the following values to define the **Email** settings fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>User&lt;xx&gt;@edu.com</td>
</tr>
</tbody>
</table>
Click the **On Error** tab.

22. Select the **Stop process** radio button.

23. Click **Save**.

24. Select **File > Close**.

This exercise requires a Close and a Reopen of Infor Process Designer to work.

### Part 5: Test the process

1. Select **File > Open Infor Process File**.
2. Select the **HRClassicUser.lpd** file.
3. Click **Open**.
4. Select **Process > Run**.
5. Select the **No input** data. The **User Action Simulation** window opens.
6. Select **Approve** in the **Take Action** field. You can also put something in the Reason Code and Message.
7. Click **OK**.
8. Select **Approve** in the **Take Action** field. You can also put something in the Reason Code and Message.
9. Click **OK**.
10. Review the Console tab to verify that the system returned your employee’s supervisor and your supervisor’s supervisor.

11. Double-click the MailEnable icon in the training desktop. The MailEnable – Webmail Sign In window opens.

12. Type user<xx> in the Username field.

13. Type Tr@in123 in the Password field.

14. Click Login.

15. Verify that you received the emails.
HRTM User Action Infor Lawson HR and TM Application Type

In the second of two exercises in this lesson we will demonstrate a Landmark example. You will see how the HRTM User Action pulls the Landmark Talent Manager (TM) supervisor (direct manager) based on the Landmark supervisor structure.

The diagram below is a graphic representation of the process design we will use:

Scenario

In this scenario, you will create a process that will pull the Landmark employee’s supervisor based on the Landmark TM supervisor structure.

Note: This is just an example of how the Landmark supervisor is pulled from the HRTM User Action node. In the next lesson, the Infor Landmark process includes an HRTM User Action that pulls the TM supervisor within an hcm service.

For this process, you will use the following nodes:

- Query
- HRTM User
- Assign

Demo: Find HCM resource’s direct supervisor

Your instructor will demonstrate how access a resource in hcm and identify the primary work assignment direct supervisor code and the actor associated with the supervisor.
Demo steps

1. Double-click the **Infor Rich Client hcm** icon on the desktop. The **Infor Rich Client** canvas opens.
2. Type `lawson@gdeinfor2.com` in the **Login Name** field.
3. Type `Tr@in123` in the **Password** field.
4. Click **Login**.
5. Select **Administrator > Resources > Resources**. The **Resources** list opens. **Note:** You can also type Resources in the search text box to access the Resources list.
6. Type `1101` in the **Employment ID** field. **Note:** Julie Hahn’s employee number is 1101.
7. Click **Search**. The **Julie Hahn** employee record is returned.
8. Double click **Julie Hahn**’s employee record. **Note:** The **At A Glance** page indicates her direct supervisor is Charles Adams.
9. Click the **Work Assignments** tab.
10. Double-click the record under the **Work Assignments** section. The record opens and shows that under the **Supervisor** section the **Direct Supervisor code** number is `2`, which is assigned to Charles Adams.
11. Click X to close the **Work Assignment** page.
12. Click X to close **Julie Hahn**’s employee record page.
13. Type `Actor` in the **Search** field. **Note:** The Search field is in the upper-right corner of the screen of the Resource list.
14. Press Enter. The list of business classes displays.
15. Select **Actor person/business class**. The **Actor** list opens.
16. Click the magnifying glass.
17. Type `Adams` in the **Last Name** field.
18. Type `Charles` in the **First Name** field.
19. Press Enter. Charles Adams’ employee record displays. **Note:** Charles Adams’ Actor ID is **IN01**.
20. Click X to close **Infor Rich Client**.

**Demo: Create a process to pull the Landmark HRTM Supervisor**

Your instructor will demonstrate how to create a process that will pull the employee’s supervisor based on the Landmark HRTM supervisor structure.
Lesson 13: User action process

© 2016 Infor Education

Exercise 13.2: Create a process to pull the Landmark HRTM Supervisor

In this exercise, you will create a process that will pull the employee’s supervisor based on the Landmark HRTM supervisor structure.

Exercise 13.2 steps

Part 1: Create variables

2. Double-click the Infor Process Designer icon on your training desktop.
3. Select the hcm connection.
4. Type Tr@in123 in the Password field.
5. Click Login.
7. Select the Start node. The properties for the Start node display in the Properties panel.
8. Click the plus (+) sign. The Variable Expression Builder displays and you can create a new variable.
9. Type ORGANIZATION in the Variable Name field.
10. Select String from the Variable Type drop-down menu.
11. Click OK.
12. Click the plus (+) sign to create another variable.
13. Type SUPERVISOR in the Variable Name field.
14. Select String from the Variable Type drop-down menu.
15. Click OK.
16. Select File > Save As. The Save As dialog window opens.
17. Select Desktop as the location to save the file.
18. Type TMLAndmkUser in the File name field.
19. Click Save. Click Yes to proceed to save if you receive a validation error. The Infor Process Designer (.lpd) file is saved to your training desktop.

Part 2: Pull your employee number from hcm

1. Select the Landmark Transaction node in the Palette. Hint: The Landmark Transaction node is located in the Infor Lawson folder.
2. Click and drag the Landmark Transaction node between the Start and End nodes.
3. Select Connection in the Palette.
4. Select the Start node.
5. Select the LMTxn node. A blue connector arrow appears between the two nodes.
6. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
7. Select the LMTxn node in the Process Editor.
8. Click **Build**.

9. Type or select the following values to define the properties:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>SUP</td>
</tr>
<tr>
<td>Name</td>
<td>GetSupervisor</td>
</tr>
<tr>
<td>Data Area</td>
<td>hcm</td>
</tr>
<tr>
<td>Module</td>
<td>hr</td>
</tr>
<tr>
<td>Object Name</td>
<td>Employee</td>
</tr>
<tr>
<td>Action</td>
<td>Find</td>
</tr>
<tr>
<td>Action Type</td>
<td>SingleRecordQuery</td>
</tr>
<tr>
<td>HROrganization</td>
<td>7000</td>
</tr>
<tr>
<td><strong>Note</strong>: To add literal values, select the field from the Selected Fields section and click the Set Field Value icon.</td>
<td></td>
</tr>
<tr>
<td>Employee</td>
<td>&lt;!inputData&gt;</td>
</tr>
<tr>
<td><strong>Note</strong>: Press Ctrl + space to select the value.</td>
<td></td>
</tr>
<tr>
<td>PrimaryWorkAssignmentDirectSupervisor</td>
<td></td>
</tr>
</tbody>
</table>

10. Click **OK**. The **Landmark Transaction Field Value Handling** form opens.

11. Select **Use Variable** for the **Data Area** field.

12. Type `<appProdline>` in the **Variable** field. **Note**: You can also press **Ctrl + space** to search for the value.

13. Click **OK**.

14. Click the **On Error** tab.

15. Select the **Stop process** radio button.

16. Select **Connection** in the **Palette**.

17. Select the **GetSupervisor** node.

18. Select the **End-GetSupervisor** node. A blue connector arrow displays between the two nodes. This completes the loop for the Landmark Transaction node.

19. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

20. Click **Save**. (Click yes if get validation errors).

**Part 3: Add the Assign node**

1. Click the **Palette** tab.
2. Click and drag the **Assign** node to the right of the **End-GetSupervisor** node. **Hint:** The **Assign** node is in the **Control** folder.

3. Select **Connection** in the **Palette**.

4. Connect the **End-GetSupervisor** to the **Assign** node. **Hint:** Select **Connection** in the **Palette**.

5. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

6. Select the **Assign** node.

7. Click the plus sign (+) in the **Properties** section. The **Variable Assignment** displays. **Note:** Now you can define the ORGANIZATION value.

8. Select **ORGANIZATION** in the **Variable** name.

9. Select **SUP_HROrganization** in the **Variable** value field.

10. Click **OK**.

11. Click the plus sign (+) in the **Properties** section. **Note:** Now you can define SUPERVISOR value.

12. Select **SUPERVISOR** in the **Variable** name.

13. Select **SUP_PrimaryWorkAssignmentDirectSupervisor**.

**Part 4: Add the HRTM User Action node**

1. Click the **Palette** tab.

2. Click and drag the **HRTM User Action** node to the right of the **Assign** node.

3. Select **Connection** in the **Palette**.

4. Select the **Assign** node.

5. Select the **HRTM User Action** node. A blue connector arrow displays between the two nodes.

6. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

7. Select the **HRTM User Action** node. The properties for the node displays in the **Properties** panel.

8. Click **Build**.

9. Type or select the following values for the **HRTM** properties:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>HCMUser</td>
</tr>
<tr>
<td>Name</td>
<td>HCMUser</td>
</tr>
<tr>
<td>Application Type</td>
<td>Infor Lawson HR + TM</td>
</tr>
<tr>
<td>Organization</td>
<td>ORGANIZATION</td>
</tr>
<tr>
<td>Supervisor</td>
<td>SUPERVISOR</td>
</tr>
<tr>
<td>Action</td>
<td>Approve</td>
</tr>
</tbody>
</table>

**Note:** ParentNotFound and TimeOut actions are delivered actions that are optional to use.
Part 5: Add the email node

1. Click the Palette tab.
2. Click and drag the Email node to the right of the HCMUser node.
3. Select Connection in the Palette.
4. Select the HCMUser node.
5. Select the Email node. The Select a Branch Condition opens.
6. Select the Approve condition.
7. Click OK.
8. Select the Email node. The properties for the node displays in the Properties panel.
9. Type or select the following values to define the Email node settings:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>User&lt;xx&gt;@edu.com</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:HRUserAction@infor.com">HRUserAction@infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>TM Landmark User Action</td>
</tr>
</tbody>
</table>

10. Click the On Error tab.
11. Select the Stop process radio button.
12. Connect the Email node to the End node.
13. Click Save.

Part 6: Test the process

2. Select the Use connector radio button.
3. Type 1101 in the Specify input data field.
4. Click OK.
5. Select the Approve action.
6. Type <a reason/message> in the Body field. Note: There are no set variables for the reason or message.
7. Click OK.
8. Review the console to verify that the system pulled your employee’s supervisor (supervisor = 2, User=IN01).
10. Type user<xx> in the Username field.
11. Type Tr@in123 in the Password field.
12. Click Login.
13. Review your email with the user actions output information.

   **Note:** In the email, the actor is **IN01** (this is the user the work is routed to) and the user is **lawson@gdeinfor2.com** (this is the user who took action).
Check your understanding

Which activity node would you use to pull classic Infor Lawson employee supervisor information?

- a) HRTM User Action
- b) Query
- c) Lawson Query

Which activity nodes would you use to pull the employee's supervisor based on the Landmark HRTM supervisor structure? Select all that apply.

- a) Lawson Query
- b) Landmark Transaction node
- c) HRTM User Action
Lesson 14: Infor Landmark process

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:

- Recognize the location of delivered Infor Landmark processes.
- Explain how to modify a delivered Infor Landmark process.

Topics
- Delivered Infor Landmark processes
- Modify a delivered Infor Landmark process
- Check your understanding
Delivered Infor Landmark processes

A set of Infor Landmark processes are delivered and included with the installation of Landmark. These processes reside in the Landmark environment at a path such as the following:

LMENV (or your environment) > src > hcm (or another productline) > pflows

Delivered Infor Landmark processes can be downloaded from the Process Server to the Infor Process Designer within the designer.
Modify a delivered Infor Landmark process

You may need to configure some delivered processes to meet your organization business needs. For many delivered processes, you also need to modify the process to determine how to handle error processing and notifications. For example, in many processes, Talent Management uses a default configuration to identify an email address to send Process Server errors. You will need to supply the email address to be the recipient of Process Server error messages sent by the system.

In this lesson your instructor will demonstrate how to modify a delivered Landmark termination process.

The diagram below is a graphic representation of the process design before the modifications:

![Delivered Termination process before modifications diagram]

The diagram below is a graphic representation of the process design after modifications:

![Delivered Termination process after modifications diagram]
Scenario

In this scenario, you will determine how to identify possible modification needed on delivered Landmark processes and modify a delivered Landmark termination process. You will also modify the process to include routing the request to the employee’s supervisor before the HR Representative gets notification of the request.

For this process, you will use the following nodes:

- User Action
- Landmark Transaction
- Email

Demo: Modify a delivered Infor Landmark termination process

Your instructor will demonstrate how to find a delivered Landmark process, define how to identify needed modifications to a delivered process, and modify a delivered termination process to include an HRTM User action.

Demo steps

Part 1: Download the Terminate process to your desktop

1. Double-click Infor Process Designer.
2. Select the hcm in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Select Tools > Manage Processes.
6. Select the Terminate process.
7. Click Download. Note: When you finish the download process the process will open up in the designer.
8. Select File > Save As to save the file.
10. Type Terminate in the File name field.
11. Click Save.
12. Click Close.

Part 2: Modification to the process – 1st modification

2. Open the Lesson14_Terminate00.lpd process in the IPAAattendees folder.
3. Review the following changes to the process:
   - Added a Landmark Transaction node after the Assign node. This node is used to find the employee’s direct supervisor.
   - Added an HRTM User Action node after the Landmark Transaction node and define the activity to route to the Supervisor for the resource.
Part 3: Modification to the process – 2nd modification

1. Review the changes made to capture Actors names for action request:
   - Added two Landmark Transaction nodes to get the actor’s name for the actors’ who took action on the request. (Employee’s supervisor and HR representative). Access the actor information from the output from the HRTM User Action node and User Action node.
   - Added an Email node after the Landmark Transaction node to identify who took action on the request and what action they took.

Part 4: Resolve issues to delivered process

1. Click the Process Issues tab.
2. Discuss the On Error tab issues that are the result of the delivered process default content, such as set the “On Error Processing” to “Must notify” and/or custom log and select Custom Log.
3. Discuss the Email tab.
4. Review the generic email addresses that come with the delivered process.
5. Select the Custom Log entry radio button to resolve outstanding issues.
6. Click Save.

Part 5: Upload the process

1. Select Process > Upload to upload your process.
2. Select the Workunit and Activity Level in the Log Level field.
3. Click OK.
4. Click the minus (−) sign to minimize the Infor Process Designer window.

   Selecting the Workunit and Activity level when uploading a process in a live/production environment will create a large log file so keep this in mind. In this demo, we will select the Workunit and Activity level for training purposes in a test environment.

Part 6: Attach the process to a service definition

2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click the magnifying glass.
7. Type Terminate in the Search field.
8. Press Enter.
10. Select Actions > Create in the Process tab section.
11. Type 7000 in the HROrganization field.
12. Search for the Lesson14_Terminate00.lpd in the Process Definition field.
13. Click Select.
14. Click Save.
15. Click X to close the Service Process Definition form.
16. Click X to close the Service Definition list.

Part 7: Terminate an employee

2. Type 1119 in the Employee ID field.
3. Press Enter. The Mathew Lincoln employee record is returned.
4. Double-click the Mathew Lincoln employee record to open. Review the Direct Supervisor. Note: This shows on the At A Glance page.
5. Click Terminate in the top of the employee’s profile. The Request To Terminate Mathew Lincoln – 1119 form opens.
6. Type or select the follow values in the Request To Terminate Mathew Lincoln – 1119 form.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effective Date</td>
<td>Today’s Date</td>
</tr>
<tr>
<td>Reason</td>
<td>RETIREMENT</td>
</tr>
<tr>
<td>Relationship Status</td>
<td>RETIRED</td>
</tr>
<tr>
<td>Termination Notice</td>
<td>Today’s Date</td>
</tr>
<tr>
<td>Comment</td>
<td>Employee won the Lottery! Retiring effective today!</td>
</tr>
</tbody>
</table>

7. Click Submit.
8. Click X to close Mathew Lincoln’s Profile page.
9. Click X to close the Resource Search list page.

Part 8: Validate workunit was created

1. Select Process Server Administrator > Administration > Workunits > Workunits.
2. Verify that the workunit was created. Note: The workunit should be in Processing status.
   a. You will take action as Charles Adams - Direct Supervisor in the next part of the exercise and the status should change to Complete.
3. Select Start > Log Off to log out as the lawson user in Infor Rich Client.

Part 9: Take action on a workunit as user Charles Adams

1. Double-click Infor Rich Client hcm on the training desktop.
2. Type IN01@gdeinfor2.com in the User Name field.
3. Type IN01 in the Password field. Note: Employee 1119’s Direct Supervisor – Charles Adams.
5. Select Start > My Inbasket. The Inbasket opens.
6. Double-click the n the **Work Items** tab. The workunit form opens.
7. Click **Approve**. The workunit no longer appears in the **Work Items** section.
8. Select **Start > Log Off**. You are logged off Infor Rich Client.

**Part 10: You will log back in to Infor Rich Client as lawson because the process requires the HR Administrator to also approve the termination and the lawson actor is assigned the HR Administrator task.**

1. Double-click **Infor Rich Client** in your training desktop.
2. Type **lawson@gdeinfor2.com** in the **Login Name** field.
3. Type **Tr@In123** in the **Password** field.
4. Click **Login**.
5. Select **Start > My Inbasket**. The **Inbasket** opens.
6. Select the **HR Administrator** in the **Task** section.
7. Double-click the **workunit** in the **Work Items** tab to open the form.
8. Click **Approve**. Notice that the workunit disappears from the Work Items section.
9. Click X to close the **Inbasket**.

**Part 11: Validate the workunit was completed and email sent**

1. Select **Administrator > Resources > Resources** in the **Infor Rich Client** canvas.
2. Type **1119** in the **Employee ID** field.
3. Press **Enter**.
4. Double-click the **1119** employee record.
5. Scroll down the **At A Glance** section to see your employee’s relationship status. The status is updated.
6. Click X to close **Infor Rich Client**.
7. Double-click the **Mail Enable** icon on the desktop.
8. Type **user00** in the **Username** field.
9. Type **Tr@in123** in the **Password** field.
10. Click **Login**.
11. Verify that you received an email with the users who took action and what action they took.
Check your understanding

Delivered Infor Landmark processes included with the installation of Landmark reside in an organization's ______ directory.

a) Environment  
b) Apps  
c) Graphics

Which of the following are examples of why an organization would modify a delivered Infor Landmark process? Select all that apply.

a) To change the default email address defined in email notifications on a delivered process  
b) To meet an organization's business needs  
c) To define how to handle error processing
Lesson 15: Scheduling

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:

- Identify the forms and features of the scheduler.
- Explain how to schedule a process.

Topics
- Schedule form
- My Actions form
- Schedule a process
- Check your understanding
Schedule form

Scheduling is done using the Schedule form. Features of the scheduler include the following:

- Multiple scheduling options
- Notification available
- Selection of time zone to run
- Actions when process failed to run
My Actions form

Any processes that you have scheduled are listed on the My Scheduled Actions tab which is on the My Actions form. Actions will remain listed as long as one or more of the following is true:

- There are more executions remaining (such as with a repeating schedule or a future schedule)
- There are triggers remaining (called Action Instances)
- There are failed triggers
Schedule a process

The Process Server Administrator allows you to schedule processes by:

- Service definition
- Process definition

In the exercise that follows you will schedule a process by process definition. The diagram below is a graphic representation of the process design we will use:

![Process schedule example diagram]

**Scenario**

In this scenario, you will create and schedule a process to capture all the failed workunits in the hcm data area.

For this process, you will use the following nodes:

- Landmark Transaction
- Msg Builder
- Email

**Demo: Build and schedule a process**

Your instructor will demonstrate how to schedule a process that captures all the failed workunits in the hcm data area.
Exercise 15.1: Build and schedule a process

In this exercise, you will build and schedule a process to capture all the failed workunits in the hcm data area.

Exercise 15.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Download a process to the desktop and upload to the server

1. Double-click the Infor Process Designer icon on your training desktop.
2. Select the hcm connection.
3. Type Tr@in123 in the Password field.
4. Click Login.
2. Go to the IPAAttendees folder on the desktop.
3. Select the Lesson15_SchFailedWU1011.lpd file.
4. Select File > Save As.
5. Select Desktop.
6. Type WorkUnit<xx> in the File name field.
7. Click Save.
8. Click the Email node.
9. Type user<xx>@edu.com in the To email address.
10. Click Save.
12. Select Workunit and Activity level in the Log Level field.
13. Click OK.

Part 2: Schedule a process by process definition

2. Click New. A new Process Trigger form opens. Note: You can also select Actions > Create.
3. Click the arrow next to the Process Name.
4. Select the WorkUnit<xx> process you uploaded to the server in Part 1, step 7.
5. Click Select.
6. Type <xx>Schedule in the Work Title field.
7. Click Save.
8. Click X to close the Process Trigger page. You return to the Process Triggers page.
9. Double-click your WorkUnit<xx> from the list in the Process Triggers page. The workunit opens.
10. Select Actions > Schedule. The Schedule form opens.
11. Type <xx>FailedWorkUnits in the Schedule Action Name field.
12. Type user<xx>@edu.com in the Email Address field.
13. Select Always in the Notify Type field.
14. Select Run Once in the Schedule Type field.
15. Change the time to schedule out 5 minutes in the First Time To Run field. Notice that the time is based on the server time. Note the current time that displays on your desktop image and schedule the process 5 minutes from that time).
16. Click Next.
17. Click Finish.

Part 3: View Actions and check email

1. Select Start > My Actions > My Scheduled Actions to view your schedule. Note: If the schedule is successful, it is removed from My Scheduled Actions and a workunit is created.
2. Select Process Server Administrator > Administration > WorkUnits > Workunits. The Workunits list opens.
3. Verify that a workunit was created.
4. Double-click the Mail Enable icon on the desktop.
5. Type user<xx> in the Username field.
6. Type Tr@in123 in the Password field.
7. Click Login.
8. Verify that you received your email. Fix any errors if needed and then reschedule if needed.
Check your understanding

Which form is used to set up a schedule?

a) My Actions form
b) Schedule form
c) Configuration form

Which form would you use to look for your scheduled processes?

a) Schedule form
b) My Actions form
c) Designer form

Identify the three conditions that would determine when a process remains listed on the My Actions form:

a) There are more executions remaining
b) There are completed tasks
c) There are triggers remaining
d) There are failed triggers

Identify the two ways you can schedule a process in Process Server Administrator.

a) Service Definition
b) Process Definition
c) Resource Definition

True or false? You can setup to only be notified when a scheduled process fails.

a) True
b) False
Lesson 16: SQL query and update process

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:

- Describe how to configure an SQL connection.
- Explain how to build an SQL query and update process.

Topics
- Connect to an SQL database
- SQL Query and SQL Transaction activity nodes
- Build an SQL query and update process
- Check your understanding
Connect to an SQL database

IPA uses JDBC drivers to connect to SQL databases.

As a convenience to customers, Infor Landmark Technology delivers the necessary .jar files and then installs them to required locations on the IPA server and the Infor Process Designer. The files delivered are listed in the table below:

<table>
<thead>
<tr>
<th>Platform</th>
<th>Jar files</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM™ DB2, UNIX™, and Windows</td>
<td>db2jcc4.jar, db2jcc4_license_cu.jar</td>
</tr>
<tr>
<td>Oracle ®</td>
<td>ojdbc7.jar, ojdbc6.jar</td>
</tr>
<tr>
<td>Microsoft™ SQL Server</td>
<td>sqljdbc4.jar</td>
</tr>
</tbody>
</table>

To verify that the files you need are installed, check in this location: LAENVDIR/install/jdbc

**Note:** Database vendors can change their driver file requirements at any time. For this reason, it is a good idea to check your database vendor's web site for the latest information about database drivers before you install. This is true even if your database drivers were delivered by Lawson.

**JDBC connections**

Below are examples of how to configure a JDBC connection on the server so that the connection is available for nodes that use the JDBC connection, such as the SQL Query and SQL Transaction node. This is vendor-specific information that is published by the vendor, however, this information is subject to change by the vendor. **Note:** Always check with your database vendor for the latest information.

<table>
<thead>
<tr>
<th>Platform</th>
<th>JDBC driver</th>
<th>Database URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM DB2 Version 9, UNIX and Windows</td>
<td>com.ibm.db2.jcc.DB2Driver</td>
<td>jdbc:db2://YourComputerName/YourDatabaseName</td>
</tr>
<tr>
<td>IBM DB2 Version 8, UNIX and Windows</td>
<td>COM.ibm.db2.net.DB2Driver</td>
<td>jdbc:db2://YourComputerName/YourDatabaseName</td>
</tr>
<tr>
<td>IBM DB2 on System i</td>
<td>COM.ibm.as400.access.AS400JDBCDriver</td>
<td>jdbc:as400://YourComputerName/YourDatabaseSchemaName</td>
</tr>
<tr>
<td>Oracle</td>
<td>ojdbc6.jar, ojdbc7.jar</td>
<td>Use the correct driver for the version of Infor Landmark that you use. More information is available on the Oracle web site. jdbc:oracle:drivertype:@database</td>
</tr>
</tbody>
</table>

**Note:** Use a thin driver type as this is pure Java and
<table>
<thead>
<tr>
<th>Platform</th>
<th>JDBC driver</th>
<th>Database URL</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>does not depend on the C library and is platform-independent. This requires that the Oracle server is configured with TCP/IP listener. Example: jdbc:oracle:thin@myhost:port:sid</td>
<td></td>
</tr>
<tr>
<td>Microsoft SQL Server 2005</td>
<td>com.microsoft.sqlserver.jdbc.SQLServerDriver</td>
<td>jdbc:sqlserver://Host:port;databaseName=databaseName</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> For customers upgrading from Microsoft SQL Server 2005 please note that the driver class name is not the same as it was for Microsoft SQL Server 2000. Both the class name and the URL prefix have changed</td>
<td></td>
</tr>
<tr>
<td>Microsoft SQL Server 2000</td>
<td>com.microsoft.jdbc.sqlserver.SQLSeverDriver</td>
<td>jdbc:microsoft:sqlserver://Host:port;databaseName=databaseName</td>
</tr>
</tbody>
</table>

**Class paths**

Drivers must be added to the class path, which is located in the Grid Management Configuration – Misc. Module Properties.

**Grid.app.classpath:** Copy any external jar file to this location (i.e., $LACFGDIR/LPS/jars)

*Miscellaneous module properties*
Class Path properties
SQL Query and SQL Transaction activity nodes

Earlier in the course, you were introduced to all of the activity nodes, including two data nodes related to SQL, the SQL Query and SQL Transaction activity nodes.

It is important to understand more detailed functionality for the SQL-related activity nodes. For example, the SQL Query activity node supports:

- Executing SQL queries
- Creating and executing SQL procedures
- Iteration through multiple result sets with each result set with multiple records

The SQL Transaction activity node can:

- Insert records
- Update record
- Delete records

In the exercise that follows you will configure an SQL connection and then use the SQL Query activity node to test the connection.

Demo: Review the JDBC connection for an SQL database

Your instructor will demonstrate how to review the JDBC connection for an SQL database.

Demo steps:

1. Double-click Infor Rich Client hcm.
2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login.
5. Select the Process Server Administrator.
6. Select Configuration > System Configuration Main configuration set.
7. Click the JDBC tab.
8. Review the following connection information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>JDBC Driver</td>
<td>com.microsoft.sqlserver.jdbc.SQLServerDriver</td>
</tr>
</tbody>
</table>
9. Click X to close Infor Rich Client.

**Demo: Define the JDBC driver on the Process Designer to make the connection to the SQL database.**

Your instructor will demonstrate how to define the JDBC driver on the Process Designer to make the connection to the SQL database.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database url</td>
<td>jdbc:sqlserver://lsf901:5005;databaseName=LSF901_APPS</td>
</tr>
<tr>
<td>User</td>
<td>LSF901_APPS</td>
</tr>
<tr>
<td>Password</td>
<td>lawson</td>
</tr>
</tbody>
</table>

Exercise 16.1: Define the JDBC driver on the Process Designer to make the connection to the SQL database.

In this exercise you will define the JDBC driver on the Process Designer to make the connection to the SQL database.

**Exercise 16.1 steps**

1. Double-click the Infor Process Designer icon on your training desktop.
2. Select the hcm connection.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click New. The Select JARs window opens.
7. Select the Desktop > IPAAAttendees folder.
8. Select sqljdbc41.jar.
9. Click Open.
10. Click OK. A message displays indicating that the changes you made will take effect only on restart.
11. Click Yes. The Infor Process Designer restarts.

**Demo: Configure an SQL database connection**

Your instructor will demonstrate how to configure the SQL database connection information on the Process Server.

---

**Exercise 16.2: Configure an SQL database connection**

In this exercise you will configure the SQL database and connection information on the Process Server.

**Exercise 16.2 steps**

1. Select the hcm in the **Connection** field.
2. Type Tr@in123 in the **Password** field.
3. Click **Login**.
4. Select **File > New Infor Process File**.
5. Click and drag the SQL Query node to the **Process Editor**. Hint: The SQL Query is in the **Data** folder.
6. Select the SQL Query node in the **Process Editor**. The node’s properties display in the **Properties** panel.
7. Click **Build**. The SQL Query Builder appears. This indicates you made a connection.
8. Click **Cancel** to close the SQL Query Builder. You will define the query in the next exercise.

⚠️ You do not have to select a configuration on the SQL Transaction node because the main configuration defaults if you do not select a specific configuration.
Build an SQL query and update process

In the exercise that follows you will build an SQL query to check a record. If the record does not exist, it is inserted. The diagram below is a graphic representation of the process design we will use:

**Scenario**

Build a process that will check an SQL database for an existing record. If the record is found, the result is sent via email. If the record does not exist, then an insert statement creates a new record in the SQL database.

For this process, you will use the following nodes:

- SQL Query
- SQL Transaction
- Branch
- Email

**Demo: Create an SQL query and update process**

Your instructor will demonstrate how to create a SQL query and update process.
Exercise 16.3: Create an SQL Query and update process

In this exercise, you will build a process that will check an SQL database for an existing record. If the record is found, the result is sent via email. If the record does not exist, then an insert statement creates a new record in the SQL database.

Exercise 16.3 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: SQL Query node

1. Select the SQL Query node in the Process Editor. The node’s properties display in the Properties panel.
2. Type SQLQuery in the ID field.
3. Type Run SQL Query in the SQL type field.
4. Click Build.
5. Double-click LSF901_APPS_Schema. A list of tables displays.
6. Scroll to find the PFIDATA table.
7. Double-click the PFIDATA table. A list of fields displays.
8. Select the Show schema check box.
9. Select the following fields below from the PFIDATA table.
   - OBJID
   - FIRST_NAME
   - LAST_NAME
   - USERFIELD1
   - USERFIELD2
   - USERFIELD3
10. Click the right-facing arrow Field button. The fields are added to the Select section:
11. Click the WHERE tab to add a filter condition.
   - Filter Condition: OBJID= (select variable) <!_inputData>
12. Click the arrow to add this as a filter Condition
13. Click OK.
14. Click Generate Statement.
15. Click Execute Statement.
16. Type 10<xx>, in the Value field next to the <!_inputData> variable.
17. Click OK. The SQL statement results window opens with the results. Note: Your user record should not be in this database. You are adding your user to this database from the process.
18. Click Finish.
19. Click the On Error tab.
20. Select Continue process.
21. Select Notify.
22. Type user<xx>@edu.com in the To: field.
23. Type SQLQueryprocess@infor.com in the From field.
24. Select Connection in the Palette.
25. Select the Start node.
26. Select the SQLQuery node. A blue connector arrow appears between the two nodes.
27. Select the SQLQuery node.
28. Select the End-SQLQuery node to close the loop.
29. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
30. Select File > Save As. The file is saved. Note: If a message appears that validation errors exist, click Yes.
31. Type SQLQueryUpdate.lp in the File name field.
32. Click Save.

Part 2: Add a Branch node
1. Click the Palette tab.
2. Click and drag a Branch node and place it to the right of the End-SQL Query node. Hint: See the process diagram for placement.
3. Select Connection in the Palette.
4. Select the End-SQLQuery node.
5. Select the Branch node. A blue connector arrow appears between the two nodes.
6. Select the Branch node.
7. Click the plus (+) sign in Properties. The Condition Express Builder opens.
8. Type NoRecordsFound in the Branch name.
9. Type or select SQLQuery_RECORD_COUNT ==0 in the Branch condition field.
10. Click OK.
11. Click the plus (+) sign in Properties.
12. Type RecordsFound in the Branch name field.
13. Type SQLQuery_RECORD_COUNT !=0 in the Branch condition field.
14. Click OK.
15. Click Save.

Part 3: Add a SQL Transaction node
1. Click the Palette tab.
2. Click and drag the SQL Transaction node to the right of the Branch node. Hint: See the process diagram for placement.
3. Select the SQLTxn node. The properties for the node appears in the Property panel.
4. Type SQLUpdate in the ID field.
5. Click Build. The SQL Transaction Query Builder opens.
6. Select the **INSERT** radio button in the **Statement Type** section.

7. Click **Yes** to the **Change SQL Statement Type** message.

8. Double-click **LSF901_APPS_Schema**. A list of tables displays.

9. Select the **PFIDATA** table.

10. Select the **Show Schema** radio button.

11. Click the right-facing arrow **Table** button. The table is added.

12. Click the **SET** tab.

13. Type or select the following values in the **Values** tab fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>OBJID</td>
<td>(select variable) &lt;_inputData&gt;</td>
</tr>
<tr>
<td>FIRST_NAME</td>
<td><em>Your First Name Hint</em>: Wrap your entry in single quotes, e.g., 'John'</td>
</tr>
<tr>
<td>LAST_NAME</td>
<td><em>Your Last Name</em></td>
</tr>
<tr>
<td>USERFIELD1</td>
<td><em>Whatever you want (max 10 characters)</em></td>
</tr>
<tr>
<td>USERFIELD2</td>
<td><em>Whatever you want (max 10 characters)</em></td>
</tr>
<tr>
<td>USERFIELD3</td>
<td><em>Whatever you want (max 20 characters)</em></td>
</tr>
</tbody>
</table>

14. Click **Generate Statement**.

15. Click **Finish**. (Do not execute statement as it will do the execution on the database.)

16. Click the **On Error** tab.

17. Select **Continue process**.

18. Select **Notify**.

19. Type **user<xx>@edu.com** in the **To**: field.

20. Type **SQLQueryprocess@infor.com** in the **From** field.

21. Select **Connection** in the **Palette**.

22. Select the **Branch** node.

23. Select the **SQLTxn** node. A blue connector arrow displays between the two nodes.

24. Select the **NoRecordsFound** condition.

25. Click **OK**.

26. Click **Save**.

**Part 4: Email node**

1. Click and drag an **Email** node to the right of the **SQLTxn** node. **Note**: See process diagram for placement.

2. Select **Connection** in the **Palette**.

3. Select the **SQLTxn** node.
4. Select the **Email** node. A blue connector arrow displays between the two nodes.
5. Select the **Email** node.
6. Select the **End** node. A blue connector arrow displays between the two nodes.
7. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
8. Select the **Email** node.
9. Type or select the following values to the **Record Successfully Added Email** node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>User&lt;xx&gt;@edu.com</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:ProcessAutomation@infor.com">ProcessAutomation@infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>SQL record added</td>
</tr>
<tr>
<td>Body</td>
<td>Record &lt;!_inputData&gt; was successfully added.</td>
</tr>
<tr>
<td>On Error</td>
<td>Stop Process</td>
</tr>
</tbody>
</table>

10. Click and drag another **Email** node below the first **Email** node. **Note:** See the process diagram for placement.
11. Select **Connection** in the **Palette**.
12. Select the **Branch** node.
13. Select the **Email** node. A blue connector arrow displays between the two nodes.
14. Select the **RecordsFound** condition.
15. Click **OK**.
16. Select the second **Email** node. **Note:** This is the node from step 10 above you just dragged to the Process Editor.
17. Type or select following values for **Record Exists Email** node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>User&lt;xx&gt;@edu.com</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:ProcessAutomation@infor.com">ProcessAutomation@infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>SQL record exists</td>
</tr>
</tbody>
</table>
| Body     | Record <!_inputData> already exists.  
           <!SQLQuery_RETURN_MSG>           |
| On Error | Stop Process                          |

18. Select Connection in the Palette.
19. Select the **Email** node.
20. Select the **End** node. A blue connector arrow displays between the two nodes.
21. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
22. Select File > Save. The process file is saved.

Part 5: Run the process and check email

2. Select the Use Connector radio button.
3. Type 10<xx> in the Specify input data field.
4. Click OK.
5. Click X to close the SQLQueryUpdate process.
6. Double-click the Mail Enable icon on the desktop.
7. Type user<xx> in the Username field.
8. Type Tr@in123 in the Password field.
9. Click Login. Verify you receive the email that the user exists. If not, run the process again.
10. Repeat part 5, steps 1-4 above to run the process again.
11. Re-verify you receive the email that the user exists.
Check your understanding

Which type of file does Infor Landmark deliver and install on the IPA server and on the Infor Process Designer in order to support a connection to the SQL database?

a) .txt
b) .XML
c) .jar

Which type of connection does IPA use to connect to the SQL database?

a) ReST
b) JDBC
c) SOAP

Which of the following are supported by the SQL Query activity node? Select all that apply.

a) Executing SQL queries
b) Inserting records
c) Creating and executing SQL procedures
d) Iteration through multiple result sets with each result set with multiple records

Which of the following are supported by the SQL Transaction activity node? Select all that apply.

a) Insert record
b) Delete record
c) Update record
d) Execute SQL queries

True or false? Drivers must be added to the class path.

a) True
b) False

Which type of activity node would you use to insert a record in a SQL database as part of a process?

a) SQL Transaction
b) SQL Query
c) User Action
Lesson 17: System command and FTP

Estimated time
1 ½ hours

Learning objectives
After completing this lesson, you will be able to:
- Describe how to set up and execute a system command.

Topics
- Define system command LSF configuration
- Define file transfer LSF configuration
- Build an LSF system command and FTP process
- Check your understanding
Define system command LSF configuration

You can run an LSF system command in IPA. To do so, you must first set up the Process Server to be configured to identify the LSF.

In the first of two demos in this lesson, your instructor will demonstrate how to create the system command configuration for LSF.

Demo: Create a system command configuration
Your instructor will demonstrate how to create a system command configuration to LSF.

Demo steps

1. Double-click Infor Rich Client hcm on the training desktop.
2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login. The Infor Rich Client canvas opens.
5. Select Start > Applications > Process Server Administrator > Configuration > System Configuration.
6. Double-click the Main configuration set. The Main configuration form opens.
7. Click the Sys Cmd tab. Note: The connection information has already been defined.
8. Select Actions > Open to review the connection information.
9. Verify that the Remote check box is checked.
10. Verify the following information is defined on the form:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>LSF Web Root</td>
<td><a href="https://lsf10.gdeinfor2.com">https://lsf10.gdeinfor2.com</a></td>
</tr>
<tr>
<td>Web User</td>
<td><a href="mailto:lawson@gdeinfor2.com">lawson@gdeinfor2.com</a></td>
</tr>
<tr>
<td>Web Password</td>
<td>Tr@in123</td>
</tr>
<tr>
<td>Run as user</td>
<td>lawson</td>
</tr>
<tr>
<td>Run as user password</td>
<td>Tr@in123</td>
</tr>
</tbody>
</table>

11. Click X to close the record.
Define file transfer LSF configuration

You can run a file transfer command in IPA. To do so, you must first set up the process server to be configured to identify the LSF.

In the second demo in this lesson, your instructor will demonstrate how to create a file transfer configuration for LSF.

Demo: Create a file transfer configuration

Your instructor will demonstrate how to create a file transfer configuration for LSF.

Demo steps

2. Double-click the Main configuration set.
3. Click the File Transfer tab. Note: The connection information is already defined.
5. Review the connection information.
6. Verify the following values are defined:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host</td>
<td>lsf10.gdeinfor2.com:21</td>
</tr>
<tr>
<td>Protocol</td>
<td>Ftp</td>
</tr>
<tr>
<td>User</td>
<td>lawson</td>
</tr>
<tr>
<td>Password</td>
<td>Global08</td>
</tr>
</tbody>
</table>

7. Click Save.
8. Click X to close Infor Rich Client.
Build an LSF system command and FTP process

The System Command activity node is a very powerful tool that allows you to drop to the operating system (OS) level and execute any command or script. The FTP node provides a way to transfer files from one machine to another within a process.

System command and FTP process diagram

Scenario
In this scenario, you will use the System Command node to dump LSF data and create a .csv file and then transfer the file from the LSF server to the Landmark server.

For this process, you will use the following nodes:
- System Command
- FTP
- Email

Demo: Build a system command and FTP transaction process
Your instructor will demonstrate how to build a system command and FTP process to dump currency codes table from an Infor Lawson General Ledger application and create a .csv file in LSF. Then the process will transfer the file from LSF to Landmark.
Exercise 17.1: Build a system command and FTP transaction process

In this exercise, you will build a system command and FTP process to dump currency codes table from an Infor Lawson General Ledger application, create a csv file in LSF and transfer the file from LSF to Landmark.

Exercise 17.1 steps

Note: Your assigned login number is identified as "xx" in the exercise steps.

Part 1: Define the SysCommand node
1. Double-click the Infor Process Designer on the training desktop.
2. Select the LMRK10 hcm connection.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click and drag the System Command node to the Process Editor between Start and End. Hint: The System Command code is in the Control folder.
7. Select Connection in the Palette.
8. Select the Stop node.
9. Select the SysCommand node. A blue connector arrow appears between the two nodes.
10. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
11. Select the SysCommand node. The node’s properties display in the Properties panel.
12. Type or select the following values for the SysCommand node properties:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>SYS</td>
</tr>
<tr>
<td>Execution mode</td>
<td>run cmd.exe (Windows only)</td>
</tr>
<tr>
<td>Command</td>
<td>rmgdbdump -c APPS10 CUCODES &gt;\lsf10\launt\LSF10ClassFiles\xx\CUCODES.csv Replace &quot;xx&quot; with your assigned number.</td>
</tr>
</tbody>
</table>

13. Click the On Error tab.
14. Select the Stop process radio button.

Part 2: Define the FTP node
1. Click the Palette tab.
2. Click and drag the FTP node to the Process Editor to the right of the SysCommand node. Hint: The FTP node is in the Data folder.
3. Select Connection in the Palette.
4. Select the SysCommand node.
5. Select the FTP node. A blue connector arrow appears between the two nodes.
6. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
7. Select the FTP node. The node’s properties display in the Properties panel.
8. Type or select the following values for the Source file in the Properties tab:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Transfer</td>
</tr>
<tr>
<td>File name</td>
<td>LSF10ClassFiles/xx/CUCODES.csv</td>
</tr>
<tr>
<td></td>
<td>Replace “xx” with your assigned number.</td>
</tr>
</tbody>
</table>

9. Select the Is source remote check box.
10. Type or select the following values for the Destination file in the Properties tab:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>S:\xx\LSFCUCODES.csv</td>
</tr>
<tr>
<td></td>
<td>Replace “xx” with your assigned number.</td>
</tr>
</tbody>
</table>

11. Select Auto in the Transfer Options - File Transfer Mode section.
12. Click the On Error tab.
13. Select the Stop process radio button.

Part 3: Add and define an Email node
1. Click and drag the Email node to the right of the FTP node.
2. Select Connection in the Palette.
3. Select the FTP node.
4. Select the Email node. A blue connector arrow appears between the two nodes.
5. Select the Email node.
6. Select the End node. A blue connector arrow appears between the two nodes.
7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
8. Select the Email node. The Email node’s properties display in the Properties panel.
9. Type or select the following values for the Email node properties:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>user&lt;xx&gt;@edu.com</td>
</tr>
<tr>
<td>From</td>
<td><a href="mailto:SystemExecution@infor.com">SystemExecution@infor.com</a></td>
</tr>
<tr>
<td>Subject</td>
<td>LSF System Command CSV</td>
</tr>
<tr>
<td>Field</td>
<td>Value</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Body</td>
<td>System Command Output:</td>
</tr>
<tr>
<td></td>
<td>ErrorCode- &lt;!SYS_errorCode&gt;</td>
</tr>
<tr>
<td></td>
<td>ErrorOutput- &lt;!SYS_errorOutput&gt; InformationCode- &lt;!SYS_informationCode&gt; OutputData- &lt;!SYS_outputData&gt;</td>
</tr>
<tr>
<td></td>
<td>ReturnMessage- &lt;!SYS_returnMessage&gt;</td>
</tr>
</tbody>
</table>

10. Click the **On Error** tab.
11. Select the **Stop process** radio button.

**Part 4: Save the file, run the process and validate file was created**

1. Select **File > Save As**.
2. Save the file as **LSFSystemCommand<xx>** in the File Name field.
3. Click **Save**. The file is saved.
4. Select **Process > Run**.
5. Select the **No Input data** radio button.
6. Click **OK**.
7. Double-click the **LSF10ClassFiles** shortcut on the desktop. The folder opens with a list of files.
8. Select your **<xx> folder**. Verify your file exists.
9. Double-click the **LMRK10ClassFiles** shortcut on the desktop.
10. Select the **<xx> folder**. Verify your file exists.
Check your understanding

In order to run an LSF system command in IPA you must first:

a) Set up the process server to identify the system command server information for LSF.
b) Configure the Infor Rich Client to recognize LSF.
c) Move the platform from LSF to Landmark.

Which activity node would you select to create an FTP process?

a) System command node
b) FTP node
c) Email

Which activity node permits a user to work in the operating system (OS) level and execute any command or script?

a) FTP node
b) System Command node
c) XML node
Lesson 18: Data iteration and file access

Estimated time
1 ½ hours

Learning objectives
After completing this lesson, you will be able to:

- Explain how to build a process using Data Iterator and File Access activity nodes.

Topics
- Data Iterator activity node
- File Access activity node
- Build a Data Iterator and File Access process
- Check your understanding
Data Iterator activity node

The Data Iterator activity node allows you to parse a file based on several options. Additionally, this node provides the capability to iteratively read the data in a variable or file, looking for specific data or data parameters that can then be used as part of a business process.
File Access activity node

The File Access activity node allows you to read, write, append, delete or check if a file exists. You can configure the File Access node and create configuration sets to identify connection parameters.

One of the actions in the File Access activity node is to list files that match the file name pattern specific in the file name filter field. Files that are not modified within some period of time are not listed.

The File Access Check time is the time value to check if the file has been modify so it can be listed. Time value is in seconds.

File Access System Configuration

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>fileAccessCheckTime</td>
<td></td>
</tr>
</tbody>
</table>
Build a Data Iterator and File Access process

Configuration sets can be created to identify LSF connection parameters. If the file is located on the Process Server, no specific connection parameters are needed. The directory path or file can be identified within the properties of the File Access node.

In the exercise that follows you will build a process that uses both the Data Iterator and File Access nodes. The diagram below is a graphic representation of the process design we will use:

![Data Iterator process diagram]

**Scenario: Parse file by delimiter**

In this scenario, you will use a LSFCUCODES.csv file and parse this file by the delimiter string. You will use the File Access node to write the output to a new file.

For this process, you will use the following nodes:

- Data Iterator
- File Access
- Msg Builder

**Demo: Parse file by delimiter**

Your instructor will demonstrate how to use the LSFCUCODES.csv file located in the IPAAttendees folder and parse this file by the delimiter string. You will also see how to use the File Access node to write the output to a new file.
Exercise 18.1: Parse file by delimiter

In this exercise, you will use the LSFCUCODES.csv file and parse this file by the delimiter string. You will use the File Access node to write the output to a new file.

Exercise 18.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Create the output variable file

1. Double-click **Infor Process Designer icon on your desktop.**
2. Select the **LMRK10 hcm** in the **Connection** field.
3. Type **Tr@in123** in the **Password** field.
4. Click **Login**.
5. Select **File > New Infor Process File**.
6. Select the **Start** node.
7. Type or select the following values in the **Start node Properties**:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable Name</td>
<td>OutputFileName</td>
</tr>
<tr>
<td>Variable Type</td>
<td>String</td>
</tr>
<tr>
<td>Variable Value</td>
<td>“Data10xx.txt” Replace “xx” with your assigned number.</td>
</tr>
</tbody>
</table>

8. Click and drag the **Data Iterator** node to the **Process Editor** between **Start** and **End**. **Hint**: The **Data Iterator** node is in the **Data** folder.
9. Select **Connection** in the Palette.
10. Select the **Start** node.
11. Select the **DataIterator** node. A blue connector arrow appears between the two nodes.
12. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
13. Select the **DataIterator** node.
14. Type or select the following values for the

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>DI1</td>
</tr>
<tr>
<td>Input Method</td>
<td>File</td>
</tr>
<tr>
<td>Input file</td>
<td>\lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\LSFCUCODES.csv Replace “xx” with your assigned number.</td>
</tr>
</tbody>
</table>
15. Click the **On Error** tab.

16. Select the **Stop process** radio button.

17. Click the **Palette** tab.

18. Click and drag the **Msg Builder** node to the **Process Editor** between the **Datalterator** and **End-Datalterator** nodes. **Hint:** See the process diagram for placement.

19. Select **Connection** in the **Palette**.

20. Select the **Datalterator** node.

21. Select the **MsgBuilder** node. A blue connector arrow appears between the two nodes.

22. Select the **MsgBuilder** node.

23. Select the **End-Datalterator** node. A blue connector arrow appears between the two nodes.

24. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

25. Select the **MsgBuilder** node.

26. Type or select the following values for the **MsgBuilder** node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable Name</td>
<td>ParsedCucodes</td>
</tr>
<tr>
<td>Message</td>
<td>&lt;![CDATA[&lt;!DI1_outputData&gt;]]&gt;</td>
</tr>
</tbody>
</table>

27. Click the **Palette** tab.

28. Click and drag the **FileAccess** node to the **Process Editor** to the right of the **End-Datalterator** node. **Hint:** See the process diagram for placement.

29. Select **Connection** in the **Palette**.

30. Select the **End-Datalterator** node.

31. Select the **FileAccess** node. A blue connector arrow appears between the two nodes

32. Select the **FileAccess** node.

33. Select the **End** node. A blue connector arrow appears between the two nodes

34. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.

35. Select the **FileAccess** node.

36. Type or select the following values for the **FileAccess** node:
Field | Value
--- | ---
Execution mode | Append to File
Output File | \lmrk10.gdeinfer2.com\LMRK10ClassFiles\xx\<!OutputFile Name>
Input data | <!ParsedCucodes>

37. Click the **On Error** tab.
38. Select the **Stop process** radio button.
39. Select **File > Save As**.
40. Select Desktop.
41. Type **DataltrFileAccess** in the **File Name** field.
42. Click **Save**. The file is saved.

**Part 2: Run the process and validate file creation**

1. Select **Process > Run**.
2. Select **No input data**.
3. Double-click the **LMRK10ClassFiles** shortcut.
4. Select your `\LMRK10ClassFiles\<xx>` folder.
5. Verify the file appears.

**Note:** If there is no file:
- Check your Process Issues tab in Infor Process Designer to resolve any issues.
- Repeat the following steps to run the process again.
  a. Select **Process > Run**.
  b. Select **No input data**.
  c. Double-click the **LMRK10ClassFiles** shortcut icon.

**Appendices B, C, and D of this Training Workbook contains optional scenarios related to the Data Iterator process:**
- **Update an Actor’s roles in Landmark Security**
- **Update a Lawson Resource’s groups in LSF Security**
- **Create a Vendor in Infor Lawson Account Payable application**
Check your understanding

The ______________ activity node allows you to parse data in a file.

a) File Access  
b) Data Iterator  
c) For Each

Which field in the Data Iterator specifies the method by which the data stream is parsed?

a) Caption  
b) Delimiter string  
c) Parse by

The ________ is the time value to check if the file has been modify so it can be listed.

a) File Access activity node  
b) File Access Check Time  
c) File Access Record Time

Which of the following are functions of the File Access activity node? Select all that apply.

a) Read file  
b) Write file  
c) Append to a file  
d) Delete file  
e) Check if a file exists
Lesson 19: File channels

Estimated time
2 hours

Learning objectives
After completing this lesson, you will be able to:
- Describe the purpose of channels.
- Explain how to set up a file channel and receiver for a local file.

Topics
- Channels and receivers
- Properties that affect file channels
- File channels process
- Check your understanding
Channels and receivers

Channels provide a means of one-way communication between IPA and external sources. Information received via channels is used to create and trigger workunits. The receiver identifies the messages or content accepted and the process to be initiated.

Currently IPA provides channels for the following types of external sources:

- Files (local or remote)
- Java Messaging Service (JMS)
- Event Hub (Infor M3 Messages)
- ION Connect Business Object Documents (BODs)

**Note:** Appendix G of this Training Workbook contains detailed information about JMS.

Each channel that is defined represents a link to a single outside source of messages or other content. A channel may have only one receiver, or may have multiple receivers as shown in the diagram below:

To define a channel, use the Channels administration tool available through the Infor Rich Client.

*For more information on configuring channels and receivers for use with IPA, refer to the Infor Process Automation Administration Guide.*
Properties that affect file channels

The fileChannelsMonitorLoopInterval, a SystemConfiguration property, controls how often the FileChannelsMonitor program scans directories.

The fileChannelsMonitorLoopInterval value overrides any lesser scan time on a specific FileChannel. For example, if the FileChannel has a File Scan Interval Time in Minutes of three minutes but the fileChannelsMonitorLoopInterval is set to five minutes, the FileChannel would be scanned every five minutes, not three.

The scan loop that checks all active FileChannels to see if the File Access Check Time has elapsed sleeps for the specified fileChannelsMonitorLoopInterval and then checks each channel to see if its scan interval time has elapsed.

Demo: Update system configuration scan time

Your instructor will demonstrate how to update the system configuration scan time value to be different than the default value of 5 minutes. By creating this new parameter in the system configuration set, it will override the default value.

Demo steps

1. Go to the training desktop.
2. Double-click Infor Rich Client hcm.
3. Type lawson@gdeinfor2.com in the Login Name field.
4. Type Tr@in123 in the Password field.
5. Click Login.
7. Select the System configuration set.
8. Click the Properties tab.
9. Select the New icon or Actions > Create.
10. Type fileChannelsMonitorLoopInterval in the Property Name and Description fields.
11. Type 1 in the Value field.
12. Click Save.
13. Select apps10 in the Infor Rich Client data area menu. The data area changes from hcm to apps10.
14. Repeat steps 6-12 to update the information in apps10.
File channels process

This lesson contains an exercise for updating from an external file to demonstrate a file channels process. The diagram below is a graphic representation of the process design we will use:

![File channels process diagram]

**Scenario**

In this scenario, you will build a process that will update Landmark HCM data using a .csv file. The process is triggered when the .csv file exists in a specific directory.

For this process, you will use the following nodes:

- Data Iterator
- Landmark Transaction

**Demo: Update Infor Landmark when a specific file exists in a designated directory**

Your instructor will demonstrate how to build a process to update Landmark HCM data using a .csv file.

**Exercise 19.1: Update Infor Landmark when a specific file exists in a designated directory**

In this exercise, you will build a process that will update Infor Landmark HCM data using a .csv file. The process is triggered when the CSV file exists in a specific directory.
Exercise 19.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Modify a file to use in your process
1. Double-click the IPAAttendees folder in the training desktop.
2. Right-click the WorkSchedule.csv file.
3. Select Edit with Notepad++.
4. Replace the xx with your assigned number.
5. Change the date to be current year, month and day (i.e. 20151008) on both records.
6. Verify the HR Organization is 7000.
7. Save the file as WorkSchedule<xx>.csv.

Part 2: Create process
1. Double-click Infor Process Designer icon on your desktop.
2. Select the LMRK10 hcm in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click the Palette tab.
7. Click and drag the Data Iterator node to the Process Editor between Start and End. Hint: The node is in the Data folder.
8. Select Connection in the Palette.
9. Select the Start node.
10. Select the Datalterator node. A blue connector arrow appears between the two nodes.
11. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
12. Select the Datalterator node.
13. Type or select the following values to define the properties for the Datalterator node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>DA1</td>
</tr>
<tr>
<td>Name</td>
<td>ParseByLine</td>
</tr>
<tr>
<td>Input Method</td>
<td>Data</td>
</tr>
<tr>
<td>Input data</td>
<td>&lt;!_inputData&gt;</td>
</tr>
<tr>
<td>Parse by</td>
<td>Line</td>
</tr>
<tr>
<td>On Error</td>
<td>Stop process</td>
</tr>
</tbody>
</table>
14. Click the **Palette** tab.
15. Click and drag a second **Data Iterator** node to the **Process Editor** and place it to the right of the first **Data Iterator** node.
16. Type or select the following values to define the following properties for the second **Data Iterator** node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>DA2</td>
</tr>
<tr>
<td>Name</td>
<td>ParseLineData</td>
</tr>
<tr>
<td>Input Method</td>
<td>Data</td>
</tr>
<tr>
<td>Input Data</td>
<td>!DA1_outputData</td>
</tr>
<tr>
<td>Parse by</td>
<td>Delimiter string</td>
</tr>
<tr>
<td>Delimiter string</td>
<td>,</td>
</tr>
<tr>
<td>Accumulate output variable box</td>
<td>Check</td>
</tr>
<tr>
<td>On Error</td>
<td>Stop process</td>
</tr>
</tbody>
</table>

17. Select **Connection** in the **Palette**.
18. Select the **ParseByLine** node.
19. Select the **ParseLineData** node. A blue connector arrow appears between the two nodes.
20. Select the **ParseLineData** node.
21. Select the **End-ParseLineData** node. A blue connector arrow appears between the two nodes.
22. Click **Select** in the **Palette** (or press **Esc** on your keyboard) to exit the connection mode.
23. Click the **Palette** tab.
24. Click and drag the **Landmark Transaction** node to add to the process. **Hint**: See process diagram for placement.
25. Type or select the following values to define the following properties for the **Landmark Transaction** node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>UPLNMK</td>
</tr>
<tr>
<td>Name</td>
<td>UpdateLandmark</td>
</tr>
</tbody>
</table>

26. Select **Connection** in the **Palette**. **Hint**: See the process diagram for connections.
27. Select the **End-ParseLineData** node.
28. Select the **UpdateLandmark** node. A blue connector arrow appears between the two nodes.
29. Select the **UpdateLandmark** node.
30. Select the **End- UpdateLandmark** node. A blue connector arrow appears between the two nodes.
31. Select the **End- UpdateLandmark** node.
32. Select the **End-ParseByLine** node. A blue connector arrow appears between the two nodes.
33. Select the **End-ParseByLine** node.
34. Select the **End** node. A blue connector arrow appears between the two nodes.
35. Click **Select** in the Palette (or press **Esc** on your keyboard) to exit the connection mode.
36. Select the **UpdateLandmark** node. You can view the node's properties.
37. Click **Build**.
38. Type or select the following values to define the UpdateLandmark node.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Area</td>
<td>hcm</td>
</tr>
<tr>
<td>Module</td>
<td>hr</td>
</tr>
<tr>
<td>Object Name</td>
<td>WorkSchedule</td>
</tr>
<tr>
<td>Action</td>
<td>Create</td>
</tr>
<tr>
<td>Action Type</td>
<td>CreateUpdateDelete</td>
</tr>
</tbody>
</table>

39. Type or select the following values in the **Key Fields** section:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>HROrganization</td>
<td>&lt;%=IDA2_outputData1%&gt; <strong>Note:</strong> The variable will not contain the specific output data number. You need to add that value.</td>
</tr>
<tr>
<td>Work Schedule</td>
<td>&lt;%=IDA2_outputData2%&gt;</td>
</tr>
</tbody>
</table>

40. Type or select the following values in the **Non-Key Fields** section:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>1</td>
</tr>
<tr>
<td>Description</td>
<td>&lt;%=IDA2_outputData3%&gt;</td>
</tr>
<tr>
<td>WorkSchedule_effective_data</td>
<td>&lt;%=IDA2_outputData4%&gt;</td>
</tr>
</tbody>
</table>

41. Click **OK**. The Landmark Transaction Field Value Handling window opens.
42. Type or select the following values for the **Landmark Transaction Field Value Handling**:

<table>
<thead>
<tr>
<th>Field</th>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Area</td>
<td>Use Variable</td>
<td>&lt;%=appProdline%&gt;</td>
</tr>
</tbody>
</table>
Lesson 19: File channels

© 2016 Infor Education

1. **Step 1: Set up the application**

   - Click the On Error tab.
   - Select the Stop process radio button.
   - Click OK.

2. **Step 2: Save the configuration**

   - Select File > Save As.
   - Type FileChannel<xx> in the File Name field.
   - Click Save. The file is saved.

3. **Step 3: Upload the configuration**

   - Select Process > Upload process.

---

### Part 3: Set up File Channel and Receiver for a local file

1. Double-click **Infor Rich Client hcm** on the training desktop.
2. Type lawson@gdeinfor2.com in the Login Name field.
3. Type Tr@in123 in the Password field.
4. Click Login. The Infor Rich Client canvas opens.
5. Select **Process Server Administrator** > **Administration** > **Channels Administrator**.
6. Select the **File Channels** tab.
7. Select **Actions > Create**.
8. Type or select the following values to create a new record:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel Name and Description</td>
<td>LocalDirectoryScanxx</td>
</tr>
<tr>
<td>File Channel Type</td>
<td>Local</td>
</tr>
<tr>
<td>Source File Directory</td>
<td>\mrk10.gdeinfor2.com\LMRK10ClassFiles\</td>
</tr>
<tr>
<td>File Match Case Sensitivity</td>
<td>Ignore Case</td>
</tr>
<tr>
<td>Error File Directory</td>
<td>\mrk10.gdeinfor2.com\LMRK10ClassFiles\xx\Error</td>
</tr>
<tr>
<td>In-Progress File Directory</td>
<td>\mrk10.gdeinfor2.com\LMRK10ClassFiles\xx\In-Progress</td>
</tr>
<tr>
<td>File Scan Interval Time in Minutes</td>
<td>2</td>
</tr>
</tbody>
</table>

9. Click **Save**.
10. Click **New** on the **File Channel Receivers** tab.
11. Type or select the following values in the **File Receivers** tab:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receiver and Description</td>
<td>WorkScheduleUpdate\text{xx}</td>
</tr>
<tr>
<td>File Name</td>
<td>WorkSchedule\text{xx}.csv</td>
</tr>
<tr>
<td>Process</td>
<td>FileChannel\text{xx}</td>
</tr>
<tr>
<td></td>
<td>Note: This is the process you just uploaded.</td>
</tr>
<tr>
<td>Data</td>
<td>File Data</td>
</tr>
<tr>
<td>Startup Type</td>
<td>Automatic</td>
</tr>
</tbody>
</table>

12. Click **Save**. The configuration is saved.

13. Click **X** to close the **File Receiver** page. You return to the **Channels Administrator** page.

14. Click the **File Channels** tab.

15. Select **Actions** > **Activate**. **Note**: It may take a little while for the process to initiate.

16. Click the **minus (−) sign** to minimize the **Infor Rich Client** screen.

### Part 4: Move the .csv file to initiate the workunit trigger

1. Go to the **IPAAAttendees** folder on the desktop.

2. Click and drag the **WorkSchedule-xx>.csv** file to move the file to \LMRK10ClassFiles\xx.

### Part 5: Validate that a workunit was created in Infor Rich Client

1. Maximize or open **Infor Rich Client**.

2. Select **Process Server Administrator** > **Administration** > **WorkUnits** > **WorkUnits**.

3. Verify that you see a workunit with your process.

**Note**: If you don’t see the workunit:

- Review your previous steps
- Make appropriate changes
- Recopy the file to the C drive
- Initiate the workunit trigger

4. Validate that the workunit status is complete.

**Note**: If it is not complete:

- Click the **Error** tab or go to the logs to determine what failed
- Make corrections
- Recopy the file over to the C drive
- Initiate the workunit trigger

### Part 6: Verify that the work schedule is added to Work Schedules list in hcm.

1. Type **Work Schedule** in the **Search** field in **Infor Rich Client**.
2. Select **Administrator Setup > Resource Components > Work Assignment > Work Schedules**.

3. Verify that your work schedules are added to the **Work Schedules** lists. **Note**: The work schedules are MF03<xx> and MF06<xx>.

⚠️ You should also have the WorkSchedule.csv file in the \lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\In-Progress folder.
Check your understanding

Which of the following is true about channels? Select all that apply.

a) Channels provide a means of one-way communication between IPA and external sources.
b) A channel may have one or more receivers.
c) Information received via channels is used to create and trigger workunits.
d) Channels are defined using the Channels Administration tool in Infor Rich Client.

Identify the two types of external sources that IPA provides channels.

a) External or internal files
b) Java Messaging Service (JMS)
c) JSON Builders

The fileChannelsMonitorLoopInterval is an example of what kind of configuration property?

a) System
b) Main
c) Custom

Which path would you choose to set up File Channel and Receiver for a local file?

a) Process Server Administrator > Administration > Resources
b) Process Server Administrator > Administration > Channels Administrator
c) Process Server > Employee > Channels Administrator

True or false? The fileChannelsMonitorLoopInterval value overrides the File Scan Interval Time in Minutes.

a) True
b) False
Lesson 20: Infor ION

Estimated time
30 minutes

Learning objectives
After completing this lesson, you will be able to:
- Describe the functionality of ION Connect.
- Identify a Business Object Document’s function.

Topics
- ION Connect overview
- ION channels and receivers
- ION Connection setup
- ION Pulse integration
- Check your understanding
ION Connect overview

For complete details on pre-configured channels and receivers and custom configurations for ION Connect refer to the Infor Process Automation Administration Guide.

ION Connect is a messaging hub provided by Infor. IPA supports sending and receiving messages, called Business Object Documents (BODs), through pre-defined processes which are delivered with Infor Lawson applications. BODs flow through ION Connect as shown in the diagram below:

![ION Connect Diagram]

An event can be inbound or outbound. IPA acts as the middleware to get the messages to and from ION Connect. For example, if you trigger an event that sends data (outbound) to IPA, it will in turn send the information to ION.

**ION Connect functionality**

ION Connect includes the following functionality:

- You must define channels and receivers in IPA to receive messages from ION and start specific processes.
- You define processes for ION services to trigger a BOD message to be sent to ION.
- When IPA gets or sends an ION type of message (a BOD), it drops that message in a special database on the Process Automation server.
- When you publish a message to ION, it will determine what to do with the data.
- The ION Inbox Query node performs an iterative query against the ION Inbox and the ION Inbox Update node sets the status on specific ION Inbox records.
- ION Alert sends an alert message to a user or task.
ION channels and receivers

Business Object Document

Each BOD received from ION Connect can be assigned to a receiver. Those receivers are assigned to a channel. Each channel is assigned to one connection point in the ION Connect server. ION services trigger processes to create a BOD to be sent to ION Connect server.

Here is an example of a BOD:

![BOD Example](image)

BOD example

With some releases of Infor Process Automation, it is possible to receive BODs in a batch of two or more BODs. This is a way for ION to receive large data sets.
ION connection setup

IPA requires a connection to the ION system to be configured. The ION connection uses JDBC which requires that external .jar files are configured on the server and locally on the machine where Infor Process Designer is running.

Set up IPA for ION Connect

The ION connection setup for IPA can be accessed in Workspace or through the Infor Rich Client. The setup is done in the Process Server Administrator.

The following table lists and describes the four sections of IPA that must be defined for the ION connection:

<table>
<thead>
<tr>
<th>Setup tasks</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service definition</td>
<td>In this section you load the Process Automation Services for Products. All ION services start with GEN.</td>
</tr>
<tr>
<td>Process definition</td>
<td>The application defined processes are delivered with ION install; the files begin with ION.</td>
</tr>
<tr>
<td>System configuration</td>
<td>In this section you configure the IPA system for sending information to ION.</td>
</tr>
<tr>
<td>Channels</td>
<td>The database connection information is defined in a channel which represents a JDBC connection to the database with a set of ION inbox tables.</td>
</tr>
</tbody>
</table>

Note: Many Infor Lawson customers who process ION BODs do so through pre-configured channels and receivers that are delivered as scripts through an application. This topic is intended for customers who are setting up their own channels and receivers.
ION Pulse integration

IPA provides support for Infor Ming.le Enterprise/ION Pulse integration. You can enable users to receive IPA tasks in Infor Ming.le Enterprise in addition to their normal IPA Inbasket. You can also configure ION Pulse Alerts and notifications to work with processes.

To enable IPA tasks to appear in Infor Ming.le Enterprise, you simply create an ION connection in which you enable the integration flag and supply the ION Logical ID.

To enable ION Pulse Alerts or notifications, more complex configuration involves setting up the receiver and configuring the appropriate activity node.
Check your understanding

Which of the following is true about ION functionality? Select all that apply.

a) The ION Inbox node performs an iterative query against the ION Inbox.
b) Channels and receivers must be defined in IPA to receive messages from ION.
c) IPA drops ION BODs in a special database folder on the IPA server.
d) ION Alert sends an alert message to a user.
e) ION will determine what to do with the data when a message is published via ION.

IPA acts as the __________ to get the messages to and from ION Connect.

a) Middleware
b) Application
c) Graphical user interface (GUI)

True or false? Incoming and outgoing BODs are supported by IPA using processes delivered through Infor Lawson applications.

a) True
b) False

This is the ION channel configuration parameter for connecting to the database.

a) DB schema
b) Channel name
c) JDBC driver
Lesson 21: XML process

Estimated time
1 ½ hours

Learning objectives
After completing this lesson, you will be able to:
- Identify XML activity node properties.
- Define how to set up the XML activity node to output Infor Lawson data to XML.

Topics
- XML activity node
- Build an XML process
- Check your understanding
XML activity node

The XML activity node allows XML to be built or parsed within a process. XML is read or constructed as JavaScript objects so that elements or their contents can be accessed within the process, especially using the Assign and Branch nodes.

The purpose of the XML activity node is to address the need to use XML Schema to interface with programs, customers, and vendors. As an example, many Infor Lawson HR customers want to make use of an industry-standard protocol for interfacing with timecards. XML schema specifically for this purpose is available. Through the XML activity node, you can reference this standard schema in a process. The resulting process could take Infor Lawson Payroll system data and send it in the appropriate XML format to a time card contractor.

To use the XML activity node, you should be familiar with general XML concepts including XML Schema and E4X.
Build an XML process

The XML activity node allows you to parse or build XML data through a process. In this lesson we will demonstrate the latter by defining a process that builds XML data.

The diagram below is a graphic representation of the process design we will use:

![XML process diagram]

An XML Schema must be developed containing the attributes required prior to executing flows for XML. For example, cucodes.xsd is an XML Schema created from XSD.exe. XSD.exe only allows you to manipulate XML schemas that follow the XML Schema Definition (XSD) language proposed by the World Wide Web Consortium (W3C). For more information on the XML Schema Definition proposal or the XML standard, see http://www.w3.org/.

Scenario

In this scenario, you will use the XML activity node to take Infor Lawson data and build it in an XML format.

For this process, you will use the following nodes:

- XML
- Lawson Query
- File Access

Demo: Create a process to build data in an XML format

Your instructor will demonstrate how to use the XML activity node to take Infor Lawson data and build it in an XML format.
Exercise 21.1: Create a process to build data in an XML format

In this exercise, you will use the XML activity node to take Infor Lawson data and build it in an XML format.

Exercise 21.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Add the Start node
1. Double-click Infor Process Designer icon on your desktop.
2. Select the LMRK10 hcm in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Select the Start node in the Process Editor.
7. Click the plus (+) sign. You are able to add information to the Start node.
8. Type or select the following values in the Start node Properties fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable Name</td>
<td>outputFile</td>
</tr>
<tr>
<td>Variable Type</td>
<td>String</td>
</tr>
<tr>
<td>Variable Value</td>
<td>“Currency.xml”</td>
</tr>
</tbody>
</table>

9. Click OK.

Part 2: Add the XML1 node
1. Click the Palette tab.
2. Click and drag the XML node to the Process Editor. Hint: See the process diagram for placement.
3. Select Connection in the Palette.
4. Select the Start node.
5. Select the XML node. A blue connector arrow appears between the two nodes.
6. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
7. Select the XML node. The properties for the node appears in the Properties panel.
8. Type or select the following information for the XML node:
   - ID = XML1
   - Action = Build XML Object
9. Click Build. The E4X XML Builder opens.
10. Click File.
11. Go to the IPAAttendees folder in the training desktop.
12. Select the **cucodes.xsd** file.
13. Click Open. This adds the file to the **E4X XML Builder** window.
14. Click Load.
15. Click OK.
16. Delete everything after **cucodes** in the first part of the statement except for the last character. So your XML input shows as follows:
   ```xml
   <cucodes/>
   </cucodes>
   ```
17. Click the On Error tab.
18. Select Stop process.

**Part 3: Add a query node**

1. Click the **Palette** tab.
2. Click and drag the **Lawson Query** node to the **Process Editor**. Hint: See process diagram for placement.
3. Select **Connection** in the **Palette**.
4. Select the **XML** node.
5. Select the **LwsnQuery** node. A blue connector arrow appears between the two nodes.
6. Click **Select** in the **Palette** (or press Esc on your keyboard) to exit the connection mode.
7. Select the **LwsnQuery** node.
8. Type or select the following information on the **LwsnQuery** node:
   - ID = **Query1**
9. Click **Build**. The **Infor Lawson Process Query Builder** opens.
10. Select **APPS10** in the **Product Line** field.
11. Select **IF** in the **Module** field.
12. Select **CUCODES – Currency Codes** in the **Table** field.
13. Select all fields in the **Fields** section. Hint: Hold down the Shift key to select multiple items.
14. Click the right-facing (>). The fields move to the **Selected Fields** section.
15. Click **Finish**.
16. Click the On Error tab.
17. Select Stop process.

**Part 4: Add a second XML node**

1. Click the **Palette** tab.
2. Click and drag the **XML** node to the Process Editor between the **LwsnQuery** and the **End-LwsnQuery** nodes. Hint: See the process diagram for placement.
3. Select **Connection** in the **Palette**.
4. Select the **LwsnQuery** node.
5. Select the new **XML** node. A blue connector arrow appears between the two nodes.
6. Select the XML node.
7. Select the End-LwsnQuery node. A blue connector arrow appears between the two nodes.
8. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
9. Select the XML node.
10. Type or select the following information for the XML node:
    o ID = XML
    o Action = Build XML Object
11. Click Build The E4X XML Builder opens.
12. Click File.
13. Go to the IPAAttendees folder in the training desktop.
15. Click Open. The file is added to the E4X XML Builder window.
16. Select cucode in the Global element field. Note: If you receive an error message, click OK.
17. Click Load. The file is ready to load.
18. Press Ctrl + space to search and select the following values for each cucode element:

<table>
<thead>
<tr>
<th>cucode element</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>currencyCode</td>
<td>{Query1_CURRENCY_CODE}</td>
</tr>
<tr>
<td>description</td>
<td>{Query1_DESCRIPTION}</td>
</tr>
<tr>
<td>formsExp</td>
<td>{Query1_FORMS_EXP}</td>
</tr>
<tr>
<td>nbrDecimals</td>
<td>{Query1_NBR_DECIMALS}</td>
</tr>
<tr>
<td>ISOCode</td>
<td>{Query1_ISO_CODE}</td>
</tr>
</tbody>
</table>

19. Click OK.
20. Delete all the data in the first line of the XML Builder/Parser except for the <cucode>. Note: See first line on image below.

21. Check the Append output to check box.
22. Type XML1_output cuckod in the Append output to field. Note: The output should be the output from the XML1 node since you are appending to this.

23. Click the On Error tab.

24. Select Stop process.

Part 5: Add the File Access node
1. Click the Palette tab.
2. Click and drag the File Access node to the Process Editor to the right of the End-LwsnQuery node. Hint: The File Access node is in the Data folder.
3. Select the FileAccess node.
4. Type or select the following values for the FileAccess node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Execution mode</td>
<td>Write to file</td>
</tr>
<tr>
<td>Output File</td>
<td>\MRK10.gdeinfor2.com\LMRK10ClassFiles\xx&lt;!outputFile&gt;</td>
</tr>
<tr>
<td></td>
<td>Replace &quot;xx&quot; with your assigned number.</td>
</tr>
<tr>
<td>Input Data</td>
<td>&lt;!XML1_output&gt;</td>
</tr>
</tbody>
</table>

5. Click the On Error tab.
6. Select Stop process.
7. Select Connection in the Palette.
8. Select the End-LwsnQuery node.
9. Select the FileAccess node. A blue connector arrow appears between the two nodes.
10. Select the FileAccess node.
11. Select the End node. A blue connector arrow appears between the two nodes.
12. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

Part 6: Save the file and run the process
1. Select File > Save As.
2. Type XML in the File name field.
3. Click Save.
5. Select the No Input Data radio button.
6. Go to the LMRK10ClassFiles shortcut on the desktop.
7. Select your <xx> directory.
8. Verify that you have the Currency.xml file.
9. Right-click the **Currency.xml** file.

10. Select *Open With > Notepad++*. You are able to view the file.
Check your understanding

The ______ activity node allows XML to be built or parsed within a process.

a) XML  
b) ION Connect  
c) Web Run

The XML Builder Wizard is located on the ____________ section of the XML activity node properties tab.

a) Input  
b) Output  
c) General

The ______ is required to build data in an XML format using XML activity nodes.

a) XML parser  
b) XML execution  
c) XML schema
Lesson 22: For Each process

Estimated time
1 ½ hours

Learning objectives
After completing this lesson, you will be able to:

- Recognize the four processing options available for a loop.
- Describe how to set up the For Each node to parse an XML document.

Topics
- For Each activity node
- Build a process to configure a loop for an XML element
- Check your understanding
For Each activity node

The For Each activity node lets you configure a loop, equivalent to a For or While loop in programming, for processing of multiple items.

There are four ways to process a loop:

- Iteration - Takes a single number as input and loops for exactly that number of times
- Expression - Takes Java Script expressions as input to determine number of iterations
- Array - Takes an array of values as input
- XML - Takes XML schema and data as input
Build a process to configure a loop for an XML element

In this lesson we will demonstrate how to configure a loop for an XML element. The diagram below is a graphic representation of the process design we will use:

![Diagram of process design]

**Scenario**

In this scenario, you will use the XML file you created in a previous lesson to parse the file using the For Each process to build a pipe delimited file.

For this process, you will use the following nodes:

- For Each
- MsgBuilder
- File Access

**Demo: Create a process to parse an XML file to build a pipe delimited file**

Your instructor will demonstrate how to use the For Each process to parse an XML file to build a pipe delimited file.

**Exercise 22.1: Create a process to parse an XML file to build a pipe delimited file**

In this exercise, you will create a process using For Each node to parse an XML file to build a pipe delimited file.
Exercise 22.1 steps

Note: Your assigned login number is identified as “xx” in the exercise steps.

Part 1: Add the For Each node

1. Double-click Infor Process Designer icon on your desktop.
2. Select the LMRK10 hcm in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click the Palette tab.
7. Click and drag the For Each node between the Start and End nodes. Hint: The For Each node is located in the Data folder in the Palette.
8. Select the ForEach node.
9. Type or select the following values in the ForEach node fields:
   - ID = ForEach
   - Name: ParseXML
   - Select Option: XML Element
11. Go to the IPAAttendees folder on the desktop.
12. Select the cucodes.xsd file.
13. Click Open.
14. Select cucode (cucodes) in the Element to loop over field.
15. Type <\_inputData> in the XML Input field. Note: Press Ctrl + space to search for the value.
16. Click the On Error tab.
17. Select the Continue process radio button.
18. Select the Custom Log Entry check box.
19. Select Connection in the Palette.
20. Select the Start node.
21. Select the the ParseXML node. A blue connector arrow appears between the two nodes.
22. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
23. Select File > Save As. (Click Yes to save file with validation errors).
24. Type ForEach in the File name field.
25. Click Save.

Part 2: Add a Msg Builder node

1. Click the Palette tab.
2. Click and drag the MsgBuilder node to the Process Editor.
3. Select the MsgBuilder node. The node’s properties displays in the Properties panel.
4. Type FileData in the Variable name field.
5. Select **Connection** in the Palette.
6. Select the **ParseXML** node.
7. Select the **MsgBuilder** node. A blue connector arrow appears between the two nodes.
8. Select the **MsgBuilder** node.
9. Select the **End-ParseXML** node. A blue connector arrow appears between the two nodes.
10. Click **Select** in the Palette (or press **Esc** on your keyboard) to exit the connection mode.
11. Type (or select the variables) the following in the **Message** field:

   ```
   <!ForEach_cucode_currencyCode>|<!ForEach_cucode_description>|<!ForEach_cucode_formsExp>|<!ForEach_cucode_ISOCode>|<!ForEach_cucode_nbrDecimals>
   ```

**Part 3: Add a File Access node**

1. Click the **Palette** tab.
2. Click and drag the **File Access** node to the **Process Editor**. **Hint:** See the process diagram for placement.
3. Select the **FileAccess** node.
4. Type or select the following values for the **FileAccess** node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Execution mode:</td>
<td>Write to file</td>
</tr>
<tr>
<td>Encoding type:</td>
<td>US-ASCII</td>
</tr>
<tr>
<td>Output File</td>
<td>\lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\CurrencyFlatFile.dat</td>
</tr>
<tr>
<td>Input Data</td>
<td>&lt;!FileData&gt;</td>
</tr>
</tbody>
</table>

5. Click the **OnError** tab.
6. Select **Stop process**.
7. Select **Connection** in the Palette.
8. Select the **End-ParseXML** node.
9. Select the **FileAccess** node. A blue connector arrow appears between the two nodes.
10. Select the **FileAccess** node.
11. Select the **End** node. A blue connector arrow appears between the two nodes.
12. Click **Select** in the Palette (or press **Esc** on your keyboard) to exit the connection mode.
13. Click **Save**.

**Part 4: Run the process**

1. Select **Process > Run**.
2. Select the **Use Connector** radio button.
3. Select the **Input data file** radio button.
4. Click **Browse**.
5. Go to the `<\lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\Currency.xml` file.
6. Click **Open**.
7. Click **OK**.

**Part 5: Validate the process worked**

1. Go to the **LMRK10ClassFiles** shortcut on the desktop.
2. Select your `<xx>` directory.
3. Verify that you have the **CurrencyFlatFile.dat** file.
4. Right-click the file.
5. Select **Open With > Try an app on This PC**.
6. Select **Word Pad**, You can view the file.
Check your understanding

Identify the four processing options available for a loop:

- a) Reinvigoration
- b) Iteration
- c) Expression
- d) Array
- e) XML

When setting up the For Each node to parse an XML document, IPA takes XML schema and data as _________.

- a) Output
- b) Input
- c) Parameters
Lesson 23: Java Script Object Notation (JSON)

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:

- Explain how to build a process to convert XML to JSON.

Topics
- JSON activity node
- Check your understanding
JSON activity node

Java Script Object Notation (JSON) is a lightweight data interchange format. JSON uses JavaScript syntax, but the JSON format is text only, just like XML. IPA offers multiple functions for JSON including:

- JSON Builder
- JSON Converter
- JSON Parser

In this lesson we will demonstrate how use the JSON Converter to convert XML to JSON format. The diagram below is a graphic representation of the process design we will use:

![JSON Converter Process diagram](image)

Scenario

In this scenario, you will use the JSON Converter to convert XML to JSON format.

For this process, you will use the following nodes:

- JSON Converter
- File Access

Demo: Create a process to convert XML data to JSON format

Your instructor will demonstrate how to use the JSON Converter to convert XML to JSON format.

Exercise 23.1: Create a process to convert XML data to JSON format

In this exercise, you will create a process using the JSON Converter to convert XML data to JSON format.

Exercise 23.1 steps

*Note: Your assigned login number is identified as “xx” in the exercise steps.*
Part 1: Add a JSON Converter node

1. Double-click Infor Process Designer icon on your desktop.
2. Select the LMRK10 hcm in the Connection field.
3. Type Tr@in123 in the Password field.
4. Click Login.
6. Click the Palette tab.
7. Click and drag the JSON Converter node between the Start and End nodes. Hint: The JSON Converter node is located in the Web/XML/JSON folder in the Palette.
8. Select the JSON Converter node.
9. Type or select the following values in the JSON Converter node fields:
   - ID = JSON
   - Converter Type: XML -> JSON
   - Data to Convert: <!_inputData>
10. Click the On Error tab.
11. Select Stop process.
12. Select Connection in the Palette.
13. Select the Start node.
14. Select the JSON Converter node. A blue connector arrow appears between the two nodes.
15. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.

Part 2: Add the File Access node

1. Click and drag the File Access node to the Process Editor to the right of the JSON Converter node.
2. Select Connection in the Palette.
3. Select the JSON Converter node.
4. Select the FileAccess node. A blue connector arrow appears between the two nodes.
5. Select the FileAccess node.
6. Select the End node. A blue connector arrow appears between the two nodes.
7. Click Select in the Palette (or press Esc on your keyboard) to exit the connection mode.
8. Select the FileAccess node.
9. Type or select the following values for the FileAccess node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Execution mode:</td>
<td>Write to file</td>
</tr>
<tr>
<td>Output File</td>
<td>\lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\EmployeeInfo.json</td>
</tr>
<tr>
<td>Field</td>
<td>Value</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Input Data</td>
<td><code>&lt;!JSON_outputData&gt;</code></td>
</tr>
</tbody>
</table>

10. Click the **On Error** tab.
11. Select **Stop process**.

**Part 3: Save and test the process**

1. Select **File > Save As**.
2. Type **JSON** in the **File name** field.
3. Click **Save**.
4. Select **Process > Run**.
5. Select the **Use connector** radio button.
6. Select the **Input data file** radio button.
7. Click **Browse**.
8. Go to the **IPAAttendees** folder on the desktop.
9. Select the **EmployeeInformation.xml** document.
10. Click **Open**.
11. Click **OK**.

**Part 4: Validate the process ran**

1. Go to the training desktop.
2. Select the **LMRK10ClassFiles** shortcut.
3. Select the **<xx> directory**.
4. Validate that there is an **EmployeeInfo.json** file created.
5. Right-click the **EmployeeInfo.json** file.
6. Select **Open With > Try an app on This PC**.
7. Select **Word Pad**. You can view the file.
Check your understanding

True or false? JSON uses JavaScript syntax in text format to convert data.

a) True  
b) False

Which activity node would you select to convert XML to JSON format?

a) JSON Builder  
b) JSON Converter  
c) JSON Parser
Lesson 24: Web services

Estimated time
1 hour

Learning objectives
After completing this lesson, you will be able to:
  - Describe how IPA works with web services.

Topics
- Web services and IPA
- Web Services activity node
- Exchange rates example
- Check your understanding
Web services and IPA

Web services are software systems that can be accessed over a network and that support automated machine-to-machine interactions. A web service may provide information on how to access the service and is part of a Service Oriented Architecture (SOA).

There are two types of web services associated with IPA:

- Intranet web services
- Internet web services

IPA uses the following protocols to support web services:

- SOAP 1.1 and SOAP 1.2
- WSDL 1.1.
- Communication build on Apache Axis2.
- SOAP XML builder wizard which supports document-literal style web services. **Note:** It does not support RPC-style web services.

The diagram below illustrates how IPA works with web services. IPA calls a web service and receives the response. The web service takes XML in and returns XML out.

![Web services and IPA diagram](image-url)
Web Services activity node

The Web Services activity node allows the server to call a web service and use any returned information in the process.

Because a web service takes XML as input and returns XML as output, the Web Services node uses much of the same functionality as the XML activity node. You can think of a Web Services node as both an XML builder and an XML parser, with a web service call in-between. Like the XML node, XML input is built (and the output parsed) as JavaScript objects so that elements or their contents may be accessed within the process, especially using the Assign and Branch nodes.

To use the Web Services activity node, you should be familiar with general XML concepts including XML Schema, E4X, Simple Object Access Protocol (SOAP), as well as web services.
Exchange rates example

In this example we will walk through how to automate the process of getting an exchange rate from a web service and then updating Infor Lawson. The diagram below is a graphic representation of the process design we will use:

![Web service process diagram](image)

**Scenario**

In this scenario, you see how to automate getting an exchange rate from a web service and updating the Lawson ERP by walking through a set of images that illustrate the following process steps:

- Retrieve exchange rate date from a commercial web service
- Extract the date and rate from the return XML
- Transform the date to the Infor Lawson format
- Update the Infor Lawson ERP Exchange rate (CU10.1)

The example handles one exchange rate at a time, such as USD to CAD. Various companies and organizations provide exchange rates but we use the web service at [http://www.webservicex.net/](http://www.webservicex.net/).

**Image A:** The Start node defines some default variables as shown in this image.
**Image B:** The Web Service node is set up to get exchange rates as shown in the image.

**Image C:** The Web Service node has additional properties setup as shown in the image.
Image D: The Assign node matches input and output variables as shown in the image.

Image E: The Lawson Transaction node updates Lawson ERP Exchange Rate (CU10.1). The IOS API Wizard helps create the transaction as shown in the image.
**Image F:** Before the process runs, the exchange rates appear as shown in the image.

Exchange rates (CU10.1) before the process is run

**Image G:** After the process runs, the exchange rates appear as shown in the image.

Exchange rates (CU10.1) after the process is run
Check your understanding

Identify the parts of web services associated with IPA. Select all that apply.

- a) Web Protocol services
- b) Intranet web services
- c) Internet web services

Like this _____ activity node, the Web Services activity node takes XML as input and returns XML as output.

- a) JSON Converter
- b) Web Run
- c) XML

Which protocols does the IPA Web Service node support? Select all that apply.

- a) SOAP
- b) RPC style web service
- c) WSDL
- d) Document/literal style
Lesson 25: Wait node

Estimated time
30 minutes

Learning objectives
After completing this lesson, you will be able to:
  • Describe the functionality of the Wait activity node.

Topics
  • Wait activity node
  • Administering waiting workunits
  • Check your understanding
Wait activity node

The Wait activity node lets you add a wait time to a process. During the wait period, the process completely stops. This releases the working thread and allows the resource to be used for another process.

The Wait node is typically used in situations where you can predict that a process will not be able to process during a specific timeframe. For example, if you design a process that requires action from an employee who only works weekdays, you could add a wait time to start at the end of the workday on Friday and resume at the start of the workday on Monday.

**Note:** The Wait activity node is grouped with Common activity nodes on the Infor Process Designer interface.

The Wait activity node cannot be used inside the loop on an iterative node such as the SQL Query node or the Data Iterator node.
Administering waiting workunits

As an administrator, you can manage workunits with a wait status.

Using IPA, any process in a waiting status can be viewed from the Waiting Workunits page in the Infor Rich Client. From the Waiting Workunits page, you can also cancel the wait period and force the process to proceed immediately.

The table below describes actions you can take associated with the Waiting Workunits page:

<table>
<thead>
<tr>
<th>To ....</th>
<th>Follow these instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>View all processes in a waiting status</td>
<td>Navigate to this path: Process Server Administrator &gt; Administration &gt; Workunits &gt; Waiting Workunits. A page displays a list of all processes that are currently in a wait status.</td>
</tr>
<tr>
<td>Cancel a wait period</td>
<td>Click Proceed Now for any record in the Waiting Workunits page. This overrides any remaining time of the wait period and forces the process to continue immediately.</td>
</tr>
</tbody>
</table>
Check your understanding

True or false? When the Wait activity node is utilized in a process, the working thread is released and allows the resource to be used for another process.

a) True
b) False

Where in Infor Rich Client would you go to view waiting processes?

a) Data widget page
b) Waiting Workunits page
   c) Configuration Security page
Lesson 26: Encrypt and decrypt

Estimated time
30 minutes

Learning objectives
After completing this lesson, you will be able to:
- Describe the functionality of the Encrypt and Decrypt activity nodes.

Topics
- Encrypt and Decrypt activity nodes
- Setting encryption properties
- Check your understanding
Encrypt and Decrypt activity nodes

The Encrypt and Decrypt activity nodes let you encrypt and decrypt data. Use Encrypt when you want to send encrypted data and use Decrypt when you are receiving data that has been encrypted.

Data is encrypted or decrypted based on a selected encryption protocol such as Pretty Good Privacy (PGP).

**Note:** The Encrypt and Decrypt activity nodes are grouped with Data activity nodes on the Process Designer interface.

Before you set properties for Encrypt or Decrypt activity nodes, you must generate the PGP key pair. The nodes contain the “service” portion of the pair. **Note:** PGP key pairs are typically created by a security administrator.
Check your understanding

The Encrypt and Decrypt activity nodes are grouped with ______ activity nodes on the Process Designer interface.

a) Data  
b) ION  
c) Web Service

Which Encrypt and Decrypt activity node property allows you to define or select the encryption protocol?

a) Service name  
b) Encrypt and Decrypt type  
c) Date source
Lesson 27: IPA administration

Estimated time
2 ½ hours

Learning objectives
After completing this lesson, you will be able to:
- Identify tasks associated with administering the IPA server.
- Describe the system administration section of the Process Service Administrator.
- Describe IPA settings in the grid.
- Explain how to start or stop Infor Process Automation.

Topics
- Administrative tasks
- System administration
- Grid configuration
- IPA with Infor Lawson System Foundation (LSF)
- Start or stop IPA
- Check your understanding
Administrative tasks

*Infor Process Automation Administration Guide*

Administration of the IPA Server is usually done by an application administrator. This is usually not the same person who designs the IPA processes. The skills required are different. However, it is good for the IPA process designer to also be aware of the server configuration option.

Knowledge of the Infor Grid, Infor Landmark, server operating system, and hardware are required to administer the IPA server application. It is recommended that the application administrator for the IPA server also consider taking the *Lawson: Administering Landmark Foundation* and the *Lawson: Configuring and Administering the Infor Process Automation Server* classes offered by Infor Education.

Within the Process Server Administration, the following functions are available:

**Workunits**
- Restart – If a workunit is paused and you think a server problem might have been the cause, restarting can solve the problem.
- Cancel – Use this option to cancel an in-progress workunit.
- Release
- Move workunit or schedule move to workunit history to History - Retains all associated data until you run the delete logs and activities or delete the work unit.
- Delete Selected Activities and Variables or Schedule Logs and Activities Deletion – Deletes the selected workunit activities and variables immediately.
- Schedule Workunit Deletion or Delete Selected Workunits - Permanently deletes all information about the workunits.

**Action Pending Workunits**
- View the workunits that currently are awaiting action from a user
- Actions available: Open, Cancel, Take Action

**Workunit History**
- View a list of workunits that have been moved from the active list
- Actions available: Delete or schedule activities and variables, delete or schedule workunit deletion

**Tracking**
- View details about the status and history of a workunit
- Actions available: Open, Proceed Now, Create Comparison Workunit, Delete Activities and Variables, Take Action, Schedule Logs and Activities Deletion

**Cleaning up IPA workunits**

Best practices for cleaning up IPA workunits are determined at your site. Decisions about how often to archive and delete are based on how many processes you run and how much runtime data the workunits generate.

For example, if your processes generate a moderate amount of data, you might want to delete workunit data monthly. You could run the delete procedure on the last day of the month. See the *Infor Process Automation Administration Guide* for details on how to do this task.
System administration

The system administration section in the Process Server Administrator consists of these sections:

- Security management
- Remove analytics data

Security management

IPA can be secured within the Landmark security. The securable objects that can be configured include the following:

- Processes
- Triggers
- Business classes
- Fields
- Menus
- Web apps

The table below lists the delivered IPA-related security classes that can be secured:

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProcessServerAllAccess</td>
<td>Update access to everything Infor Process Server.</td>
</tr>
<tr>
<td></td>
<td>Assigned to ProcessServerAllAccess Role</td>
</tr>
<tr>
<td>ProcessServerReadAccess</td>
<td>Inquire-only access</td>
</tr>
<tr>
<td></td>
<td>Assigned to ProcessServerReadAccess Role</td>
</tr>
<tr>
<td>InbasketAdministrator</td>
<td>Update/inquiry access to Infor Process Server and objects as needed for a</td>
</tr>
<tr>
<td></td>
<td>global Inbasket administrator</td>
</tr>
<tr>
<td>InbasketUser</td>
<td>Inquiry access, limited</td>
</tr>
<tr>
<td></td>
<td>Update access to Infor Process Server as needed for personal Inbasket</td>
</tr>
<tr>
<td></td>
<td>activities</td>
</tr>
<tr>
<td>ProcessSchedulingAllAccess</td>
<td>Inquiry access to processes and service definitions</td>
</tr>
<tr>
<td></td>
<td>Update access to objects as needed to submit/schedule processes</td>
</tr>
<tr>
<td>ProcessDesigner</td>
<td>Designing processes in Process Designer and to upload to server</td>
</tr>
<tr>
<td></td>
<td>Mainly inquiry-only access to limited selection of Infor Process Server</td>
</tr>
<tr>
<td></td>
<td>business classes</td>
</tr>
<tr>
<td></td>
<td>Update access only to Infor Process Server business classes required to</td>
</tr>
<tr>
<td></td>
<td>upload/save processes</td>
</tr>
<tr>
<td>ProcessAutomationProxy</td>
<td>Users who need to assign tasks to other users to cover for them</td>
</tr>
<tr>
<td></td>
<td>Not delivered through a role</td>
</tr>
</tbody>
</table>

Remove analytics data

From this section, you can remove the Workunit Activity Comparison data.
Grid configuration

Landmark is a collection of servers. Seven Java Virtual Machines (JVMs) provide Landmark’s functionality. The services perform the following:

- Process business logic requests
- Authenticate and authorize
- Interpret Lawson Pattern Language
- Access database tables
- Manage process flows and background processing,
- Display help pages
- Send email

Landmark servers run inside a Java application called the Grid, which also manages the collection of servers. The configuration properties for IPA can be accessed at the following path: Grid Manager > Advanced > Configuration > Configuration Manager > Applications > Landmark LMKEVN (this may vary based on your install) > Edit Properties.

Configuring some of the IPA properties can take trial and error. If database requests are being denied, you might need to increase pool sizes. If performance is not what you want, you may want to try and decrease the pool sizes. Many of these properties work in conjunction with another parameter.

IPA settings

The properties in this section control the frequency with which Process Server polls for such things as work escalation, reminders, and for new workunits.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pfi.escalator.pollingFrequency</td>
<td>Polling frequency, in minutes, for Process Server to look for work escalation and reminders messages for Inbasket</td>
</tr>
<tr>
<td></td>
<td>Default = 30 minutes</td>
</tr>
<tr>
<td>pfi.workunit.pollingFrequency</td>
<td>Polling frequency, in minutes, for workunit needing processing</td>
</tr>
<tr>
<td></td>
<td>Default = 30 minutes</td>
</tr>
</tbody>
</table>

These parameters are to be used with applications only. Use them to configure special characters that are not enabled by default.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pfi.extraEncodingChars</td>
<td>This parameter:</td>
</tr>
<tr>
<td></td>
<td>- Is a Set of commonly used special characters are encoded by default for use with applications</td>
</tr>
<tr>
<td></td>
<td>- Lists of these characters are in the Process Designer online help</td>
</tr>
<tr>
<td>pfi.extraEncoding</td>
<td>If you need characters, other than those that are encoded by default, you can configure them through the Grid properties pfi.extraEncodingChar and pfi.extraEncoding.</td>
</tr>
</tbody>
</table>
The properties in this section apply only if you use the Custom activity node.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pfi.customActivity.beans</td>
<td>This parameter is where you indicate the class names for .jar files needed for custom activities. The names are listed in this property separated by commas or semicolons. LPS must be stopped and restarted for these activities to be available.</td>
</tr>
<tr>
<td>pfi.customActivity.beansToRunSeparate</td>
<td>This true/false flag indicates that custom adapters will run in their own process, separate from the Process Server. Note: It is recommended to run the adapters a separate process).</td>
</tr>
<tr>
<td>pfi.customActivity.beansToRunSeparateOptions</td>
<td>This parameter specifies your own runtime options for custom activities. It is available for custom activities that run in a separate process.</td>
</tr>
</tbody>
</table>

The Process Server creates a pool of database connections to be used for making database calls. This pool ensures that a connection to the database is always available when a process execution request made. The pool also makes processes execute faster and allows connections to be reused.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| pfi.dataAccessPool.min                         | * Min. number of database connections in the pool  
  * Default = 0                                                                                   |
| pfi.dataAccessPool.max                         | * Max number of database connections in the pool  
  * Default = 2000                                                                               |
| pfi.dataAccessPool.holdTime                    | * Max length of time, in milliseconds, that an idle connection should remain in the pool when the pool contains more than the number of objects specified in "pfi.dataAccessPool.min"  
  * Default = 120000 (2 minutes)                                                                 |
| pfi.dataAccessPool.maxWaitTime                 | * Maximum time, in milliseconds, to wait for a database connection to become available before timeout occurs  
  * Default = 10000 (10 seconds)                                                                  |
| pfi.dataAccessPool.reuseLimit                  | * Reusing an existing connection can improve performance because time is saved by not having to reestablish a database connection  
  * Parameter specifies the number of times a database connection can be reused  
  * Default = 2000                                                                                |

Thread pools provide improved performance when executing large numbers of process execution requests, because the threads are created ahead of time and are waiting for the requests. Thread pools also provide a way to limit the number of threads used by the Process Server to ensure that resources are managed effectively.

The following properties let you configure the number of processes the server can execute simultaneously.
### JDBC (SQL) connections

Separate connection pools are maintained for each data source, which is a combination of JDBC Driver Name and JDBC Url. This means each database has its own connection pool.

Various configuration options can be specified in the IPA configuration properties to control the pool's behavior:

![SQL Pooling](image)

---

**JDBC connection configuration options**

Various configuration options can be specified in the IPA configuration properties to control the pool's behavior:

<table>
<thead>
<tr>
<th>Property</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pfi.pooling.jdbcUsePooledConnections</td>
<td>false</td>
<td>Enables or disables JDBC connection pooling</td>
</tr>
<tr>
<td>pfi.pooling.jdbcMaxActiveConnections</td>
<td>5</td>
<td>- Max number of active connections for a user</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- A negative number means no limit</td>
</tr>
<tr>
<td>Property</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| pfi.pooling.jdbcMaxIdleConnections | 2 | ● Max number of idle connections for a user  
● A negative number means no limit  
● The pool will have at least this many connections for the user  
● 0 means all returned connections are closed; no pooling |
| pfi.pooling.jdbcMaxConnectionWaitSec | 300 | Time (seconds) to wait for an available connection, if pool is full for the user are as follows:  
● 0= immediate failure  
● -1= indefinite wait  
● >0= wait for specific time, then fail |
| pfi.pooling.jdbcTimeBetweenEvictionRunsSec | -1 | ● How often the eviction process is run  
● A -1 turns off the eviction process  
● When enabled, connections idle for 30 minutes are closed  
● Eviction process should be setup to run infrequently |
| pfi.pooling.jdbcEnableConnectionValidation | false | ● Enables or disables the verification of connections |
| pfi.pooling.jdbcValidationQuery | (none) | ● Defines the SQL statement that is used to verify a connection  
● Each JDBC Driver can have its own validation SQL statement  
● Format of this property is: <JDBC Driver>=<<SQL statement>;<JDBC Driver>=<<SQL statement> i.e.-org.gjt.mm.mysql.Driver=select 1 |

**Connection validation**

When connection validation is enabled, unused connections in the pool are first validated before being given out. An invalid connection is closed and a new connection created before it is handed out.

The validation query has to be a SQL statement that returns one or more rows if the JDBC connection is valid. The following are pre-defined validation queries set up for the common DBs:

<table>
<thead>
<tr>
<th>Database</th>
<th>Validation SQL Statement</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB2</td>
<td>select 1 from sysibm.sysdummy1</td>
</tr>
<tr>
<td>Oracle</td>
<td>select 1 from dual</td>
</tr>
<tr>
<td>SQL Server</td>
<td>select 1</td>
</tr>
<tr>
<td>My SQL</td>
<td>select 1</td>
</tr>
<tr>
<td>&lt;default&gt;</td>
<td>select 1</td>
</tr>
</tbody>
</table>

The pre-defined validation query can be overridden by the pfi.pooling.jdbcValidationQuery property.
**Class path**

You need to define the location class path. This is the location that where the JDBC drivers should be loaded to make JDBC connections.

Configuration properties for JDBC Class Path can be access within the Grid Manager > Advanced > Configuration > Configuration Manager > Grid Properties.

**Grid configuration - misc. module properties**

The following properties are for specifying .jar files to be added to the classpath and data areas to be used for process execution.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>grid.app.classpath</td>
<td>Copy any external .jar files to this location (for example, JDBC that you want to use in a process: $LACFGDIR/LPS/jars</td>
</tr>
</tbody>
</table>
IPA with Infor Lawson System Foundation (LSF)

If you have IPA and Lawson System Foundation (LSF), you can bind them to use just IPA. If bound, then all LSF information is managed by IPA. Triggered events should be managed in the data area where the trigger would occur—i.e., HCM versus APPS10.

Binding LSF and IPA

To do this, run this command: `pfserv config ips`. You are prompted to answer questions and define the information, as shown in the following table:

<table>
<thead>
<tr>
<th>Prompt</th>
<th>Possible responses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Manager port number</td>
<td>Possible responses are “Y” or “N.”</td>
</tr>
<tr>
<td>ProcessFlow RMI Server port number</td>
<td>If your response is “Y” you must provide the additional information below:</td>
</tr>
<tr>
<td>Is LPS enabled?</td>
<td>• LPS grid host name</td>
</tr>
<tr>
<td></td>
<td>• LPS grid port</td>
</tr>
<tr>
<td></td>
<td>• LPS user</td>
</tr>
<tr>
<td></td>
<td>• LPS password</td>
</tr>
<tr>
<td></td>
<td>• LPS default data area</td>
</tr>
</tbody>
</table>

| Disable PFI Inbasket?                       | Possible responses are “Y” or “N.”                     |
| Disable LPS Tracking?                       |                                                        |
| Disable LPS Admin?                          |                                                        |
Start or stop IPA

The table below describes the two ways to stop and start IPA:

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use the grid console</strong></td>
<td>• Landmark environment</td>
</tr>
<tr>
<td></td>
<td>• IPA</td>
</tr>
<tr>
<td><strong>Use the command line</strong></td>
<td>managegrid – options:</td>
</tr>
<tr>
<td></td>
<td>• list [-a]</td>
</tr>
<tr>
<td></td>
<td>o List grid nodes and their status start bindingName1</td>
</tr>
<tr>
<td></td>
<td>o Start a specific grid node start [-a] exception1</td>
</tr>
<tr>
<td></td>
<td>o Start grid nodes with exception of any listed after the –a option stop bindingName1</td>
</tr>
<tr>
<td></td>
<td>o Stop the specified grid node Stop [-a]exception1</td>
</tr>
<tr>
<td></td>
<td>o Stop the grid nodes with exception of any listed after the –a option</td>
</tr>
</tbody>
</table>
Check your understanding

Why would an administrator want to revert back to a previous version of a process in Process Server Administrator? Select all that apply.

- a) The new process contains errors.
- b) The workunits are routed to the wrong resource/task.
- c) You cannot revert back to a previous version.

Which of the following sections are included in the Process Server Administrator security administration? Select all that apply.

- a) Properties
- b) Security management
- c) Remove analytics data

This IPA property is set to look for work escalation and reminders messages for Inbasket.

- a) pfi.workunit.pollingFrequency
- b) pfi.escalator.pollingFrequency
- c) pfi.extraEncoding

Which of the following describes the Landmark Grid? Select all that apply.

- a) It is a Java application which manages Java Virtual Machines (JVMs) which provided landmark functionality.
- b) It can be used to start and stop IPA.
- c) It requires knowledge of Lawson Pattern Language (LPL).

Which command would you run to bind IPA with Lawson System Foundation in order to ensure all LSF information is managed by IPA?

- a) managegrid
- b) pfserv config lps
- c) stoplaw
Course summary

Estimated time
30 minutes

Course objectives
Now that you have completed this course, you should be able to:

- Describe IPA and its architecture.
- Describe the purpose of each activity node.
- Describe the Infor Process Designer functionality.
- Explain how to create and run a basic email process.
- Explain how to build processes using various activity nodes.
- Describe how to run processes.
- Describe how to configure IPA users.
- Explain how to enable services.
- Describe how to create configuration sets.
- Explain how to administer Infor Process Automation.

Topics
- Course review
Appendices

Appendix list

This section contains the following appendices:

- **Appendix A: Understanding dates**
  - Build a process using date formats

- **Appendix B: Data Iterator for Infor Landmark transaction**
  - Parse a CSV file to update an actor’s role in Landmark

- **Appendix C: Data Iterator for Infor Lawson resource transaction example**
  - Parse a CSV file to update Infor Lawson Resources group in LDAP

- **Appendix D: Data Iterator for Infor Lawson transactions**
  - Parse a CSV file to create a vendor in Infor Lawson Accounts Payable system

- **Appendix E: Custom Activities**
  - Use a custom activity to convert ASCII to EBCDIC

- **Appendix F: Infor Cloverleaf**

- **Appendix G: Java Messaging Services (JMS)**
Appendix A: Understanding dates

Various date formats are used in Process Automation. The available formats currently defined within date JavaScript functions in Process Automation are shown in the table below:

<table>
<thead>
<tr>
<th>Title</th>
<th>Abbr.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transaction</td>
<td>AGS</td>
<td>ccyymmdd i.e. 20120525</td>
</tr>
<tr>
<td>Data service</td>
<td>DME</td>
<td>mm/dd/yyyy i.e. 05/25/2012</td>
</tr>
<tr>
<td>JavaScript</td>
<td>JS</td>
<td>May 25 2004 (plus time information)</td>
</tr>
<tr>
<td>Landmark Transaction</td>
<td>n/a</td>
<td>ccyymmdd or mm/dd/yyyy</td>
</tr>
<tr>
<td>Current locate var date</td>
<td>n/a</td>
<td>new Date(year, month, day, hour, minute, second, fraction)</td>
</tr>
<tr>
<td>Coordinated Universal Time</td>
<td>UTC</td>
<td>date - var date = new Date(Date.UTC [year, month, day, hour, minute, second, fraction])</td>
</tr>
</tbody>
</table>

For current local and UTC date:

- Year should always be four digits
- Month is 0-11
- Day is 1-31
- Hour is 0-23
- Minute is 0-59
- Second is 0-59
- Fraction is in milliseconds, 0-999

Scenario

In this scenario, you will modify an existing Infor Lawson query process to find records for a specific date. For this process, you will use the following:

- Variable using Expression Builder

Instructor setup: To test pulling Purchase Order for yesterday’s date:

- Access Infor Lawson for Infor Ming.le as lawson@gdeinfor2.com
- Access PO20
- Inquire on Company 4321 and PO 6106. Note: Instructors will change the PO date, Delivery Date and Dlvr date (on the line) to yesterday’s date and the PO number from 6106 to 12345 and add the record.

- Access the Lawson Query process you previously created.
- Save the process as LawsonQuerywDate.
- Create a variable to define yesterday’s date.
  
  Note: Your assigned number is identified as xx in this scenario.

- From the Start Node create the following variable:
- Variable Name: Yesterday
- Variable Type: Date
- Select and add function: Date = AddDay(var1, NbrDays)
- Edit the Variable Value – AddDay (today(), -1)

Create a variable to reformat yesterday’s date into a **Lawson Query (DME)** format.

- From the **Start Node** create the following variable:
  - Variable Name: YesterdayDME
  - Variable Type: String
  - Select and add function – String = getDateDME(var1)
  - Edit the Variable value – getDateDME(Yesterday)

- **Add Date to Query.**
  - Modify your existing Lawson Query to include the PO Date as criteria.
  - Note: replace <!appProdline> with APPS10 to get back to your original search fields and criteria.
  - Put in the variable <!YesterdayDME> in the PO Date criteria.
- Save your process and run with No connectors.
- Access Mail Enable on the desktop and login as user <xx>, and password Tr@in123.
Appendix B: Data iterator – Landmark transaction example

The diagram below is a graphic representation of the process design to update an actor’s role in Landmark:

![Diagram of the process design to update an actor’s role in Landmark](image)

**Process to Update Actor’s Roles in Landmark diagram**

**Scenario**

In this scenario, you will use a csv file and parse this file to update actor’s roles in Landmark. For this process, you will use the following nodes:
- Data Iterator
- Landmark Transaction
- **Note**: Your assigned number is identified as xx in this scenario.

**Part 1: Define Prerequisites**

- Find the DataIteratorExtras folder within the IPAAttendees folder.
- Right-click Role.csv file.
- Select Edit with Notepad++.
- Replace the xx with your assigned number.
- Save the file as Role<xx>.csv. **Note**: Your assigned number is identified as xx.
- Save this to the \lmark10.gdeinfor2.com\LMRK10ClassFiles \xx drive.
- Define Data Iterator node with the following information:
  - ID = DI1
  - Input Method = File
  - Input File= \lmark10.gdeinfor2.com\LMRK10ClassFiles\xx\Role<xx>.csv
  - Parse by = Line
  - On Error = Stop Process
- Define another Data Iterator node with the following information:
  - ID = DI2
  - Input Method = Data
  - Input Data= <!DI1_outputData>
  - Parse by = Delimiter
  -Delimiter String = ,
  - Accumulate Output Variables = Selected
  - On Error = Stop Process
- Define the Landmark Transaction node with the following information:
  - ID = ROLE
  - Name = ActorAddRole
  - Build the following:
- Data Area = gen
- Module = security
- Object name = ActorRole
- Action = AssignExistingRoleToActor
- Action Type = CreateUpdateDelete
- Actor = <!DI2_outputData1>
- ActorRole.Role = <!DI2_outputData2>
  - On Error = Stop Process
- Define the Email node with the following information:
  - To: user<xx>@edu.com
  - From: ResourceUpdate@infor.com
  - Body = Resource: <!DI2_outputData1>
  - Message: <!RU_returnMessage>
  - Select Stop Process for the On Error.
- Save as DILmkRole and Run with No input data.
- Access the GEN data area and User Management > Actor Management.
- Find your user and open the record.
- Review the Roles tab and verify if your user has received the two new Roles.
Appendix C: Data iterator – Infor Lawson Resource Transaction example

The diagram below is a graphic representation of the process design we will use:

![Update Lawson Resource Group Process diagram](image)

**Scenario**

In this scenario, you will use a CSV file and parse this file to update Resource's groups in LDAP.

For this process, you will use the following nodes:
- Data Iterator
- Lawson Resource Transaction
- **Note:** Your assigned number is identified as xx in this scenario.

- In the DataIteratorExtra folder within the IPAAttendees folder, access the Group.csv file and edit with Notepad++ and replace the xx with your assigned number.
- Save the files as Group<xx>.csv and save to \lmark10.gdeinfor2.com\LMRK10ClassFiles \xx drive
- Log in to the designer and connect to the LSF10apps10 data area.
- Define the **Data Iterator 1** node with the following information:
  - ID = DI1
  - Input Method = File
  - Input File= \lmark10.gdeinfor2.com\LMRK10ClassFiles\xx\Groupxx.csv
  - Parse by = Line
  - On Error = Stop Process
- Define the **Data Iterator 2** node with the following information:
  - ID = DI2
  - Input Method = Data
  - Input Data= <!DI1_outputData>
  - Parse by = Delimited String
  - Delimited String = ,
  - Accumulate Variables = Selected
  - On Error = Stop Process
- Define the **Resource Update** node with the following information:
  - ID = RU
  - Name = ResourceAddGroup
  - Action = Update
  - Build
- RM ID=<!DI2_outputData1>
- RM Objects= People
- RM Attribute: Group
- Action = Append
- Value: <!DI2_outputData2>
  - On Error = Stop Process
- Define the **Email** node with the following information:
  - **To:** user<xx>@edu.com
  - **From:** ResourceUpdate@infor.com
  - **Body = Resource:** <!DI2_outputData1>
  - **Message:** <!RU_returnMessage>
  - **On Error:** Stop Process
- Save as DILawsonGroup and Run with No input data.
- Review the User Maintenance in Security Administrator to verify if your user has received the two new Groups.
Appendix D: Data iterator – Infor Lawson example

The diagram below is a graphic representation of the process design we will use:

![Diagram of process design]

Create a vendor diagram

Scenario

In this scenario, you will build a process that will retrieve data from a csv file. Parse the file and data, update the Lawson AP application, collect the information and write the results to a file.

For this process, you will use the following nodes:

- Data Iterator
- Lawson Transaction

Note: Your assigned number is identified as xx in this scenario.

Part 1: Open the Vendor.csv file

- In the DataIteratorExtra folder within the IPAAttendees folder, open the Vendor.csv file using Edit with Notepad++ and replace the xx with your assigned number.
- Save the files as Vendor<xx>.csv
- Save the files to \lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx drive.

Part 2: Access the LPD Designer and create a new process

- Define the Start Variable with the following information:
  - Create variable:
    - String vReturn="\r\n"
- Define the first Data Iterator node with the following information:
  - ID = DA1
  - Input Method = File
  - Input File= \lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\Vendorxx.csv
  - Parse by = Line
  - On Error = Stop Process
- Define the second Data Iterator node with the following information:
  - ID = DA2
  - Input Method = Data
  - Input Data= <!DA1_outputData>
  - Parse by = Delimited String
  - Delimited String = ,
  - Accumulate Variables = Selected
  - On Error = Stop Process
- Define the Lawson Transaction node with the following information:
- ID = AP10Add
- Name = AP10AddVendor
- Build:
  - Method = Add
  - VEN-VENDOR-GROUP="<!DA2_outputData1>
  - VEN-VENDOR="<!DA2_outputData2>
  - VEN-VENDOR-VNAME="<!DA2_outputData3>
  - VEN-VEN-CLASS="<!DA2_outputData4>
  - VDR-ADDR1="<!DA2_outputData5>
  - VDR-CITY-ADDR5="<!DA2_outputData6>
  - VDR-STATE-PROV="<!DA2_outputData7>
  - VDR-POSTAL-CODE="<!DA2_outputData8>
- On Error = Stop Process

Define the Message Builder node with the following information:
- Name = Capture Message
- Variable name = AP10
- Message:
  - <!vReturn>
  - Vendor: <!DA2_outputData2> - <!DA2_outputData3>
  - <!AP10Add_RETURN_MSG>

Define the File Access node with the following information:
- Configuration: Main
- Function = Append to File
- Output File = \lmrk10.gdeinfor2.com\LMRK10ClassFiles\xx\Vendor.log
- Input Data = <!AP10>
- Save as DIS3Vendor.xml and Run with No input data.
- Check C\ directory for Vendor.log.
- Log in to the Infor Ming.le and access Lawson.
- Type AP10 in the search box.
- Select CGI vendor group.
- Click the vendor list.
- Review the list for your newly added vendors.
Appendix E: Custom activities

About custom activities
Written in the Java programming language, custom activities are created to perform functions current activity nodes can’t do. For example, a custom activity can integrate or interface with internal or external third-party systems.

Some custom activities delivered with IPA include:
- Encoding
- Assert
- Component Test
- Flow Runner
- Java Beans
- Input and output created through Java Bean properties and methods

Configuring custom activities
Custom activities information must be configured within the Grid Manager under the LPA section. The table below lists the parameters that must be defined:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pfi.customActivity.beans</td>
<td>Class names for .jar files needed for custom activities. List them in this property separated by commas or semicolons. LPS must be stopped and restarted for these activities to be available.</td>
</tr>
<tr>
<td>pfi.customActivity.beansToRunSeparate</td>
<td>This true/false flag indicates that custom adapters run in their own process, separate from Process Server (Recommended to run in a separate process).</td>
</tr>
<tr>
<td>pfi.customActivity.beansToRunSeparateOptions</td>
<td>Specify your own runtime options for custom activities. Available for custom activities that run in a separate process.</td>
</tr>
</tbody>
</table>

...
The following is an example of using the Encoding Activity available in the Custom Activity node.

Custom Activity: Encoding diagram

Scenario: Use a custom activity to convert ASCII to EBCDIC

In this scenario, you will practice how to use a custom activity to convert from ASCII to EBCDIC and back and send output in an email.

Note: Your assigned number is identified as xx in this scenario.

Part 1: Open an existing process file
- Open the Infor Process Designer.
- Select File > Open Infor Process File.
- Find the IPAInstructorProcesses folder.
- Open AppendixE_CustomActivity.lpd file.

Part 2: Select activities identifying the encoding activity.
- Select the first CustomActivity node and validate the action is set to converting a StringToEBCDICBytes. Hint: Select the CustomActivity node in Process Editor and look at the Action field in the Properties tab to validate the action.
- Verify the Input table in the Property tab is defined as "ABC."
- Select the first Email node.
- Review the body of the email and validate that the first Email node has this defined:
  - Input = ABC
  - Output = <!CA1_output>
- Select the second CustomActivity node and validate the action is set to converting an EBCDICBytes toString.
- Verify the input of the second CustomActivity node is the output from the first CustomActivity node.
- Select the second Email node.
- Review the body of the email and validate that the email node is set to include the output from the second CustomActivity node (<!CA2_output>).
- Select Process > Run.
- Select the No input data radio button.
- Click OK.

Part 3: Test the process
- Double-click the Mail Enable icon on the desktop.
- Log in as user<xx> and password Tr@in123
- Validate that you received the two emails showing the results:
  - first email is string (ABC) to EBCDICBytes
  - second email is EBCDICBytes to a string
Custom Activity node 1: convertStringToEBCDICBytes

Used to convert identified text from ASCII to EBCDIC.

```
Activity started: CA1 (Run Id: 5)
CA1_charEncoding = Cp1047
CA1_input = "ABC"
CA1_output = [EBCDIC code for "ABC"]
CA1_errorCode = 0
CA1_informationCode = 0
CA1_returnMessage = Custom Activity CA1: Executed successfully.
```

Custom Activity node 2: convertEBCDICBytesToString

- Converts ASCII string to anything, as specified in the character encoding
- Character encoding of "CP1047" = EBCDIC
CA2_charEncoding = Cp1047
CA2_input = "こんにちは"
CA2_output = "ABC" ← ASCII to EBCDIC"
CA2_errorCode = 0
CA2_informationCode = 0
CA2_returnMessage = Custom activity CA2: Executed successfully.

Custom code for EBCDIC
Appendix F: Infor Cloverleaf

Infor Cloverleaf activity node

Infor Cloverleaf is a messaging system that is primarily used among health care institutions. The Infor Cloverleaf activity node functions to allow one-way communication from Infor Lawson to an Infor Cloverleaf-compatible system.

Note: The Infor Cloverleaf activity node is grouped with Integration nodes on the Process Designer interface.

Configuring an Infor Cloverleaf connection

In order to use the Infor Cloverleaf activity node, you must first configure a connection so it can be used with IPA. The Cloverleaf Interface connection information can be defined within System Configuration in IPA. The following table lists the key configuration properties:

<table>
<thead>
<tr>
<th>Field/check box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration name</td>
<td>In this field type the configuration name that contains the Infor Cloverleaf connection that you want to use for this activity node.</td>
</tr>
<tr>
<td>Connection name</td>
<td>In this field type the connection name that this node should use.</td>
</tr>
<tr>
<td>Message encoding</td>
<td>In this field select a value from the drop-down menu. Options include:</td>
</tr>
<tr>
<td></td>
<td>- USASCII</td>
</tr>
<tr>
<td></td>
<td>- UTF8</td>
</tr>
<tr>
<td></td>
<td>- UTF16BE</td>
</tr>
<tr>
<td></td>
<td>- UT16LE</td>
</tr>
<tr>
<td>Use byte order mark</td>
<td>Select this checkbox to send a byte order mark at the beginning of the data flag that tells which byte is the most significant.</td>
</tr>
<tr>
<td>Host</td>
<td>In this field type the Cloverleaf IP address.</td>
</tr>
<tr>
<td>Port</td>
<td>In this field type the port number used.</td>
</tr>
<tr>
<td>Socket timeout</td>
<td>In this field type the time in milliseconds that the system should wait for a return message (acknowledgement) before issuing a time out.</td>
</tr>
</tbody>
</table>

Setting Infor Cloverleaf properties

When using the Infor Cloverleaf activity node as part of a process, you must set properties on the node properties dialog box.

The following table shows the properties to set when using the Infor Cloverleaf activity node:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration name</td>
<td>In this field type the configuration name that contains the Infor Cloverleaf connection that you want to use for this activity node.</td>
</tr>
<tr>
<td>Connection name</td>
<td>In this field type a connection name that this node should use. Note: This field is used when multiple connections are available.</td>
</tr>
<tr>
<td>Message</td>
<td>In this field type the actual message to be sent.</td>
</tr>
</tbody>
</table>
Appendix G: Java Messaging Service (JMS)

IPA works with JMS, a J2EE-compliant API for sending and receiving messages between two or more clients.

There are two processes associated with JMS. The process used is dependent on whether the message is inbound or outbound:

- **Outbound** – When sending messages, the process includes the JMS activity node
- **Inbound** – When receiving messages, the process is triggered through Channel administration.

In the remainder of this lesson, we will look in detail at inbound and outbound messages.

**JMS inbound messages**

As we learned, JMS inbound messages are handled through Channel Administration. When a message is received it triggers a process.

JMS includes the following functionality:

- Durable subscriptions are not supported.
- No provision for grouping of messages.
- Text and map messages are supported.
- Message header and property values are assigned process variables.

**JMS channel parameters**

The following table lists and describes the parameters available for defining a JMS channel:

<table>
<thead>
<tr>
<th>Parameter/check box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Channel name</strong></td>
<td>In this field type the name of the configuration associated with this connection. You can have one JMS connection per connection set.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If you have selected to edit this connection from within a configuration set, the name of the set is displayed and is not editable.</td>
</tr>
<tr>
<td><strong>Enabled</strong></td>
<td>When this check box is selected, the channel is enabled meaning that it is available to activate. This activation could occur either manually or automatically when IPA is started. If this check box is cleared, none of its receivers can be activated.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The channel is enabled by default.</td>
</tr>
<tr>
<td>Description</td>
<td>In this field type a short description of the channel in this field.</td>
</tr>
<tr>
<td><strong>JNDI initial factory</strong></td>
<td>In this field type the fully qualified class name of the factory class that creates an initial context.</td>
</tr>
<tr>
<td><strong>JNDI provider URL</strong></td>
<td>In this field type the URL string that specifies the service provider.</td>
</tr>
<tr>
<td><strong>JNDI connection factory name</strong></td>
<td>In this field type the location name used to create a connection to the JMS provider.</td>
</tr>
<tr>
<td><strong>JNDI user</strong></td>
<td>In this field type a JNDI user name in this field.</td>
</tr>
<tr>
<td>Parameter/check box</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>JNDI password</td>
<td>In this field type the password associated with the JNDI user.</td>
</tr>
<tr>
<td>Context property file</td>
<td>In this field type the name and location of the file that contains properties about the connection. You can use this file to specify the properties available on this dialog. You can also use it to specify other JNDI properties that might available from the provider you use. If the properties file conflicts with information on the JMS connection dialog box, IPA gives precedence to setting on the dialog box.</td>
</tr>
<tr>
<td>JMS user</td>
<td>In this field type a JMS user name in this field.</td>
</tr>
<tr>
<td>JMS password</td>
<td>In this field type the password associated with the JMS user.</td>
</tr>
</tbody>
</table>

**JMS receiver**

The following table lists and describes the key parameters available for defining a JMS receiver:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel name</td>
<td>In this field type the name of the configuration associated with this receiver. <strong>Note:</strong> If you have selected to edit this connection from within a configuration set, the name of the set is displayed and is not editable.</td>
</tr>
<tr>
<td>Receiver</td>
<td>In this field type a name for the receiver.</td>
</tr>
<tr>
<td>Description</td>
<td>In this field type a short description of the receiver in this field.</td>
</tr>
<tr>
<td>Destination</td>
<td>In this field type the queue or topic as defined by the JMS protocol and the name of the location where the message is to be delivered.</td>
</tr>
<tr>
<td>Process</td>
<td>In this field type the processes to be initiated.</td>
</tr>
</tbody>
</table>
| Acknowledgement mode | In this field select a value from the drop-down list. Options include:
  * Auto acknowledge – More than one workunit can be created for the same message
  * Client acknowledge – Only one workunit can be created from the same message |

**JMS outbound messages**

JMS activity node is used to send outbound messages from a process. **Note:** In its current implementation, the JMS activity node supports only sending, not receiving.

The JMS activity node can:

- Override the configuration setup.
- Have either secured or non-secured settings

The parameters available to set up the activity mode connection are similar to the JMS receiver set up with these exceptions:
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Correlation ID</td>
<td>In this field type the message identifier to be correlated to a previously-sent message. <strong>Note:</strong> This is an optional parameter.</td>
</tr>
<tr>
<td>Acknowledge mode</td>
<td>In this field type a name for the receiver.</td>
</tr>
<tr>
<td>Description</td>
<td>In this field type a short description of the receiver in this field.</td>
</tr>
<tr>
<td>Destination</td>
<td>In this field type the queue or topic as defined by the JMS protocol and the name of the location where the message is to be delivered.</td>
</tr>
<tr>
<td>Process</td>
<td>In this field type the processes to be initiated.</td>
</tr>
</tbody>
</table>
| Acknowledge mode | In this field select a value from the drop-down list. Options include:  
  - Auto – Sends as soon as the message is received  
  - Dups_OK – Permits a duplicate message to be sent to the same destination  
  - Client – Sent at a point determined by the client.                                                                                           |
| Delivery mode    | In this field select a value from the drop-down list. Options include:  
  - Persistent – Message should be delivered one time only  
  - Non-persistent – Message should be delivered at most one time                                                                                   |